summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-30 18:55:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-30 18:55:09 +0000
commitaecfe562fe49d3f54dc9e2d5a01be49a7692a519 (patch)
tree509c4ab81155aff99c41beb0ae5547da2d9ea41c /dev-python/pygsl/pygsl-0.9.4.ebuild
parentAdding snapshot from current 2.5 'gruntster' branch, which works with (diff)
downloadhistorical-aecfe562fe49d3f54dc9e2d5a01be49a7692a519.tar.gz
historical-aecfe562fe49d3f54dc9e2d5a01be49a7692a519.tar.bz2
historical-aecfe562fe49d3f54dc9e2d5a01be49a7692a519.zip
Added a patch to compile with gsl >= 1.13, thanks Kacper Kowalik, closing bug #286605
Package-Manager: portage-2.2_rc42/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pygsl/pygsl-0.9.4.ebuild')
-rw-r--r--dev-python/pygsl/pygsl-0.9.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/pygsl/pygsl-0.9.4.ebuild b/dev-python/pygsl/pygsl-0.9.4.ebuild
index 9ad72c56588c..52df5f6bf33f 100644
--- a/dev-python/pygsl/pygsl-0.9.4.ebuild
+++ b/dev-python/pygsl/pygsl-0.9.4.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.4.ebuild,v 1.2 2009/04/06 14:39:59 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.4.ebuild,v 1.3 2009/09/30 18:55:08 bicatali Exp $
+EAPI=2
inherit distutils
DESCRIPTION="A Python interface for the GNU scientific library (gsl)."
@@ -17,6 +18,10 @@ DEPEND="sci-libs/gsl
dev-python/numpy"
RDEPEND="${DEPEND}"
+src_prepare() {
+ has_version '>=sci-libs/gsl-1.13' && epatch "${FILESDIR}"/${P}-obsolete-units.patch
+}
+
src_test() {
cd "${S}/tests"
PYTHONPATH=$(ls -d ../build/lib*) "${python}" run_test.py || die "tests failed"