summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-03 21:05:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-03 21:05:58 +0000
commitbd1967161b8f43de2a9432ca80289eb4de1ba32e (patch)
tree506ee590f3b3759de1170e106034fbf2cd9b0d92 /dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
parentnet-p2p/pandodl masked for removal in 30 days (diff)
downloadhistorical-bd1967161b8f43de2a9432ca80289eb4de1ba32e.tar.gz
historical-bd1967161b8f43de2a9432ca80289eb4de1ba32e.tar.bz2
historical-bd1967161b8f43de2a9432ca80289eb4de1ba32e.zip
Initial import. Ebuild by Thomas R. (TRauMa). Closes #161853.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyconstruct/pyconstruct-2.0.0.ebuild')
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.0.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild b/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
new file mode 100644
index 000000000000..d5ac20a7be44
--- /dev/null
+++ b/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild,v 1.1 2009/02/03 21:05:58 patrick Exp $
+
+inherit python
+
+DESCRIPTION="Simple parsing of binary (and textual) data with Python"
+HOMEPAGE="http://construct.wikispaces.com/"
+
+# TODO
+# tests are quite large, upstream provides extra dist with them
+#SRC_URI="
+# !test? ( mirror://sourceforge/pyconstruct/construct-${PV}-distro.zip )
+# test? ( mirror://sourceforge/pyconstruct/construct-${PV}-full.zip )
+#"
+# Upstream labels it as 2.00
+SRC_URI="mirror://sourceforge/pyconstruct/construct-2.00-distro.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+#IUSE="test"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/python-2.5"
+
+S="${WORKDIR}/construct"
+
+src_compile() {
+ # Hello World! :-)
+ einfo Nothing to compile
+}
+
+src_install() {
+ # upstream "doesn't believe in setups"
+ python_version
+ dodir /usr/lib/python${PYVER}/site-packages
+ cp -ra "${S}" "${D}"/usr/lib/python${PYVER}/site-packages || die
+}
+
+#src_test() {
+# echo TODO :-/
+#}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize "${ROOT}"usr/lib/python${PYVER}/site-packages/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}