summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-09 14:37:23 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-09 14:37:23 +0000
commit6fb6c2695e1e036ca5c3e593378cd6a3b9585b0a (patch)
tree8043ea67c610bad394bb880b00423b646796eb7d /dev-python/orbit-python
parent*** empty log message *** (diff)
downloadhistorical-6fb6c2695e1e036ca5c3e593378cd6a3b9585b0a.tar.gz
historical-6fb6c2695e1e036ca5c3e593378cd6a3b9585b0a.tar.bz2
historical-6fb6c2695e1e036ca5c3e593378cd6a3b9585b0a.zip
updated fixes after move to /usr
Diffstat (limited to 'dev-python/orbit-python')
-rw-r--r--dev-python/orbit-python/orbit-python-0.3.0-r1.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/dev-python/orbit-python/orbit-python-0.3.0-r1.ebuild b/dev-python/orbit-python/orbit-python-0.3.0-r1.ebuild
index ed71456c04bf..c65d073e05bb 100644
--- a/dev-python/orbit-python/orbit-python-0.3.0-r1.ebuild
+++ b/dev-python/orbit-python/orbit-python-0.3.0-r1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Mikael Hallendal <micke@hallendal.net>
-# $Header: /var/cvsroot/gentoo-x86/dev-python/orbit-python/orbit-python-0.3.0-r1.ebuild,v 1.1 2001/10/06 11:24:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/orbit-python/orbit-python-0.3.0-r1.ebuild,v 1.2 2001/10/09 14:37:23 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="ORBit bindings for Python"
-SRC_URI="http://orbit-python.sault.org/files/${A}"
+SRC_URI="http://orbit-python.sault.org/files/${P}.tar.gz"
HOMEPAGE="http://orbit-python.sault.org/"
DEPEND=">=dev-libs/glib-1.2.10
@@ -14,17 +13,19 @@ DEPEND=">=dev-libs/glib-1.2.10
virtual/python"
src_compile() {
- PYTHON="/usr/bin/python" try ./configure --host=${CHOST} --prefix=/usr \
- --with-libIDL-prefix=/usr --with-orbit-prefix=/usr
- try make
+ CFLAGS="$CFLAGS `gnome-config --cflags libIDL`"
+
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --with-libIDL-prefix=/usr \
+ --with-orbit-prefix=/usr
+ assert
+
+ make || die
}
src_install() {
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING ChangeLog NEWS
- dodoc README TODO
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
}
-
-
-
-