summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2012-12-28 05:35:05 +0000
committerMatt Thode <prometheanfire@gentoo.org>2012-12-28 05:35:05 +0000
commit2818d695cb06c2e271ca9658b6011212e47c6200 (patch)
tree67b24c74b1c026fd2dcb34472592041bfde4f84f /dev-python/keyring/keyring-1.0.ebuild
parentloosen base dep in monad-control for ghc >= 7.7 (diff)
downloadhistorical-2818d695cb06c2e271ca9658b6011212e47c6200.tar.gz
historical-2818d695cb06c2e271ca9658b6011212e47c6200.tar.bz2
historical-2818d695cb06c2e271ca9658b6011212e47c6200.zip
updated license and fixed bug 448730
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 Manifest-Sign-Key: 0x2471EB3E40AC5AC3
Diffstat (limited to 'dev-python/keyring/keyring-1.0.ebuild')
-rw-r--r--dev-python/keyring/keyring-1.0.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/keyring/keyring-1.0.ebuild b/dev-python/keyring/keyring-1.0.ebuild
index aad8d7af0f10..fc0664696f0b 100644
--- a/dev-python/keyring/keyring-1.0.ebuild
+++ b/dev-python/keyring/keyring-1.0.ebuild
@@ -1,25 +1,39 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-1.0.ebuild,v 1.1 2012/12/19 20:47:59 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/keyring/keyring-1.0.ebuild,v 1.2 2012/12/28 05:34:57 prometheanfire Exp $
# Ebuild generated by g-pypi 0.2.2 (rev. 214)
EAPI=4
-inherit distutils
+inherit distutils eutils
MY_PN=${PN#python-}
S="${WORKDIR}/${MY_PN}-${PV}"
DESCRIPTION="Provides a easy way to access the system keyring service from
python."
-HOMEPAGE="http://pypi.python.org/pypi/keyring"
+HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
SRC_URI="mirror://pypi/k/${MY_PN}/${MY_PN}-${PV}.zip"
-LICENSE="BSD-2"
+LICENSE="PSF-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE=""
-DEPEND="dev-python/setuptools"
+IUSE="test"
+DEPEND="dev-python/setuptools
+ test? ( dev-python/pytest
+ dev-python/pytest-runner
+ dev-python/unittest2 )"
RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}/setup-1.0.patch"
+}
+
+src_test() {
+ PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_util.py
+ PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_backend.py
+ PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_core.py
+ PYTHONPATH="build/lib" "$(PYTHON)" keyring/tests/test_cli.py
+}
+
src_install() {
distutils_src_install
}