summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-03 19:45:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-03 19:45:28 +0000
commit2408624522e58fc154c9e426d3fe252664d2335f (patch)
treed34b548de963fabc8147188aa528cea73930c6db /dev-python/html5lib
parentAdd missing gettext to DEPEND, bug 191669 (diff)
downloadhistorical-2408624522e58fc154c9e426d3fe252664d2335f.tar.gz
historical-2408624522e58fc154c9e426d3fe252664d2335f.tar.bz2
historical-2408624522e58fc154c9e426d3fe252664d2335f.zip
Initial import. Ebuild based on #202456 with minor tweaks. Thanks to Sebastian Wiesner and Priit Laes
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/ChangeLog11
-rw-r--r--dev-python/html5lib/Manifest4
-rw-r--r--dev-python/html5lib/html5lib-0.11.1.ebuild39
-rw-r--r--dev-python/html5lib/metadata.xml5
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/html5lib/ChangeLog b/dev-python/html5lib/ChangeLog
new file mode 100644
index 000000000000..41b799215f7f
--- /dev/null
+++ b/dev-python/html5lib/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/html5lib
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.1 2009/02/03 19:45:28 patrick Exp $
+
+*html5lib-0.11.1 (03 Feb 2009)
+
+ 03 Feb 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +html5lib-0.11.1.ebuild:
+ Initial import. Ebuild based on #202456 with minor tweaks. Thanks to
+ Sebastian Wiesner and Priit Laes
+
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
new file mode 100644
index 000000000000..12ecb4f69c39
--- /dev/null
+++ b/dev-python/html5lib/Manifest
@@ -0,0 +1,4 @@
+DIST html5lib-0.11.1.zip 375892 RMD160 ac00975e5ea8b20606531e631274c1a8985110c9 SHA1 157506319e40f5d973c128e5e2b826cd1bee471e SHA256 e5a26cb5eda1101871ea3a1199de47311f75e72921583d417b44bcff60f8746e
+EBUILD html5lib-0.11.1.ebuild 991 RMD160 a0dfe6109867bc3b668504e01c93d1cc1e909170 SHA1 d35b34f4e6a3815c5f1e402eb14edf9541ee35d2 SHA256 a4396c0de34008763fe2cb121fb51043ae7845af293f74d7370e2f0ff00a88d3
+MISC ChangeLog 443 RMD160 8efb9a7fed860a8ffba26c66f29d2533e35389fb SHA1 ffb8a4cb8294caf51d6a8e1733d1be7d984f8541 SHA256 e49fbc9ead938abb02d54ef49b81f877a9220be6106345df608bd0edb5299a0d
+MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/html5lib/html5lib-0.11.1.ebuild b/dev-python/html5lib/html5lib-0.11.1.ebuild
new file mode 100644
index 000000000000..326158bd9117
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/html5lib-0.11.1.ebuild,v 1.1 2009/02/03 19:45:28 patrick Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.4"
+
+inherit distutils
+
+DESCRIPTION="HTML parser based on the WHAT-WG Web Applications 1.0 HTML5 specification"
+HOMEPAGE="http://code.google.com/p/html5lib/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+# simplejson will be bundled with python 2.6
+RDEPEND="
+ test? ( dev-python/simplejson )"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6_rc5
+ dev-lang/python[xml]"
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ $(find examples -name '*.pyc' -exec rm -rf {} \;)
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "Failed to install examples"
+ fi
+}
+
+src_test() {
+ distutils_python_version
+ "${python}" setup.py test || die "tests failed"
+}
diff --git a/dev-python/html5lib/metadata.xml b/dev-python/html5lib/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/html5lib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>