summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-02-12 11:17:08 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-02-12 11:17:08 +0000
commit2c36e21af00c4620e635ac86f9584314b208e270 (patch)
tree79b195578d82b316b8d87f9dd385520597f7e5e4 /dev-python/cgkit
parentremove libglade, updated fixed version in tree (diff)
downloadhistorical-2c36e21af00c4620e635ac86f9584314b208e270.tar.gz
historical-2c36e21af00c4620e635ac86f9584314b208e270.tar.bz2
historical-2c36e21af00c4620e635ac86f9584314b208e270.zip
Version bump.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-python/cgkit')
-rw-r--r--dev-python/cgkit/ChangeLog9
-rw-r--r--dev-python/cgkit/Manifest16
-rw-r--r--dev-python/cgkit/cgkit-1.1.0.ebuild4
-rw-r--r--dev-python/cgkit/cgkit-1.2.0.ebuild31
-rw-r--r--dev-python/cgkit/files/digest-cgkit-1.2.01
5 files changed, 55 insertions, 6 deletions
diff --git a/dev-python/cgkit/ChangeLog b/dev-python/cgkit/ChangeLog
index f9a7b20b868a..0fbea5bfd174 100644
--- a/dev-python/cgkit/ChangeLog
+++ b/dev-python/cgkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cgkit
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.2 2004/08/03 11:34:41 dholm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.3 2005/02/12 11:17:07 kloeri Exp $
+
+*cgkit-1.2.0 (12 Feb 2005)
+
+ 12 Feb 2005; Bryan Østergaard <kloeri@gentoo.org> +cgkit-1.2.0.ebuild:
+ Version bump.
03 Aug 2004; David Holm <dholm@gentoo.org> cgkit-1.1.0.ebuild:
Added to ~ppc.
diff --git a/dev-python/cgkit/Manifest b/dev-python/cgkit/Manifest
index 38ab7823bb91..f65cd4df9c87 100644
--- a/dev-python/cgkit/Manifest
+++ b/dev-python/cgkit/Manifest
@@ -1,4 +1,16 @@
-MD5 aa34d0bc97adf5e67842f6c0d10d054c ChangeLog 401
-MD5 cad9c5bb949f1ceec8078182d6fe794d cgkit-1.1.0.ebuild 823
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 984fc0471975c73bdeb549fb03999cee metadata.xml 326
+MD5 f9093463dd55946e4e458ac47703ab34 cgkit-1.1.0.ebuild 824
+MD5 16d74d5da3b1e210952e04803853e7f0 ChangeLog 521
+MD5 4cdcf844048e00ddddf8c12068080d54 cgkit-1.2.0.ebuild 826
+MD5 bbefb53083b5476471ae7a80bd19225f files/digest-cgkit-1.2.0 60
MD5 0dc9644564e6fe463b85fb42ed468ad3 files/digest-cgkit-1.1.0 123
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCDeXVugEuf3OQ0akRAlNxAJ0aEuVxP7GP8cHkHvLPfQsfzWaLhQCgoitO
+GycOv+HCdplwyEgTCd288Cs=
+=QcGV
+-----END PGP SIGNATURE-----
diff --git a/dev-python/cgkit/cgkit-1.1.0.ebuild b/dev-python/cgkit/cgkit-1.1.0.ebuild
index 33b927cb22e3..a8c32e969efc 100644
--- a/dev-python/cgkit/cgkit-1.1.0.ebuild
+++ b/dev-python/cgkit/cgkit-1.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-1.1.0.ebuild,v 1.2 2004/08/03 11:34:41 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-1.1.0.ebuild,v 1.3 2005/02/12 11:17:07 kloeri Exp $
inherit distutils
diff --git a/dev-python/cgkit/cgkit-1.2.0.ebuild b/dev-python/cgkit/cgkit-1.2.0.ebuild
new file mode 100644
index 000000000000..5c835d93f689
--- /dev/null
+++ b/dev-python/cgkit/cgkit-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-1.2.0.ebuild,v 1.1 2005/02/12 11:17:07 kloeri Exp $
+
+inherit distutils
+
+DESCRIPTION="Python library for creating 3D images"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+# mirror://sourceforge/${PN}/${P}.doc.zip"
+HOMEPAGE="http://cgkit.sourceforge.net"
+DEPEND="dev-lang/python
+ dev-python/pyrex"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc"
+
+src_install () {
+ distutils_src_install
+ if use doc; then
+ cd ${WORKDIR}
+ dohtml *.html
+ cp -ar pics ${D}/usr/share/doc/${PF}/html/
+ cd ${S}/examples
+ for example in *; do
+ dodir /usr/share/${P}/examples/${example}
+ exeinto /usr/share/${P}/examples/${example}
+ doexe ${example}/*.py
+ done
+ fi
+}
diff --git a/dev-python/cgkit/files/digest-cgkit-1.2.0 b/dev-python/cgkit/files/digest-cgkit-1.2.0
new file mode 100644
index 000000000000..e748dbeb07c0
--- /dev/null
+++ b/dev-python/cgkit/files/digest-cgkit-1.2.0
@@ -0,0 +1 @@
+MD5 0d1e9f5feaf68c24d24addfe35fb046c cgkit-1.2.0.zip 231492