summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-08 18:23:07 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-08 18:23:07 +0000
commit7bb2227e35bc768ec9507fb61451f5352e0ea8b3 (patch)
tree4f2eede3af00d4660c3a93aaf35a7cc02d8c8a97 /dev-python/bicyclerepair
parentinitial ebuild (diff)
downloadhistorical-7bb2227e35bc768ec9507fb61451f5352e0ea8b3.tar.gz
historical-7bb2227e35bc768ec9507fb61451f5352e0ea8b3.tar.bz2
historical-7bb2227e35bc768ec9507fb61451f5352e0ea8b3.zip
new ebuild. #16448.
Diffstat (limited to 'dev-python/bicyclerepair')
-rw-r--r--dev-python/bicyclerepair/ChangeLog9
-rw-r--r--dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild36
-rw-r--r--dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.11
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/bicyclerepair/ChangeLog b/dev-python/bicyclerepair/ChangeLog
new file mode 100644
index 000000000000..3e2c2c924903
--- /dev/null
+++ b/dev-python/bicyclerepair/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/bicyclerepair
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bicyclerepair/ChangeLog,v 1.1 2003/03/08 18:23:07 liquidx Exp $
+
+*bicyclerepair-0.7.1 (08 Mar 2003)
+
+ 08 Mar 2003; Alastair Tse <liquidx@gentoo.org> bicyclerepair-0.7.1.ebuild:
+ initial ebuild. thanks to Lin Zhemin <ljm@ljm.idv.tw> (#16448)
+
diff --git a/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild b/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild
new file mode 100644
index 000000000000..898e5d01c3e4
--- /dev/null
+++ b/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bicyclerepair/bicyclerepair-0.7.1.ebuild,v 1.1 2003/03/08 18:23:07 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="Bicycle Repair Man is the Python Refactoring Browser,"
+HOMEPAGE="http://bicyclerepair.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bicyclerepair/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="virtual/python"
+
+S="${WORKDIR}/${P}"
+
+mydoc="NEWS DESIGN"
+
+src_install() {
+ distutils_src_install
+ rm -f ${D}/usr/bin/bikeemacs.bat
+}
+
+pkg_postinst() {
+ # Enable IDLE integration if Python was compiled with tcltk.
+ PYTHON_VER=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+ config_txt=/usr/lib/python${PYTHON_VER}/tools/idle/config.txt
+ if [ -f "${config_txt}" ]; then
+ if [ -z "`grep BicycleRepairMan_Idle ${config_txt}`" ]; then
+ einfo "Appending BicycleRepairman to IDLE.."
+ echo "[BicycleRepairMan_Idle]" >> ${config_txt}
+ fi
+ fi
+}
diff --git a/dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.1 b/dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.1
new file mode 100644
index 000000000000..703fbf11735b
--- /dev/null
+++ b/dev-python/bicyclerepair/files/digest-bicyclerepair-0.7.1
@@ -0,0 +1 @@
+MD5 90207f4718602fd1be1b38453febfca5 bicyclerepair-0.7.1.tar.gz 87885