summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2008-11-23 13:03:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2008-11-23 13:03:07 +0000
commit21a5248e65e96f75080f13ec8db16837f9c6315c (patch)
tree6e1484a833e609e7bbd46111656b2f14c895aa99 /dev-python/PyQt4/PyQt4-4.4.4-r1.ebuild
parentMasking webkit useflag for PyQt4 (diff)
downloadhistorical-21a5248e65e96f75080f13ec8db16837f9c6315c.tar.gz
historical-21a5248e65e96f75080f13ec8db16837f9c6315c.tar.bz2
historical-21a5248e65e96f75080f13ec8db16837f9c6315c.zip
Adding webkit useflag. Fixes pykde failing to build because of ordering issues.
Package-Manager: portage-2.2_rc15/cvs/Linux 2.6.26.5 x86_64
Diffstat (limited to 'dev-python/PyQt4/PyQt4-4.4.4-r1.ebuild')
-rw-r--r--dev-python/PyQt4/PyQt4-4.4.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/PyQt4/PyQt4-4.4.4-r1.ebuild b/dev-python/PyQt4/PyQt4-4.4.4-r1.ebuild
new file mode 100644
index 000000000000..7290fbc5dd9c
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.4.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.4-r1.ebuild,v 1.1 2008/11/23 13:03:07 patrick Exp $
+
+EAPI=1
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt4/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus debug doc examples opengl qt3support svg webkit X"
+
+RDEPEND=">=dev-python/sip-4.7.8
+ >=x11-libs/qt-core-4.4.2:4
+ dbus? ( >=x11-libs/qt-dbus-4.4.2:4 )
+ opengl? ( >=x11-libs/qt-opengl-4.4.2:4 )
+ svg? ( >=x11-libs/qt-svg-4.4.2:4 )
+ qt3support? ( >=x11-libs/qt-qt3support-4.4.2:4 )
+ webkit? ( >=x11-libs/qt-webkit-4.4.2:4 )
+ X? ( >=x11-libs/qt-gui-4.4.2:4 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+QT4_BUILT_WITH_USE_CHECK="zlib"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" "${S}"/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}