summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-04-23 10:05:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-04-23 10:05:06 +0000
commite736e0e3d0f5cf136558c98c42b0e92987019088 (patch)
tree0aa0ff8e0fc19260dba406ef20d8c0f08f1eb526 /dev-php
parentexperimental version for new PHP eclass (diff)
downloadhistorical-e736e0e3d0f5cf136558c98c42b0e92987019088.tar.gz
historical-e736e0e3d0f5cf136558c98c42b0e92987019088.tar.bz2
historical-e736e0e3d0f5cf136558c98c42b0e92987019088.zip
experimental version for new PHP eclass
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/Manifest5
-rw-r--r--dev-php/mod_php/files/digest-mod_php-4.3.1-r31
-rw-r--r--dev-php/mod_php/mod_php-4.3.1-r3.ebuild100
3 files changed, 103 insertions, 3 deletions
diff --git a/dev-php/mod_php/Manifest b/dev-php/mod_php/Manifest
index cc5ec72f4cd7..827b2cc100e7 100644
--- a/dev-php/mod_php/Manifest
+++ b/dev-php/mod_php/Manifest
@@ -1,10 +1,9 @@
-MD5 9265b53e4004a2c4658d2c86976270e3 mod_php-4.3.1-r3.ebuild 2745
+MD5 943f40908e087586336045d28e002b8c mod_php-4.3.1-r3.ebuild 2748
MD5 40e7c2563c18f1b091ef5fb26c4d59ed mod_php-4.3.1.ebuild 8688
MD5 904d1ba2927fae09ff0d9f8e12561317 mod_php-4.3.1-r2.ebuild 9128
MD5 6de98d80b82a71ed8845884b0bd5676e mod_php-4.2.3-r2.ebuild 8071
MD5 d470c7ff3d3a9d470e845eb240519982 mod_php-4.3.0-r2.ebuild 8635
-MD5 af59ccf297420d485eca1ea23000df39 ChangeLog 13983
-MD5 24a4ab98d3af5fcf49d9a27eec0a9558 mod_php-4.3.1-r3.ebuild~ 2747
+MD5 3aae7db3f07a3ebb36eea8eff467dae2 ChangeLog 14163
MD5 68f967fbb5cf7faabf563eb9f340da35 mod_php-4.3.1-r1.ebuild 8904
MD5 cceddd5c262e0ffef31d45b7da269851 files/mod_php.conf 148
MD5 6cf293d9a0faa0e7e5d86d9fd2d47131 files/70_mod_php.conf 329
diff --git a/dev-php/mod_php/files/digest-mod_php-4.3.1-r3 b/dev-php/mod_php/files/digest-mod_php-4.3.1-r3
new file mode 100644
index 000000000000..da8da7df7d9d
--- /dev/null
+++ b/dev-php/mod_php/files/digest-mod_php-4.3.1-r3
@@ -0,0 +1 @@
+MD5 bbfe584acb3549c62bb61355165e2ca6 php-4.3.1.tar.bz2 3682417
diff --git a/dev-php/mod_php/mod_php-4.3.1-r3.ebuild b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
new file mode 100644
index 000000000000..f16bd6b7af30
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.1-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r3.ebuild,v 1.1 2003/04/23 10:04:57 robbat2 Exp $
+
+inherit php eutils
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa"
+SLOT="0"
+
+ # users have been having problems with compiling the gmp support... disabled for now
+ # - rphillips
+ #>=dev-libs/gmp-3.1.1
+
+DEPEND="${DEPEND}
+ || (
+ apache2? ( >=net-www/apache-2.0.43-r1 )
+ >=net-www/apache-1.3.26-r2
+ )
+ "
+
+RDEPEND="${RDEPEND}"
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline "
+
+ # optional support for apache2
+ myconf="${myconf} --with-exec-dir=/usr/bin"
+ if [ "`use apache2`" ] ; then
+ myconf="${myconf} --with-apxs2=/usr/sbin/apxs2"
+ else
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+ fi
+
+ #this is an extra item required with mcrypt (which is include in the eclass) when used with apache
+ use crypt && myconf="${myconf} --disable-posix-threads"
+
+ myconf="${myconf} \
+ --enable-discard-path \
+ --enable-force-cgi-redirect \
+ --enable-mime-magic \
+ --enable-safe-mode \
+ --with-iconv"
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+
+ make INSTALL_ROOT=${D} install-pear install-headers install-programs install-build || die
+
+ cp php.ini-dist php.ini
+ insinto /etc/php4
+ doins php.ini
+ dosym /usr/lib/apache-extramodules /etc/php4/lib
+
+ if [ "`use apache2`" ] ; then
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache2/conf/php.ini
+ else
+ exeinto /usr/lib/apache-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache/conf/php.ini
+ dosym /etc/php4/php.ini /etc/apache/conf/addon-modules/php.ini
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP4\""
+ einfo
+ einfo "Please note Apache 2 support in php is currently experimental"
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
+ einfo
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+}