summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-26 20:16:51 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-26 20:16:51 +0000
commite50982209c7a649c1c23068390f00de7cf16ba23 (patch)
tree35584175f8b27487274e40e8716e068eba109171 /dev-php
parentAdded compile flag. Fixes bug #6817. Submitted by Michael Glauche (diff)
downloadhistorical-e50982209c7a649c1c23068390f00de7cf16ba23.tar.gz
historical-e50982209c7a649c1c23068390f00de7cf16ba23.tar.bz2
historical-e50982209c7a649c1c23068390f00de7cf16ba23.zip
Adds multibyte support. Fixes #6747. Submitted by Ryan Shaw
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog8
-rw-r--r--dev-php/mod_php/mod_php-4.2.2-r1.ebuild3
-rw-r--r--dev-php/php/php-4.2.2-r1.ebuild3
3 files changed, 10 insertions, 4 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 7d7b3cfaca5b..9a19413cbe87 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.10 2002/08/26 20:10:30 rphillips Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.11 2002/08/26 20:15:19 rphillips Exp $
*mod_php-4.2.2-r1 (18 Aug 2002)
+ 26 Aug 2002; Ryan Phillips <rphillips@gentoo.org> mod_php-4.2.2-r1.ebuild :
+
+ Added support for multibyte strings. Fixes #6747
+ Submitted by Ryan Shaw
+
18 Aug 2002; Ryan Phillips <rphillips@gentoo.org> mod_php-4.2.2-r1.ebuild :
Should fix pdflib/jpeg/tiff/java bug... #2708
diff --git a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
index e080ddc12aac..ecc8a583dcff 100644
--- a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
+++ b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.1 2002/08/19 00:03:40 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.2 2002/08/26 20:15:19 rphillips Exp $
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -96,6 +96,7 @@ src_compile() {
use ssl && myconf="${myconf} --with-openssl"
use curl && myconf="${myconf} --with-curl"
use snmp && myconf="${myconf} --with-snmp --enable-ucd-snmp-hack"
+ use cjk && myconf="${myconf} --enable-mbstring"
use gdbm && myconf="${myconf} --with-gdbm=/usr"
use berkdb && myconf="${myconf} --with-db3=/usr"
use mysql && myconf="${myconf} --with-mysql=/usr" || myconf="${myconf} --without-mysql"
diff --git a/dev-php/php/php-4.2.2-r1.ebuild b/dev-php/php/php-4.2.2-r1.ebuild
index a552f99488a0..367185564798 100644
--- a/dev-php/php/php-4.2.2-r1.ebuild
+++ b/dev-php/php/php-4.2.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.1 2002/08/19 00:02:21 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.2 2002/08/26 20:16:51 rphillips Exp $
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -87,6 +87,7 @@ src_compile() {
use pam && myconf="${myconf} --with-pam"
use nls && myconf="${myconf} --with-gettext" || myconf="${myconf} --without-gettext"
use ssl && myconf="${myconf} --with-openssl"
+ use cjk && myconf="${myconf} --enable-mbstring"
use curl && myconf="${myconf} --with-curl"
use snmp && myconf="${myconf} --with-snmp --enable-ucd-snmp-hack"
use gdbm && myconf="${myconf} --with-gdbm=/usr"