summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-09-03 20:36:35 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-09-03 20:36:35 +0000
commit43e0821432ae227c3415d21a96a3c7b1ca0f4b79 (patch)
treee4e2f31b1152e2d7aa7b18234172cca197be3026 /dev-php
parent/etc/exim/configure.default is now installed as /etc/exim/exim.conf.dist (diff)
downloadhistorical-43e0821432ae227c3415d21a96a3c7b1ca0f4b79.tar.gz
historical-43e0821432ae227c3415d21a96a3c7b1ca0f4b79.tar.bz2
historical-43e0821432ae227c3415d21a96a3c7b1ca0f4b79.zip
disabled java support
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/mod_php/ChangeLog8
-rw-r--r--dev-php/mod_php/mod_php-4.2.2-r1.ebuild46
-rw-r--r--dev-php/php/ChangeLog8
-rw-r--r--dev-php/php/php-4.2.2-r1.ebuild44
4 files changed, 59 insertions, 47 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index 19b6a284f8b7..18bbdab2fe1d 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.16 2002/09/02 16:57:07 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.17 2002/09/03 20:33:18 rphillips Exp $
02 Sep 2002; Daniel Robbins <drobbins@gentoo.org> mod_php-4.2.2-r1.ebuild :
rphillips' gmp fix broke the ebuild, fixing... (no rev bump)
@@ -11,6 +11,12 @@
*mod_php-4.2.2-r1 (18 Aug 2002)
+ 03 Sep 2002; Ryan Phillips <rphillips@gentoo.org> mod_php-4.2.2-r1.ebuild :
+
+ Users have had issues compiling php with java support. It works fine
+ on my two computers. I'm not sure if it is user error or config file
+ problems. I've disabled it for now.
+
01 Sep 2002; Ryan Phillips <rphillips@gentoo.org> mod_php-4.2.2-r1.ebuild :
Users have had trouble compiling with gmp support... Disabled for now
diff --git a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
index e2003c7842b5..4a2608986bc6 100644
--- a/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
+++ b/dev-php/mod_php/mod_php-4.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.9 2002/09/02 16:57:07 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.2.2-r1.ebuild,v 1.10 2002/09/03 20:33:18 rphillips Exp $
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -44,8 +44,8 @@ DEPEND="
libwww? ( >=net-libs/libwww-5.3.2 )
firebird? ( >=dev-db/firebird-1.0 )
pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
- postgres? ( >=dev-db/postgresql-7.1 )
- java? ( virtual/jdk )"
+ postgres? ( >=dev-db/postgresql-7.1 )"
+ #java? ( virtual/jdk )
# Only needed by CGI-Version
# readline? ( >=sys-libs/ncurses-5.1
# >=sys-libs/readline-4.1 )"
@@ -63,25 +63,25 @@ src_unpack() {
cat configure.old | sed "s/PHP_UNAME=\`uname -a\`/PHP_UNAME=\`uname -s -n -r -v\`/g" > configure
chmod 755 configure
- if [ "`use java`" ] ; then
-
- cp configure configure.orig
- cat configure.orig | \
- sed -e 's/LIBS="-lttf $LIBS"/LIBS="-lttf $LIBS"/' \
- > configure
-
- cp ext/gd/gd.c ext/gd/gd.c.orig
- cat ext/gd/gd.c.orig | \
- sed -e "s/typedef FILE gdIOCtx;//" \
- > ext/gd/gd.c
- if [ "$JAVAC" ];
- then
- cp ext/java/Makefile.in ext/java/Makefile.in.orig
- cat ext/java/Makefile.in.orig | \
- sed -e "s/^\tjavac/\t\$(JAVAC)/" \
- > ext/java/Makefile.in
- fi
- fi
+ #if [ "`use java`" ] ; then
+
+ # cp configure configure.orig
+ # cat configure.orig | \
+ # sed -e 's/LIBS="-lttf $LIBS"/LIBS="-lttf $LIBS"/' \
+ # > configure
+
+ # cp ext/gd/gd.c ext/gd/gd.c.orig
+ # cat ext/gd/gd.c.orig | \
+ # sed -e "s/typedef FILE gdIOCtx;//" \
+ # > ext/gd/gd.c
+ # if [ "$JAVAC" ];
+ # then
+ # cp ext/java/Makefile.in ext/java/Makefile.in.orig
+ # cat ext/java/Makefile.in.orig | \
+ # sed -e "s/^\tjavac/\t\$(JAVAC)/" \
+ # > ext/java/Makefile.in
+ # fi
+ #fi
}
@@ -154,7 +154,7 @@ src_compile() {
use xml2 && myconf="${myconf} --with-dom"
use crypt && myconf="${myconf} --with-mcrypt --with-mhash"
- use java && myconf="${myconf} --with-java=${JDK_HOME}"
+ #use java && myconf="${myconf} --with-java=${JDK_HOME}"
LDFLAGS="$LDFLAGS -ltiff -ljpeg"
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 1d1633fc811b..2548b2d2e608 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.11 2002/09/02 02:27:42 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.12 2002/09/03 20:36:35 rphillips Exp $
*php-4.2.2-r1 (18 Aug 2002)
+ 03 Sep 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.2-r1.ebuild :
+
+ Users have had issues compiling php with java support. It works fine
+ on my two computers. I'm not sure if it is user error or config file
+ problems. I've disabled it for now.
+
1 Sep 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.2-r1.ebuild :
too many users having trouble with gmp support.
diff --git a/dev-php/php/php-4.2.2-r1.ebuild b/dev-php/php/php-4.2.2-r1.ebuild
index 6b75fd524a4c..a32db16c98a1 100644
--- a/dev-php/php/php-4.2.2-r1.ebuild
+++ b/dev-php/php/php-4.2.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.8 2002/09/02 20:45:16 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.9 2002/09/03 20:36:35 rphillips Exp $
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -45,7 +45,7 @@ DEPEND="
pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
postgres? ( >=dev-db/postgresql-7.1 )
readline? ( >=sys-libs/ncurses-5.1
- java? ( virtual/jdk )
+ #java? ( virtual/jdk )
>=sys-libs/readline-4.1 )"
RDEPEND="${DEPEND}
@@ -61,25 +61,25 @@ src_unpack() {
cat configure.old | sed "s/PHP_UNAME=\`uname -a\`/PHP_UNAME=\`uname -s -n -r -v\`/g" > configure
chmod 755 configure
- if [ "`use java`" ] ; then
-
- cp configure configure.orig
- cat configure.orig | \
- sed -e 's/LIBS="-lttf $LIBS"/LIBS="-lttf $LIBS"/' \
- > configure
-
- cp ext/gd/gd.c ext/gd/gd.c.orig
- cat ext/gd/gd.c.orig | \
- sed -e "s/typedef FILE gdIOCtx;//" \
- > ext/gd/gd.c
- if [ "$JAVAC" ];
- then
- cp ext/java/Makefile.in ext/java/Makefile.in.orig
- cat ext/java/Makefile.in.orig | \
- sed -e "s/^\tjavac/\t\$(JAVAC)/" \
- > ext/java/Makefile.in
- fi
- fi
+ #if [ "`use java`" ] ; then
+
+ # cp configure configure.orig
+ # cat configure.orig | \
+ # sed -e 's/LIBS="-lttf $LIBS"/LIBS="-lttf $LIBS"/' \
+ # > configure
+
+ # cp ext/gd/gd.c ext/gd/gd.c.orig
+ # cat ext/gd/gd.c.orig | \
+ # sed -e "s/typedef FILE gdIOCtx;//" \
+ # > ext/gd/gd.c
+ # if [ "$JAVAC" ];
+ # then
+ # cp ext/java/Makefile.in ext/java/Makefile.in.orig
+ # cat ext/java/Makefile.in.orig | \
+ # sed -e "s/^\tjavac/\t\$(JAVAC)/" \
+ # > ext/java/Makefile.in
+ # fi
+ #fi
}
src_compile() {
@@ -146,7 +146,7 @@ src_compile() {
use xml2 && myconf="${myconf} --with-dom"
use crypt && myconf="${myconf} --enable-mcrypt=/usr --with-mhash"
- use java && myconf="${myconf} --with-java=${JDK_HOME}"
+ #use java && myconf="${myconf} --with-java=${JDK_HOME}"
LDFLAGS="$LDFLAGS -ltiff -ljpeg"