summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-13 07:05:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-13 07:05:11 +0000
commit1f5646a38a73b300343834883655ece2a784471b (patch)
tree9d608ce3222a35b6ab38cb590a202c5ed1448d85 /dev-ml
parentversion bump (diff)
downloadhistorical-1f5646a38a73b300343834883655ece2a784471b.tar.gz
historical-1f5646a38a73b300343834883655ece2a784471b.tar.bz2
historical-1f5646a38a73b300343834883655ece2a784471b.zip
version bump
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/ChangeLog7
-rw-r--r--dev-ml/findlib/findlib-1.2.5.ebuild77
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild42
-rw-r--r--dev-ml/sexplib/ChangeLog8
-rw-r--r--dev-ml/sexplib/sexplib-4.2.16.ebuild (renamed from dev-ml/sexplib/sexplib-4.2.15.ebuild)2
6 files changed, 140 insertions, 4 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 62b85adf1f78..2cc44cdd4180 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/findlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.56 2009/09/18 22:37:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.57 2009/10/13 07:00:49 aballier Exp $
+
+*findlib-1.2.5 (13 Oct 2009)
+
+ 13 Oct 2009; Alexis Ballier <aballier@gentoo.org> +findlib-1.2.5.ebuild:
+ version bump
*findlib-1.2.4-r1 (18 Sep 2009)
diff --git a/dev-ml/findlib/findlib-1.2.5.ebuild b/dev-ml/findlib/findlib-1.2.5.ebuild
new file mode 100644
index 000000000000..d7217f41ebf5
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.2.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.5.ebuild,v 1.1 2009/10/13 07:00:49 aballier Exp $
+
+EAPI=2
+
+inherit multilib
+
+RESTRICT="installsources"
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT X11"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?,tk?]"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir /usr/bin -mandir /usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake all || die
+ if use ocamlopt; then
+ emake opt || die # optimized code
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ dodir `ocamlc -where`
+
+ emake prefix="${D}" install || die
+
+ dodir "${stublibs}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 7106691d4df0..6fe427168a7f 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.12 2009/09/28 18:57:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.13 2009/10/13 07:03:58 aballier Exp $
+
+*postgresql-ocaml-1.12.3 (13 Oct 2009)
+
+ 13 Oct 2009; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.12.3.ebuild:
+ version bump
28 Sep 2009; Alexis Ballier <aballier@gentoo.org>
-postgresql-ocaml-1.8.2.ebuild, -postgresql-ocaml-1.11.1.ebuild:
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild
new file mode 100644
index 000000000000..f7bb94d647f6
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.3.ebuild,v 1.1 2009/10/13 07:03:58 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=virtual/postgresql-base-7.3
+ >=virtual/postgresql-server-7.3"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index e2dc92eda028..41b902cc32a8 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/sexplib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.2 2009/09/26 12:27:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.3 2009/10/13 07:05:11 aballier Exp $
+
+*sexplib-4.2.16 (13 Oct 2009)
+
+ 13 Oct 2009; Alexis Ballier <aballier@gentoo.org> -sexplib-4.2.15.ebuild,
+ +sexplib-4.2.16.ebuild:
+ version bump
*sexplib-4.2.15 (26 Sep 2009)
diff --git a/dev-ml/sexplib/sexplib-4.2.15.ebuild b/dev-ml/sexplib/sexplib-4.2.16.ebuild
index f2d636502d8d..b9572b911c6f 100644
--- a/dev-ml/sexplib/sexplib-4.2.15.ebuild
+++ b/dev-ml/sexplib/sexplib-4.2.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-4.2.15.ebuild,v 1.1 2009/09/26 12:27:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-4.2.16.ebuild,v 1.1 2009/10/13 07:05:11 aballier Exp $
EAPI="2"