summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:20:01 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:20:01 +0000
commit94bc8112a42eac3c6c189df46aa4c791f6c6b265 (patch)
treee451a0f2aeb282ce0fcfe02b3dc4332dc27c3d97 /dev-lisp
parentremove invalid usage of USE=static (diff)
downloadhistorical-94bc8112a42eac3c6c189df46aa4c791f6c6b265.tar.gz
historical-94bc8112a42eac3c6c189df46aa4c791f6c6b265.tar.bz2
historical-94bc8112a42eac3c6c189df46aa4c791f6c6b265.zip
New upstream version.
Package-Manager: portage-2.1.2_rc1-r4
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-rfc2388/ChangeLog11
-rw-r--r--dev-lisp/cl-rfc2388/cl-rfc2388-0.9.20060727.ebuild30
-rw-r--r--dev-lisp/cl-rfc2388/files/20060727-sbcl-external-format.patch18
-rw-r--r--dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.92
-rw-r--r--dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9.200607273
5 files changed, 62 insertions, 2 deletions
diff --git a/dev-lisp/cl-rfc2388/ChangeLog b/dev-lisp/cl-rfc2388/ChangeLog
index 34015f07c585..1a171fb89460 100644
--- a/dev-lisp/cl-rfc2388/ChangeLog
+++ b/dev-lisp/cl-rfc2388/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lisp/cl-rfc2388
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rfc2388/ChangeLog,v 1.4 2005/05/24 18:48:35 mkennedy Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rfc2388/ChangeLog,v 1.5 2006/11/09 04:20:01 mkennedy Exp $
+
+*cl-rfc2388-0.9.20060727 (09 Nov 2006)
+
+ 09 Nov 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/20060727-sbcl-external-format.patch,
+ +cl-rfc2388-0.9.20060727.ebuild:
+ New upstream version.
24 May 2005; <mkennedy@gentoo.org> cl-rfc2388-0.9.ebuild:
Keywording ~sparc
diff --git a/dev-lisp/cl-rfc2388/cl-rfc2388-0.9.20060727.ebuild b/dev-lisp/cl-rfc2388/cl-rfc2388-0.9.20060727.ebuild
new file mode 100644
index 000000000000..198605f48d41
--- /dev/null
+++ b/dev-lisp/cl-rfc2388/cl-rfc2388-0.9.20060727.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rfc2388/cl-rfc2388-0.9.20060727.ebuild,v 1.1 2006/11/09 04:20:01 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="An implementation of RFC 2388 in Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/rfc2388/"
+SRC_URI="ftp://common-lisp.net/pub/project/rfc2388/rfc2388_0.9.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/commonlisp
+ dev-lisp/common-lisp-controller"
+
+S=${WORKDIR}/rfc2388
+
+CLPACKAGE=rfc2388
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/20060727-sbcl-external-format.patch
+}
+
+src_install() {
+ common-lisp-install *.lisp rfc2388.asd
+ common-lisp-system-symlink
+}
diff --git a/dev-lisp/cl-rfc2388/files/20060727-sbcl-external-format.patch b/dev-lisp/cl-rfc2388/files/20060727-sbcl-external-format.patch
new file mode 100644
index 000000000000..8c896f4f79fb
--- /dev/null
+++ b/dev-lisp/cl-rfc2388/files/20060727-sbcl-external-format.patch
@@ -0,0 +1,18 @@
+===================================================================
+RCS file: /project/rfc2388/cvsroot/rfc2388/rfc2388.lisp,v
+retrieving revision 1.9
+retrieving revision 1.10
+diff -u -r1.9 -r1.10
+--- rfc2388/rfc2388.lisp 2005/08/02 09:01:47 1.9
++++ rfc2388/rfc2388.lisp 2006/07/27 07:40:46 1.10
+@@ -439,8 +439,9 @@
+ :direction :output
+ ;; external format for faithful I/O
+ ;; see <http://cl-cookbook.sourceforge.net/io.html#faith>
+- #+(or :lispworks :allegro)
++ #+(or :sbcl :lispworks :allegro)
+ :external-format
++ #+sbcl :latin-1
+ #+:lispworks '(:latin-1 :eol-style :lf)
+ #+:allegro (excl:crlf-base-ef :latin1))
+ (read-until-next-boundary input boundary nil out-file))
diff --git a/dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9 b/dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9
index 6fcd91b96ced..5b9cf8e81921 100644
--- a/dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9
+++ b/dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9
@@ -1 +1,3 @@
MD5 a2ff10743b0d497b960cc2780c37518f rfc2388_0.9.tar.gz 5440
+RMD160 c36bca83508a0023d0e6c45adc3eb3aaae99cfab rfc2388_0.9.tar.gz 5440
+SHA256 4677da6962e367867c12ae210c6af8ed9434958044681e71257f63c21cec1e6d rfc2388_0.9.tar.gz 5440
diff --git a/dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9.20060727 b/dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9.20060727
new file mode 100644
index 000000000000..5b9cf8e81921
--- /dev/null
+++ b/dev-lisp/cl-rfc2388/files/digest-cl-rfc2388-0.9.20060727
@@ -0,0 +1,3 @@
+MD5 a2ff10743b0d497b960cc2780c37518f rfc2388_0.9.tar.gz 5440
+RMD160 c36bca83508a0023d0e6c45adc3eb3aaae99cfab rfc2388_0.9.tar.gz 5440
+SHA256 4677da6962e367867c12ae210c6af8ed9434958044681e71257f63c21cec1e6d rfc2388_0.9.tar.gz 5440