summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-08-28 15:31:13 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-08-28 15:31:13 +0000
commit68ee7d54d5c293186d6ab869943b2ffcbe697fc1 (patch)
tree1409b2ae40d66d2f57c82d1ebc03ad889500fb2d /dev-lisp
parentinitial import (diff)
downloadhistorical-68ee7d54d5c293186d6ab869943b2ffcbe697fc1.tar.gz
historical-68ee7d54d5c293186d6ab869943b2ffcbe697fc1.tar.bz2
historical-68ee7d54d5c293186d6ab869943b2ffcbe697fc1.zip
initial import
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-albert/Manifest5
-rw-r--r--dev-lisp/cl-albert/cl-albert-0.4.6.ebuild45
-rw-r--r--dev-lisp/cl-albert/files/digest-cl-albert-0.4.61
3 files changed, 48 insertions, 3 deletions
diff --git a/dev-lisp/cl-albert/Manifest b/dev-lisp/cl-albert/Manifest
index c2f8273c16e2..9301c897b003 100644
--- a/dev-lisp/cl-albert/Manifest
+++ b/dev-lisp/cl-albert/Manifest
@@ -1,4 +1,3 @@
-MD5 0a06834501b01a61d6ea2448cc7b3e12 cl-albert-0.4.6.ebuild 923
-MD5 09212b2cba6aeac2b7997d2c391e7125 cl-albert-0.4.6.ebuild~ 995
-MD5 125ee013081b112d56a1d15507d72ef2 ChangeLog 3674
+MD5 7aee591711ddf49fc1ad81ba819bb379 cl-albert-0.4.6.ebuild 1291
+MD5 1ad94e94dca5aaf4d32d45fe734f7f2a ChangeLog 325
MD5 fbac34ce452adfd67123995fa87d2008 files/digest-cl-albert-0.4.6 64
diff --git a/dev-lisp/cl-albert/cl-albert-0.4.6.ebuild b/dev-lisp/cl-albert/cl-albert-0.4.6.ebuild
new file mode 100644
index 000000000000..aca1438a5a2f
--- /dev/null
+++ b/dev-lisp/cl-albert/cl-albert-0.4.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-albert/cl-albert-0.4.6.ebuild,v 1.1 2003/08/28 15:31:08 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Albert is a doc-generator for Common Lisp, comparable to Javadoc and Doxygen. Currently it generates DocBook documentation. It reads an ASDF system definition and documents the system."
+HOMEPAGE="http://albert.sourceforge.net/"
+SRC_URI="mirror://sourceforge/albert/${P/cl-/}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ app-text/docbook-dsssl-stylesheets
+ virtual/commonlisp"
+
+CLPACKAGE=albert
+
+S=${WORKDIR}/${P/cl-/}
+
+src_compile() {
+ make -C expat all || die
+}
+
+src_install() {
+ for p in . apispec base lisp2csf specs spres tools ; do
+ insinto /usr/share/common-lisp/source/${CLPACKAGE}/${p}
+ doins ${p}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/${CLPACKAGE}
+ doins *.asd
+ common-lisp-system-symlink
+ dodoc COPYING README ChangeLog THANKS
+ dohtml web/*
+ dobin expat/alb_xml2sexp
+ doman expat/alb_xml2sexp.1
+
+ insinto /usr/share/albert
+ doins data/*
+ insinto /usr/share/albert/icons
+ doins data/icons/*
+ insinto /usr/share/albert/apis
+ doins data/apis
+}
diff --git a/dev-lisp/cl-albert/files/digest-cl-albert-0.4.6 b/dev-lisp/cl-albert/files/digest-cl-albert-0.4.6
new file mode 100644
index 000000000000..c7fc1202e284
--- /dev/null
+++ b/dev-lisp/cl-albert/files/digest-cl-albert-0.4.6
@@ -0,0 +1 @@
+MD5 6eda3b6bb22a8444771494a0e080b7d2 albert-0.4.6.tar.gz 203387