summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-01-04 04:50:10 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-01-04 04:50:10 +0000
commit74f0a06d41d8e854ab8565bfebf333110caf0a86 (patch)
treea1c8ed76e72b7f05b39513a456a0264993395375 /dev-lisp/cl-tbnl
parentclean stray digests (diff)
downloadhistorical-74f0a06d41d8e854ab8565bfebf333110caf0a86.tar.gz
historical-74f0a06d41d8e854ab8565bfebf333110caf0a86.tar.bz2
historical-74f0a06d41d8e854ab8565bfebf333110caf0a86.zip
New upstream version.
Package-Manager: portage-2.1_pre2
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest12
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.9.4.ebuild36
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.41
4 files changed, 45 insertions, 11 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index aac2f2f250d5..7bee78338da2 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.26 2006/01/02 06:53:00 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.27 2006/01/04 04:50:10 mkennedy Exp $
+
+*cl-tbnl-0.9.4 (04 Jan 2006)
+
+ 04 Jan 2006; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.9.4.ebuild:
+ New upstream version.
*cl-tbnl-0.9.3 (02 Jan 2006)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index f3509292d788..89bd0e15aea0 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 7b5915ed6a266d325064949788ee0467 ChangeLog 4549
MD5 e4051610958787d2ff87c2ebdcbe773c cl-tbnl-0.8.9.ebuild 1012
MD5 dc448481b49565620c5214d44dd67139 cl-tbnl-0.9.3.ebuild 962
+MD5 dc448481b49565620c5214d44dd67139 cl-tbnl-0.9.4.ebuild 962
MD5 b7377fe929b0307f2d7b4c8cf44965f0 files/digest-cl-tbnl-0.8.9 66
MD5 8eb91cfadf45362db4b3c887a96d4f0f files/digest-cl-tbnl-0.9.3 66
+MD5 4ab7caeab29bdede1f8a48626723a184 files/digest-cl-tbnl-0.9.4 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDuM3YyiNZaEAZA+ARAtKwAJ9BMXWn54jm5I9LB6blmVAUf4mfeQCfVVRD
-7SWyHCfKWiSKs0S3q3yThOk=
-=xkJw
------END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.9.4.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.9.4.ebuild
new file mode 100644
index 000000000000..11dde852b4c9
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.9.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.9.4.ebuild,v 1.1 2006/01/04 04:50:10 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="standalone apache2"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+RDEPEND="${DEPEND}
+ !standalone? ( apache2? ( >=www-apache/mod_lisp2-1.2 ) !apache2? ( www-apache/mod_lisp ) )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.4 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.4
new file mode 100644
index 000000000000..cb18c1490b05
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.9.4
@@ -0,0 +1 @@
+MD5 fa8846d205aa69720768b628f1e35dd9 tbnl_0.9.4.orig.tar.gz 93314