summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-10-26 18:37:36 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-10-26 18:37:36 +0000
commit1fee3ef6c4cce23a6be3fde351fd3db366a217dd (patch)
treecf4e5637d436eb0a1146c12a6d875db934300f05 /dev-lisp/cl-tbnl
parentNew revision, with patches for bugs #110467 (fix syslog() calls) and #110135 ... (diff)
downloadhistorical-1fee3ef6c4cce23a6be3fde351fd3db366a217dd.tar.gz
historical-1fee3ef6c4cce23a6be3fde351fd3db366a217dd.tar.bz2
historical-1fee3ef6c4cce23a6be3fde351fd3db366a217dd.zip
New upstream version.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest10
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.8.4.ebuild39
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.41
4 files changed, 52 insertions, 5 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 3e97748feb1c..8772e6e1dfb8 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.17 2005/10/11 18:14:00 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.18 2005/10/26 18:37:36 mkennedy Exp $
+
+*cl-tbnl-0.8.4 (26 Oct 2005)
+
+ 26 Oct 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.8.4.ebuild:
+ New upstream version.
*cl-tbnl-0.8.3 (11 Oct 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index cf9ea5c539a4..72b2f49f1fd4 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 6949fc6d16d4d50ad3ff8562726b0265 ChangeLog 3108
+MD5 bfd6a5e1dc943570a7f611857c2a00a1 ChangeLog 3239
MD5 e3ccd1fed7f3a0f146a8242eb2e3c5dc cl-tbnl-0.8.3.ebuild 1011
+MD5 4828c50f0c0bc895b085ed1ccaae958d cl-tbnl-0.8.4.ebuild 1011
MD5 ae0a708202d5fc902b362aa99ca17b35 files/digest-cl-tbnl-0.8.3 66
+MD5 b3c283bcf5c2ad2d4e8568faaceb9e2b files/digest-cl-tbnl-0.8.4 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDTAEDyiNZaEAZA+ARAuxDAJ4sB0kCdSG7lWXYuwoj01Epy2hN2wCfeUUN
-nbGc3tGBUMUse2E4nFcYo1s=
-=YFhj
+iD8DBQFDX8z9yiNZaEAZA+ARAmABAJ4qpW9upv1qGVyIg+3ud+O7XxTzAACfd+q9
+FNRSPTnyMeuksyaNNyZE4eA=
+=MSke
-----END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.8.4.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.8.4.ebuild
new file mode 100644
index 000000000000..7de465a52a5a
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.8.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.8.4.ebuild,v 1.1 2005/10/26 18:37:36 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE="standalone"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ !standalone? ( www-apache/mod_lisp )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.4 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.4
new file mode 100644
index 000000000000..2faf789a650b
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.4
@@ -0,0 +1 @@
+MD5 783f67da6103c4d8cd5b4e07822f5fe7 tbnl_0.8.4.orig.tar.gz 86585