summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-04 15:53:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-04 15:53:46 +0000
commite97e547a95ce2058988263d590024c3db14dcb05 (patch)
tree72822b9e8872e142b006319d2a6fb938cb5c5d7c /dev-libs/libev/libev-3.90.ebuild
parentVersion bumped. (diff)
downloadhistorical-e97e547a95ce2058988263d590024c3db14dcb05.tar.gz
historical-e97e547a95ce2058988263d590024c3db14dcb05.tar.bz2
historical-e97e547a95ce2058988263d590024c3db14dcb05.zip
Version bumped.
Package-Manager: portage-2.1.7.16/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libev/libev-3.90.ebuild')
-rw-r--r--dev-libs/libev/libev-3.90.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libev/libev-3.90.ebuild b/dev-libs/libev/libev-3.90.ebuild
new file mode 100644
index 000000000000..3340250d02cb
--- /dev/null
+++ b/dev-libs/libev/libev-3.90.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-3.90.ebuild,v 1.1 2010/01/04 15:53:46 matsuu Exp $
+
+inherit autotools eutils
+
+MY_P="${P/0}"
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# Bug #283558
+DEPEND=">=sys-libs/glibc-2.9_p20081201"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-3.42-gentoo.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README
+}