summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-09-17 17:48:30 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-09-17 17:48:30 +0000
commitf312af1dfeafbea1d75903dd523c586feca10371 (patch)
treeb3901c444564cd82e298eb1428bec1155022e92b /dev-lang
parentFixed up the remaining deps, tested here and looks good. Marking ~amd64, bug ... (diff)
downloadhistorical-f312af1dfeafbea1d75903dd523c586feca10371.tar.gz
historical-f312af1dfeafbea1d75903dd523c586feca10371.tar.bz2
historical-f312af1dfeafbea1d75903dd523c586feca10371.zip
Version bump
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ChangeLog7
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.3_pre22
-rw-r--r--dev-lang/ruby/ruby-1.8.3_pre2.ebuild131
3 files changed, 139 insertions, 1 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 285f7cbee3cb..ab9fd0b96504 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.145 2005/07/23 11:53:00 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.146 2005/09/17 17:48:30 caleb Exp $
+
+*ruby-1.8.3_pre2 (17 Sep 2005)
+
+ 17 Sep 2005; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.3_pre2.ebuild:
+ Version bump
23 Jul 2005; MATSUU Takuto <matsuu@gentoo.org> ruby-1.8.2-r2.ebuild:
Stable on sh.
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.3_pre2 b/dev-lang/ruby/files/digest-ruby-1.8.3_pre2
new file mode 100644
index 000000000000..427156848e86
--- /dev/null
+++ b/dev-lang/ruby/files/digest-ruby-1.8.3_pre2
@@ -0,0 +1,2 @@
+MD5 536b18046c1d51731953fd32de3df26e ruby-1.8.3-preview2.tar.gz 4202512
+MD5 271d3d39201b3a049fa5bbed417c3f0a onigd2_4_2.tar.gz 203684
diff --git a/dev-lang/ruby/ruby-1.8.3_pre2.ebuild b/dev-lang/ruby/ruby-1.8.3_pre2.ebuild
new file mode 100644
index 000000000000..5e89a18545ba
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.3_pre2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.3_pre2.ebuild,v 1.1 2005/09/17 17:48:30 caleb Exp $
+
+ONIGURUMA="onigd2_4_2"
+
+inherit flag-o-matic alternatives eutils gnuconfig
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz
+ cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+SLOT="1.8"
+# please keep sorted
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE="socks5 tcltk cjk doc threads"
+
+RDEPEND="virtual/libc
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tcltk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3
+ !=dev-lang/ruby-cvs-1.8*"
+DEPEND="sys-devel/autoconf
+ sys-apps/findutils
+ ${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+S=${WORKDIR}/${P%_*}
+
+src_unpack() {
+ unpack ${A}
+
+# if use cjk ; then
+# einfo "Applying ${ONIGURUMA}"
+# pushd ${WORKDIR}/oniguruma
+# epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
+# cp ${FILESDIR}/re.c.182.patch .
+# econf --with-rubydir=${S} || die "econf failed"
+# make ${SLOT/./}
+# popd
+# fi
+
+ # Enable build on alpha EV67 (but run gnuconfig_update everywhere)
+ gnuconfig_update || die "gnuconfig_update failed"
+
+ cd ${S}
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+}
+
+src_compile() {
+ filter-flags -fomit-frame-pointer
+
+ # Socks support via dante
+ if use socks5; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ # On ia64 we need to build without optimization #48824
+ if use ia64; then
+ replace-flags '-O*' -O0
+ fi
+
+ econf --program-suffix=${SLOT/./} --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find ${S}/ext -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ if use ppc-macos ; then
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%.*}.dylib
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%_*}.dylib
+ else
+ dosym /usr/$(get_libdir)/libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%.*}
+ dosym /usr/$(get_libdir)/libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%_*}
+ fi
+
+ dodoc COPYING* ChangeLog MANIFEST README* ToDo
+}
+
+pkg_postinst() {
+ if ! use ppc-macos ; then
+ ewarn
+ ewarn "Warning: Vim won't work if you've just updated ruby from"
+ ewarn "1.6.x to 1.8.x due to the library version change."
+ ewarn "In that case, you will need to remerge vim."
+ ewarn
+
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ einfo
+ einfo "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ einfo
+ fi
+}
+
+pkg_postrm() {
+ if ! use ppc-macos ; then
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ fi
+}