summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-17 04:39:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-17 04:39:43 +0000
commit39d4d0eb6da61bde33a6455be8f3c657509c6f1d (patch)
treea192d13096ac2e0391d05440ab60340264025e06 /dev-lang
parentstabilize (diff)
downloadhistorical-39d4d0eb6da61bde33a6455be8f3c657509c6f1d.tar.gz
historical-39d4d0eb6da61bde33a6455be8f3c657509c6f1d.tar.bz2
historical-39d4d0eb6da61bde33a6455be8f3c657509c6f1d.zip
stabilize
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl/Manifest14
-rw-r--r--dev-lang/tcl/tcl-8.4.9.ebuild21
2 files changed, 11 insertions, 24 deletions
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index 6f85e020c580..a7b21ccc8561 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,21 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 2dd05b4063cbd6f3a3a66a52699474e4 ChangeLog 6736
MD5 72be7b18671e9312d64a3fb833dceecd metadata.xml 264
MD5 298311384d5fa55d9baeb0da21211103 tcl-8.3.4.ebuild 2537
-MD5 a94e31aed8689fc3a31e268720b50938 tcl-8.4.6-r1.ebuild 3329
MD5 90748478dfa508929dea3baefdcce7ef tcl-8.4.6.ebuild 2923
-MD5 fd7d38c4aef2dadd117105352522fd8f tcl-8.4.9.ebuild 3332
+MD5 a94e31aed8689fc3a31e268720b50938 tcl-8.4.6-r1.ebuild 3329
+MD5 6343e7f8d8163d9b61e811256016541e tcl-8.4.9.ebuild 3191
MD5 d8691f60be4023222834ccdf6ee6d498 files/digest-tcl-8.3.4 61
MD5 cb07b4bc1984a971b376e1da5e478fdc files/digest-tcl-8.4.6 65
MD5 cb07b4bc1984a971b376e1da5e478fdc files/digest-tcl-8.4.6-r1 65
MD5 1209abd340cad17f50f87c58f1c0f9f5 files/tcl-8.4.6-multilib.patch 1070
MD5 9c5852717da8c531e22dda3dd4ade696 files/digest-tcl-8.4.9 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFCf5+IKRy60XGEcJIRAjbIAJ0Xla/02Rd07jDmq84hajJOPyXlQwCgqsDn
-U6FJ1n8cOfLnoJ6rfB3dGS0=
-=Sj6M
------END PGP SIGNATURE-----
diff --git a/dev-lang/tcl/tcl-8.4.9.ebuild b/dev-lang/tcl/tcl-8.4.9.ebuild
index f411d2e16dfb..6223c0d2fc63 100644
--- a/dev-lang/tcl/tcl-8.4.9.ebuild
+++ b/dev-lang/tcl/tcl-8.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.9.ebuild,v 1.6 2005/05/09 17:35:46 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.9.ebuild,v 1.7 2005/05/17 04:39:43 vapier Exp $
inherit eutils
@@ -10,16 +10,15 @@ SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sh sparc x86"
IUSE="threads"
-DEPEND="virtual/libc"
+DEPEND=""
S=${WORKDIR}/${PN}${PV}
pkg_setup() {
- if use threads
- then
+ if use threads ; then
ewarn ""
ewarn "PLEASE NOTE: You are compiling ${P} with"
ewarn "threading enabled."
@@ -40,12 +39,11 @@ src_unpack() {
src_compile() {
local local_config_use=""
- if use threads
- then
+ if use threads ; then
local_config_use="--enable-threads"
fi
- cd ${S}/unix
+ cd "${S}"/unix
econf ${local_config_use} || die
emake CFLAGS="${CFLAGS}" || die
}
@@ -59,15 +57,15 @@ src_install() {
S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
# fix the tclConfig.sh to eliminate refs to the build directory
- sed -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${ROOT}/usr/$(get_libdir)," \
+ sed -i \
+ -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${ROOT}/usr/$(get_libdir)," \
-e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${ROOT}/usr/$(get_libdir)/tcl${v1}/include'," \
-e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L${ROOT}/usr/$(get_libdir)," \
-e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${ROOT}/usr/$(get_libdir)," \
-e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
-e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/$(get_libdir)'," \
-e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/$(get_libdir)'," \
- ${D}/usr/$(get_libdir)/tclConfig.sh > ${D}/usr/$(get_libdir)/tclConfig.sh.new
- mv ${D}/usr/$(get_libdir)/tclConfig.sh.new ${D}/usr/$(get_libdir)/tclConfig.sh
+ ${D}/usr/$(get_libdir)/tclConfig.sh
# install private headers
dodir /usr/$(get_libdir)/tcl${v1}/include/unix
@@ -97,5 +95,4 @@ pkg_postinst() {
ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
ewarn "upgrade them before this recompilation, too,"
ewarn
- ewarn ${S}
}