summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-16 19:24:25 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-16 19:24:25 +0000
commit9ff334153f328a65a92479b3af8b9406c30762e1 (patch)
tree125de46b709d48dde750672f295dc42f11dea18d /dev-lang/ocaml
parentAdding patch. Closes #31265. (diff)
downloadhistorical-9ff334153f328a65a92479b3af8b9406c30762e1.tar.gz
historical-9ff334153f328a65a92479b3af8b9406c30762e1.tar.bz2
historical-9ff334153f328a65a92479b3af8b9406c30762e1.zip
Adding patch. Closes #31265.
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/Manifest5
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.07-r12
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild60
3 files changed, 64 insertions, 3 deletions
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index f653a857e138..e7c56ae1eb8d 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,12 +1,11 @@
-MD5 d8116c4adaefc533aa9bdee23a1ee1ab ChangeLog 3779
+MD5 3b1083d879021e74c9ac5602cdc74026 ChangeLog 3915
MD5 8143dd48dfed3a4e3213352b958c77af ocaml-3.06-r1.ebuild 1444
MD5 e85fd8053cc693729f0740b2ac855a44 ocaml-3.06.ebuild 1377
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 c50e8173b3a6104df726f87a39ba5f62 ocaml-3.06-r2.ebuild 1556
MD5 c850861736892791084d5b2476b2fdc0 ocaml-3.07_beta2.ebuild 1566
MD5 68e9dd97163c9b83143ecb2e06b2e889 ocaml-3.07.ebuild 1365
-MD5 a26ba5d671d0bd5233dce3f68c66ee42 attachment.cgi?id=19308.1 1775
-MD5 1edf6d9b757b8e02b2267433580303b5 ocaml-3.07-r1.ebuild 1455
+MD5 2ede00b39d12b185e738f723cc1d53a9 ocaml-3.07-r1.ebuild 1460
MD5 30ac0d14e37ff0be57927d84e4e7e1c6 files/digest-ocaml-3.06 197
MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
MD5 4df214d6cd74b3c5955d868879dd6cc7 files/ocaml-3.06-tcltk-8.4compat-patch.bz2 639
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.07-r1 b/dev-lang/ocaml/files/digest-ocaml-3.07-r1
new file mode 100644
index 000000000000..7ab2713f6106
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.07-r1
@@ -0,0 +1,2 @@
+MD5 2dd038055f5e1350078ad81270411b78 ocaml-3.07.tar.gz 2537449
+MD5 f91d1f1e531f77011bd554817dbbc12a ocaml-3.07-patch2.diffs 42799
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
new file mode 100644
index 000000000000..ba021cf23ddd
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.1 2003/10/16 19:24:18 mholzer Exp $
+
+inherit flag-o-matic eutils
+filter-flags "-fstack-protector"
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+
+SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
+ http://caml.inria.fr/distrib/${P}/${P}-patch2.diffs"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+IUSE="tcltk"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${DISTDIR}/${P}-patch2.diffs
+ grep -rle "head -1" . | xargs sed -i "s:head -1:head -n 1:g"
+}
+
+src_compile() {
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ # Fix for bug #23767.
+ if [ "${ARCH}" = "sparc" ]; then
+ myconf="${myconf} -host sparc-unknown-linux-gnu"
+ fi
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}