summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-01-22 03:41:50 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-01-22 03:41:50 +0000
commit27fe4b07f13885ec679ffb83f09fb443ec9f0b7e (patch)
tree60d29a87cc9b704be35b20ebb51f280abf071c03 /dev-java
parentStable on x86 for bug #119634; Stabilize Gnome-2.12.2 (diff)
downloadhistorical-27fe4b07f13885ec679ffb83f09fb443ec9f0b7e.tar.gz
historical-27fe4b07f13885ec679ffb83f09fb443ec9f0b7e.tar.bz2
historical-27fe4b07f13885ec679ffb83f09fb443ec9f0b7e.zip
Initial commit. Needed to build oscore from source (bug #63282).
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-ejb-spec/ChangeLog10
-rw-r--r--dev-java/sun-ejb-spec/Manifest14
-rw-r--r--dev-java/sun-ejb-spec/files/digest-sun-ejb-spec-2.11
-rw-r--r--dev-java/sun-ejb-spec/metadata.xml5
-rw-r--r--dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild36
5 files changed, 66 insertions, 0 deletions
diff --git a/dev-java/sun-ejb-spec/ChangeLog b/dev-java/sun-ejb-spec/ChangeLog
new file mode 100644
index 000000000000..6060313bf961
--- /dev/null
+++ b/dev-java/sun-ejb-spec/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/sun-ejb-spec
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-ejb-spec/ChangeLog,v 1.1 2006/01/22 03:41:50 nichoj Exp $
+
+*sun-ejb-spec-2.1 (22 Jan 2006)
+
+ 22 Jan 2006; Joshua Nichols <nichoj@gentoo.org> +metadata.xml,
+ +sun-ejb-spec-2.1.ebuild:
+ Initial commit. Needed to build oscore from source (bug #63282).
+
diff --git a/dev-java/sun-ejb-spec/Manifest b/dev-java/sun-ejb-spec/Manifest
new file mode 100644
index 000000000000..25287ef47163
--- /dev/null
+++ b/dev-java/sun-ejb-spec/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 ecb4747b05b6550bbd3445ca96f7caf6 ChangeLog 409
+MD5 1b7618e2e808abe3ffa7fba11e146ffd files/digest-sun-ejb-spec-2.1 67
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 3b2a6bb8c5da17ff58c5608c07c361f5 sun-ejb-spec-2.1.ebuild 1055
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFD0vw6ndWRXhKOboURAgKfAKDztMSdgJvZE83Y9BfowAJr0e75gQCg6Ph4
+tzMVDhGgeul4L+KZ7/7vm4g=
+=nJ7C
+-----END PGP SIGNATURE-----
diff --git a/dev-java/sun-ejb-spec/files/digest-sun-ejb-spec-2.1 b/dev-java/sun-ejb-spec/files/digest-sun-ejb-spec-2.1
new file mode 100644
index 000000000000..1ef5c7172c63
--- /dev/null
+++ b/dev-java/sun-ejb-spec/files/digest-sun-ejb-spec-2.1
@@ -0,0 +1 @@
+MD5 b86b76a7d3e113f24bf29034cee5ac43 ejb-2_1-fr-spec-api.zip 10251
diff --git a/dev-java/sun-ejb-spec/metadata.xml b/dev-java/sun-ejb-spec/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/sun-ejb-spec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild b/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild
new file mode 100644
index 000000000000..c72ea287bdca
--- /dev/null
+++ b/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-ejb-spec/sun-ejb-spec-2.1.ebuild,v 1.1 2006/01/22 03:41:50 nichoj Exp $
+
+inherit java-pkg versionator
+
+MY_PN=ejb
+MY_PV=$(replace_all_version_separators _)
+MY_P="${MY_PN}-${MY_PV}"
+At="${MY_P}-fr-spec-api.zip"
+DESCRIPTION="Sun's Enterprise Java Beans specification"
+HOMEPAGE="http://java.sun.com/products/ejb/"
+SRC_URI="${At}"
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=ejb-${PV}-fr-class-oth-JSpec&SiteId=JSC&TransactionId=noreg"
+
+LICENSE="sun-ejb-spec-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND="app-arch/unzip"
+RESTRICT="fetch"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from the following URL and place it in ${DISTDIR}:"
+ einfo "${DOWNLOAD_URL}"
+ einfo "The link is found under '2.1 Final Release', next to 'Download Class Files'"
+}
+
+
+src_install() {
+ java-pkg_newjar ${MY_P}-api.jar ${MY_PN}-api.jar
+}