summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2005-09-10 21:55:00 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2005-09-10 21:55:00 +0000
commit167a4879023e98c6db2a3f32791002c07861aa58 (patch)
tree2d04f6c2f54ec1771da7422a30328fd3dba76c5d /dev-java
parent(#105532) Add groff build-time dependency. (diff)
downloadhistorical-167a4879023e98c6db2a3f32791002c07861aa58.tar.gz
historical-167a4879023e98c6db2a3f32791002c07861aa58.tar.bz2
historical-167a4879023e98c6db2a3f32791002c07861aa58.zip
Resolving bug #105453 with new patch
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/swt/ChangeLog8
-rw-r--r--dev-java/swt/Manifest7
-rw-r--r--dev-java/swt/files/swt-cairo-0.9.2-amd64.patch251
-rw-r--r--dev-java/swt/files/swt-cairo-0.9.2.patch93
-rw-r--r--dev-java/swt/swt-3.2_pre1.ebuild8
5 files changed, 358 insertions, 9 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index 8bd1eead2466..df123e4f875d 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/swt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.23 2005/08/17 08:26:18 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.24 2005/09/10 21:55:00 compnerd Exp $
+
+ 10 Sep 2005; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/swt-cairo-0.9.2-amd64.patch, files/swt-cairo-0.9.2.patch,
+ swt-3.2_pre1.ebuild:
+ Fixed patch for 32-bit world. Added a modified patch for amd64. Resolves
+ bug #105453.
*swt-3.2_pre1 (17 Aug 2005)
diff --git a/dev-java/swt/Manifest b/dev-java/swt/Manifest
index 506caef4cd4a..388dc53874c7 100644
--- a/dev-java/swt/Manifest
+++ b/dev-java/swt/Manifest
@@ -1,9 +1,10 @@
MD5 e3ef05c80819dea145867ba03dfeaa51 swt-3.1-r1.ebuild 5294
-MD5 6a556f9ab96f89ef2224bc394f55dcdc ChangeLog 4440
+MD5 061c6d8bef2e70b80b0ce60a78ea9610 ChangeLog 4679
MD5 5ea14ff7e96eeb0ce1c8a161b7f1ce3f metadata.xml 541
-MD5 a9a6f652685f34fbf8c5e6dfa51a4d9d swt-3.2_pre1.ebuild 5374
+MD5 bc340c43c60dff2969f46bebf6719d4f swt-3.2_pre1.ebuild 5474
+MD5 7991298565d3c65cc7f7d944bf7439e6 files/swt-cairo-0.9.2-amd64.patch 8505
MD5 ad4aa305806513ab198281b6e485fbbc files/SWTMessages.properties 2085
-MD5 42ff33c44d5ec749f8b5fe4f1155fa8b files/swt-cairo-0.9.2.patch 5725
+MD5 86a056e193ce8f351e3b12d7f5751861 files/swt-cairo-0.9.2.patch 8692
MD5 c964f0ff0b83afdfd76d872821540574 files/build.xml 476
MD5 4d4ba9daee2ceef312b8e18be3ab70ed files/digest-swt-3.1-r1 216
MD5 7ee7a8d75ee15448b3f9e27aab62bb99 files/digest-swt-3.2_pre1 222
diff --git a/dev-java/swt/files/swt-cairo-0.9.2-amd64.patch b/dev-java/swt/files/swt-cairo-0.9.2-amd64.patch
new file mode 100644
index 000000000000..3838fecf0a44
--- /dev/null
+++ b/dev-java/swt/files/swt-cairo-0.9.2-amd64.patch
@@ -0,0 +1,251 @@
+--- cairo.c.orig 2005-08-11 15:44:50.000000000 +0000
++++ cairo.c 2005-09-10 21:45:59.747679632 +0000
+@@ -254,6 +254,62 @@
+ }
+ #endif
+
++#ifndef NO_cairo_1font_1options_1create
++JNIEXPORT jlong JNICALL Cairo_NATIVE(cairo_1font_1options_1create)
++ (JNIEnv *env, jclass that)
++{
++ jlong rc = 0;
++ Cairo_NATIVE_ENTER(env, that, cairo_1font_1options_1create_FUNC);
++ rc = (jlong)cairo_font_options_create();
++ Cairo_NATIVE_EXIT(env, that, cairo_1font_1options_1create_FUNC);
++ return rc;
++}
++#endif
++
++#ifndef NO_cairo_1font_1options_1destroy
++JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1font_1options_1destroy)
++ (JNIEnv *env, jclass that, jint arg0)
++{
++ Cairo_NATIVE_ENTER(env, that, cairo_1font_1options_1destroy_FUNC);
++ cairo_font_options_destroy((cairo_font_options_t *)arg0);
++ Cairo_NATIVE_EXIT(env, that, cairo_1font_1options_1destroy_FUNC);
++}
++#endif
++
++#ifndef NO_cairo_1font_1options_1get_1antialias
++JNIEXPORT jlong JNICALL Cairo_NATIVE(cairo_1font_1options_1get_1antialias)
++ (JNIEnv *env, jclass that, jlong arg0)
++{
++ jlong rc = 0;
++ Cairo_NATIVE_ENTER(env, that, cairo_1font_1options_1get_1antialias_FUNC);
++ rc = (jlong)cairo_font_options_get_antialias((cairo_font_options_t *)arg0);
++ Cairo_NATIVE_EXIT(env, that, cairo_1font_1options_1get_1antialias_FUNC);
++ return rc;
++}
++#endif
++
++#ifndef NO_cairo_1font_1options_1set_1antialias
++JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1font_1options_1set_1antialias)
++ (JNIEnv *env, jclass that, jlong arg0, jlong arg1)
++{
++ Cairo_NATIVE_ENTER(env, that, cairo_1font_1options_1set_1antialias_FUNC);
++ cairo_font_options_set_antialias((cairo_font_options_t *)arg0, (cairo_antialias_t)arg1);
++ Cairo_NATIVE_EXIT(env, that, cairo_1font_1options_1set_1antialias_FUNC);
++}
++#endif
++
++#ifndef NO_cairo_1get_1antialias
++JNIEXPORT jlong JNICALL Cairo_NATIVE(cairo_1get_1antialias)
++ (JNIEnv *env, jclass that, jlong arg0)
++{
++ jlong rc = 0;
++ Cairo_NATIVE_ENTER(env, that, cairo_1get_1antialias_FUNC);
++ rc = (jlong)cairo_get_antialias((cairo_t *)arg0);
++ Cairo_NATIVE_EXIT(env, that, cairo_1get_1antialias_FUNC);
++ return rc;
++}
++#endif
++
+ #ifndef NO_cairo_1get_1current_1point
+ JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1get_1current_1point)
+ (JNIEnv *env, jclass that, jlong arg0, jdoubleArray arg1, jdoubleArray arg2)
+@@ -972,12 +1028,14 @@
+ #endif
+
+ #ifndef NO_cairo_1reference
+-JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1reference)
++JNIEXPORT jlong JNICALL Cairo_NATIVE(cairo_1reference)
+ (JNIEnv *env, jclass that, jlong arg0)
+ {
++ jlong rc = 0;
+ Cairo_NATIVE_ENTER(env, that, cairo_1reference_FUNC);
+- cairo_reference((cairo_t *)arg0);
++ rc = (jlong)cairo_reference((cairo_t *)arg0);
+ Cairo_NATIVE_EXIT(env, that, cairo_1reference_FUNC);
++ return rc;
+ }
+ #endif
+
+@@ -1075,6 +1133,16 @@
+ }
+ #endif
+
++#ifndef NO_cairo_1set_1antialias
++JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1set_1antialias)
++ (JNIEnv *env, jclass that, jlong arg0, jlong arg1)
++{
++ Cairo_NATIVE_ENTER(env, that, cairo_1set_1antialias_FUNC);
++ cairo_set_antialias((cairo_t *)arg0, (cairo_antialias_t)arg1);
++ Cairo_NATIVE_EXIT(env, that, cairo_1set_1antialias_FUNC);
++}
++#endif
++
+ #ifndef NO_cairo_1set_1dash
+ JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1set_1dash)
+ (JNIEnv *env, jclass that, jlong arg0, jdoubleArray arg1, jint arg2, jdouble arg3)
+@@ -1123,6 +1191,16 @@
+ }
+ #endif
+
++#ifndef NO_cairo_1set_1font_1options
++JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1set_1font_1options)
++ (JNIEnv *env, jclass that, jlong arg0, jlong arg1)
++{
++ Cairo_NATIVE_ENTER(env, that, cairo_1set_1font_1options_FUNC);
++ cairo_set_font_options((cairo_t *)arg0, (cairo_font_options_t *)arg1);
++ Cairo_NATIVE_EXIT(env, that, cairo_1set_1font_1options_FUNC);
++}
++#endif
++
+ #ifndef NO_cairo_1set_1font_1size
+ JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1set_1font_1size)
+ (JNIEnv *env, jclass that, jlong arg0, jdouble arg1)
+@@ -1133,6 +1211,16 @@
+ }
+ #endif
+
++#ifndef NO_cairo_1get_1font_1options
++JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1get_1font_1options)
++ (JNIEnv *env, jclass that, jlong arg0, jlong arg1)
++{
++ Cairo_NATIVE_ENTER(env, that, cairo_1get_1font_1options_FUNC);
++ cairo_get_font_options((cairo_t *)arg0, (cairo_font_options_t *)arg1);
++ Cairo_NATIVE_EXIT(env, that, cairo_1get_1font_1options_FUNC);
++}
++#endif
++
+ #ifndef NO_cairo_1set_1line_1cap
+ JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1set_1line_1cap)
+ (JNIEnv *env, jclass that, jlong arg0, jint arg1)
+@@ -1371,14 +1459,12 @@
+ #endif
+
+ #ifndef NO_cairo_1surface_1finish
+-JNIEXPORT jint JNICALL Cairo_NATIVE(cairo_1surface_1finish)
++JNIEXPORT void JNICALL Cairo_NATIVE(cairo_1surface_1finish)
+ (JNIEnv *env, jclass that, jlong arg0)
+ {
+- jint rc = 0;
+ Cairo_NATIVE_ENTER(env, that, cairo_1surface_1finish_FUNC);
+- rc = (jint)cairo_surface_finish((cairo_surface_t *)arg0);
++ cairo_surface_finish((cairo_surface_t *)arg0);
+ Cairo_NATIVE_EXIT(env, that, cairo_1surface_1finish_FUNC);
+- return rc;
+ }
+ #endif
+
+@@ -1526,11 +1612,11 @@
+
+ #ifndef NO_cairo_1xlib_1surface_1create_1for_1bitmap
+ JNIEXPORT jlong JNICALL Cairo_NATIVE(cairo_1xlib_1surface_1create_1for_1bitmap)
+- (JNIEnv *env, jclass that, jlong arg0, jlong arg1, jint arg2, jint arg3)
++ (JNIEnv *env, jclass that, jlong arg0, jlong arg1, jlong arg2, jint arg3, jint arg4)
+ {
+ jlong rc = 0;
+ Cairo_NATIVE_ENTER(env, that, cairo_1xlib_1surface_1create_1for_1bitmap_FUNC);
+- rc = (jlong)cairo_xlib_surface_create_for_bitmap((Display *)arg0, (Pixmap)arg1, arg2, arg3);
++ rc = (jlong)cairo_xlib_surface_create_for_bitmap((Display *)arg0, (Pixmap)arg1, (Screen *)arg2, arg3, arg4);
+ Cairo_NATIVE_EXIT(env, that, cairo_1xlib_1surface_1create_1for_1bitmap_FUNC);
+ return rc;
+ }
+
+===================================================================
+RCS file: /home/eclipse/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.c,v
+retrieving revision 1.6
+retrieving revision 1.7
+diff -u -r1.6 -r1.7
+--- org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.c 2005/07/11 21:28:17 1.6
++++ org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.c 2005/08/15 20:22:55 1.7
+@@ -24,8 +24,8 @@
+
+ #ifdef NATIVE_STATS
+
+-int Cairo_nativeFunctionCount = 130;
+-int Cairo_nativeFunctionCallCount[130];
++int Cairo_nativeFunctionCount = 138;
++int Cairo_nativeFunctionCallCount[138];
+ char * Cairo_nativeFunctionNames[] = {
+ "cairo_1append_1path",
+ "cairo_1arc",
+@@ -46,10 +46,16 @@
+ "cairo_1fill_1preserve",
+ "cairo_1font_1extents",
+ "cairo_1font_1extents_1t_1sizeof",
++ "cairo_1font_1options_1create",
++ "cairo_1font_1options_1destroy",
++ "cairo_1font_1options_1get_1antialias",
++ "cairo_1font_1options_1set_1antialias",
++ "cairo_1get_1antialias",
+ "cairo_1get_1current_1point",
+ "cairo_1get_1fill_1rule",
+ "cairo_1get_1font_1face",
+ "cairo_1get_1font_1matrix",
++ "cairo_1get_1font_1options",
+ "cairo_1get_1line_1cap",
+ "cairo_1get_1line_1join",
+ "cairo_1get_1line_1width",
+@@ -114,10 +120,12 @@
+ "cairo_1save",
+ "cairo_1scale",
+ "cairo_1select_1font_1face",
++ "cairo_1set_1antialias",
+ "cairo_1set_1dash",
+ "cairo_1set_1fill_1rule",
+ "cairo_1set_1font_1face",
+ "cairo_1set_1font_1matrix",
++ "cairo_1set_1font_1options",
+ "cairo_1set_1font_1size",
+ "cairo_1set_1line_1cap",
+ "cairo_1set_1line_1join",
+
+===================================================================
+RCS file: /home/eclipse/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.h,v
+retrieving revision 1.6
+retrieving revision 1.7
+diff -u -r1.6 -r1.7
+--- org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.h 2005/07/11 21:28:17 1.6
++++ org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.h 2005/08/15 20:22:55 1.7
+@@ -50,10 +50,16 @@
+ cairo_1fill_1preserve_FUNC,
+ cairo_1font_1extents_FUNC,
+ cairo_1font_1extents_1t_1sizeof_FUNC,
++ cairo_1font_1options_1create_FUNC,
++ cairo_1font_1options_1destroy_FUNC,
++ cairo_1font_1options_1get_1antialias_FUNC,
++ cairo_1font_1options_1set_1antialias_FUNC,
++ cairo_1get_1antialias_FUNC,
+ cairo_1get_1current_1point_FUNC,
+ cairo_1get_1fill_1rule_FUNC,
+ cairo_1get_1font_1face_FUNC,
+ cairo_1get_1font_1matrix_FUNC,
++ cairo_1get_1font_1options_FUNC,
+ cairo_1get_1line_1cap_FUNC,
+ cairo_1get_1line_1join_FUNC,
+ cairo_1get_1line_1width_FUNC,
+@@ -118,10 +124,12 @@
+ cairo_1save_FUNC,
+ cairo_1scale_FUNC,
+ cairo_1select_1font_1face_FUNC,
++ cairo_1set_1antialias_FUNC,
+ cairo_1set_1dash_FUNC,
+ cairo_1set_1fill_1rule_FUNC,
+ cairo_1set_1font_1face_FUNC,
+ cairo_1set_1font_1matrix_FUNC,
++ cairo_1set_1font_1options_FUNC,
+ cairo_1set_1font_1size_FUNC,
+ cairo_1set_1line_1cap_FUNC,
+ cairo_1set_1line_1join_FUNC,
diff --git a/dev-java/swt/files/swt-cairo-0.9.2.patch b/dev-java/swt/files/swt-cairo-0.9.2.patch
index ca202d94af64..cac280ddbd4a 100644
--- a/dev-java/swt/files/swt-cairo-0.9.2.patch
+++ b/dev-java/swt/files/swt-cairo-0.9.2.patch
@@ -1,10 +1,10 @@
-===================================================================
+==================================================================
RCS file: /home/eclipse/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo.c,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
---- cairo.c 2005/07/11 21:28:17 1.4
-+++ cairo.c 2005/08/15 20:22:55 1.5
+--- org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo.c 2005/07/11 21:28:17 1.4
++++ org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo.c 2005/08/15 20:22:55 1.5
@@ -254,6 +254,62 @@
}
#endif
@@ -167,3 +167,90 @@ diff -u -r1.4 -r1.5
Cairo_NATIVE_EXIT(env, that, cairo_1xlib_1surface_1create_1for_1bitmap_FUNC);
return rc;
}
+
+===================================================================
+RCS file: /home/eclipse/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.c,v
+retrieving revision 1.6
+retrieving revision 1.7
+diff -u -r1.6 -r1.7
+--- org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.c 2005/07/11 21:28:17 1.6
++++ org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.c 2005/08/15 20:22:55 1.7
+@@ -24,8 +24,8 @@
+
+ #ifdef NATIVE_STATS
+
+-int Cairo_nativeFunctionCount = 130;
+-int Cairo_nativeFunctionCallCount[130];
++int Cairo_nativeFunctionCount = 138;
++int Cairo_nativeFunctionCallCount[138];
+ char * Cairo_nativeFunctionNames[] = {
+ "cairo_1append_1path",
+ "cairo_1arc",
+@@ -46,10 +46,16 @@
+ "cairo_1fill_1preserve",
+ "cairo_1font_1extents",
+ "cairo_1font_1extents_1t_1sizeof",
++ "cairo_1font_1options_1create",
++ "cairo_1font_1options_1destroy",
++ "cairo_1font_1options_1get_1antialias",
++ "cairo_1font_1options_1set_1antialias",
++ "cairo_1get_1antialias",
+ "cairo_1get_1current_1point",
+ "cairo_1get_1fill_1rule",
+ "cairo_1get_1font_1face",
+ "cairo_1get_1font_1matrix",
++ "cairo_1get_1font_1options",
+ "cairo_1get_1line_1cap",
+ "cairo_1get_1line_1join",
+ "cairo_1get_1line_1width",
+@@ -114,10 +120,12 @@
+ "cairo_1save",
+ "cairo_1scale",
+ "cairo_1select_1font_1face",
++ "cairo_1set_1antialias",
+ "cairo_1set_1dash",
+ "cairo_1set_1fill_1rule",
+ "cairo_1set_1font_1face",
+ "cairo_1set_1font_1matrix",
++ "cairo_1set_1font_1options",
+ "cairo_1set_1font_1size",
+ "cairo_1set_1line_1cap",
+ "cairo_1set_1line_1join",
+
+===================================================================
+RCS file: /home/eclipse/org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.h,v
+retrieving revision 1.6
+retrieving revision 1.7
+diff -u -r1.6 -r1.7
+--- org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.h 2005/07/11 21:28:17 1.6
++++ org.eclipse.swt/Eclipse SWT PI/cairo/library/cairo_stats.h 2005/08/15 20:22:55 1.7
+@@ -50,10 +50,16 @@
+ cairo_1fill_1preserve_FUNC,
+ cairo_1font_1extents_FUNC,
+ cairo_1font_1extents_1t_1sizeof_FUNC,
++ cairo_1font_1options_1create_FUNC,
++ cairo_1font_1options_1destroy_FUNC,
++ cairo_1font_1options_1get_1antialias_FUNC,
++ cairo_1font_1options_1set_1antialias_FUNC,
++ cairo_1get_1antialias_FUNC,
+ cairo_1get_1current_1point_FUNC,
+ cairo_1get_1fill_1rule_FUNC,
+ cairo_1get_1font_1face_FUNC,
+ cairo_1get_1font_1matrix_FUNC,
++ cairo_1get_1font_1options_FUNC,
+ cairo_1get_1line_1cap_FUNC,
+ cairo_1get_1line_1join_FUNC,
+ cairo_1get_1line_1width_FUNC,
+@@ -118,10 +124,12 @@
+ cairo_1save_FUNC,
+ cairo_1scale_FUNC,
+ cairo_1select_1font_1face_FUNC,
++ cairo_1set_1antialias_FUNC,
+ cairo_1set_1dash_FUNC,
+ cairo_1set_1fill_1rule_FUNC,
+ cairo_1set_1font_1face_FUNC,
+ cairo_1set_1font_1matrix_FUNC,
++ cairo_1set_1font_1options_FUNC,
+ cairo_1set_1font_1size_FUNC,
+ cairo_1set_1line_1cap_FUNC,
+ cairo_1set_1line_1join_FUNC,
diff --git a/dev-java/swt/swt-3.2_pre1.ebuild b/dev-java/swt/swt-3.2_pre1.ebuild
index 79df53212900..37946eed0973 100644
--- a/dev-java/swt/swt-3.2_pre1.ebuild
+++ b/dev-java/swt/swt-3.2_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2_pre1.ebuild,v 1.1 2005/08/17 08:26:18 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2_pre1.ebuild,v 1.2 2005/09/10 21:55:00 compnerd Exp $
inherit eutils java-pkg
@@ -73,7 +73,11 @@ src_unpack() {
# CARIO 0.9.2 API Patch
if has_version '>=x11-libs/cairo-0.9.2' ; then
- epatch ${FILESDIR}/swt-cairo-0.9.2.patch
+ if [[ ${ARCH} == 'amd64' ]] ; then
+ epatch ${FILESDIR}/swt-cairo-0.9.2-amd64.patch
+ else
+ epatch ${FILESDIR}/swt-cairo-0.9.2.patch
+ fi
fi
# Replace the build.xml to allow compilation without Eclipse tasks