summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-05-26 07:49:42 +0000
committerMark Wright <gienah@gentoo.org>2012-05-26 07:49:42 +0000
commit937eae7ac0ed2a48a86c80305f94ec36e486a5a5 (patch)
treecf9f29497ae9dc5504bae754cc7d79071cad9f72 /dev-haskell/text/text-0.11.2.1.ebuild
parentInclude compiler-rt; fixes #417419. Increase parser recursion limit wrt #4175... (diff)
downloadhistorical-937eae7ac0ed2a48a86c80305f94ec36e486a5a5.tar.gz
historical-937eae7ac0ed2a48a86c80305f94ec36e486a5a5.tar.bz2
historical-937eae7ac0ed2a48a86c80305f94ec36e486a5a5.zip
Bump text to 0.11.2.1
Package-Manager: portage-2.1.10.63/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/text/text-0.11.2.1.ebuild')
-rw-r--r--dev-haskell/text/text-0.11.2.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/text/text-0.11.2.1.ebuild b/dev-haskell/text/text-0.11.2.1.ebuild
new file mode 100644
index 000000000000..a428e263fb41
--- /dev/null
+++ b/dev-haskell/text/text-0.11.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-0.11.2.1.ebuild,v 1.1 2012/05/26 07:49:42 gienah Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type."
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/deepseq-1.1.0.0[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.4.0.1[profile?]
+ >=dev-haskell/test-framework-0.4[profile?] <dev-haskell/test-framework-0.7[profile?]
+ <dev-haskell/test-framework-hunit-0.3[profile?]
+ <dev-haskell/test-framework-quickcheck2-0.3[profile?]
+ )"
+
+src_configure() {
+ # the tests need a utf-8 locale
+ cabal_src_configure $(use test && use_enable test tests) #395351
+}