summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-12-04 17:49:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-12-04 17:49:25 +0000
commit1c9b068be60a3c348a60d95ebb04e750346c9901 (patch)
tree0ddf93878f3f8e99a4269a610238abe67d20dab4 /dev-haskell/sha
parentDrop alpha/ia64/sparc keywords (diff)
downloadhistorical-1c9b068be60a3c348a60d95ebb04e750346c9901.tar.gz
historical-1c9b068be60a3c348a60d95ebb04e750346c9901.tar.bz2
historical-1c9b068be60a3c348a60d95ebb04e750346c9901.zip
Initian version. Implementations of the SHA suite of message digest functions (dev-vcs/git-annex depend)
Package-Manager: portage-2.2.0_alpha77_p1/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/sha')
-rw-r--r--dev-haskell/sha/ChangeLog11
-rw-r--r--dev-haskell/sha/metadata.xml17
-rw-r--r--dev-haskell/sha/sha-1.5.0.0.ebuild29
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/sha/ChangeLog b/dev-haskell/sha/ChangeLog
new file mode 100644
index 000000000000..528454825772
--- /dev/null
+++ b/dev-haskell/sha/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/sha
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/sha/ChangeLog,v 1.1 2011/12/04 17:49:25 slyfox Exp $
+
+*sha-1.5.0.0 (04 Dec 2011)
+
+ 04 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +sha-1.5.0.0.ebuild:
+ Initian version. Implementations of the SHA suite of message digest functions
+ (dev-vcs/git-annex depend)
+
diff --git a/dev-haskell/sha/metadata.xml b/dev-haskell/sha/metadata.xml
new file mode 100644
index 000000000000..b3a30d785b5d
--- /dev/null
+++ b/dev-haskell/sha/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This library implements the SHA suite of message digest functions,
+ according to NIST FIPS 180-2 (with the SHA-224 addendum), as well
+ as the SHA-based HMAC routines. The functions have been tested
+ against most of the NIST and RFC test vectors for the various
+ functions. While some attention has been paid to performance,
+ these do not presently reach the speed of well-tuned libraries,
+ like OpenSSL.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/sha/sha-1.5.0.0.ebuild b/dev-haskell/sha/sha-1.5.0.0.ebuild
new file mode 100644
index 000000000000..ec6b422aaf3b
--- /dev/null
+++ b/dev-haskell/sha/sha-1.5.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/sha/sha-1.5.0.0.ebuild,v 1.1 2011/12/04 17:49:25 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="SHA"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Implementations of the SHA suite of message digest functions"
+HOMEPAGE="http://hackage.haskell.org/package/sha"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/binary
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"