summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-12 12:51:55 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-12 12:51:55 +0000
commit8e388ae79b40de2e92ccd740a80c77ac3ce6ace4 (patch)
tree064ae0ab884694ff25f68dde6c9c6709dc44e73f /dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild
parentVersion bump. (diff)
downloadhistorical-8e388ae79b40de2e92ccd740a80c77ac3ce6ace4.tar.gz
historical-8e388ae79b40de2e92ccd740a80c77ac3ce6ace4.tar.bz2
historical-8e388ae79b40de2e92ccd740a80c77ac3ce6ace4.zip
Prevent gio-sharp.dll.mdb from being installed
Package-Manager: portage-2.2.0_alpha26/cvs/Linux x86_64
Diffstat (limited to 'dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild')
-rw-r--r--dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild b/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild
new file mode 100644
index 000000000000..03e8e195d4db
--- /dev/null
+++ b/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild,v 1.1 2011/03/12 12:51:55 angelos Exp $
+
+EAPI=2
+inherit autotools eutils mono
+
+DESCRIPTION="GIO API C# binding"
+HOMEPAGE="http://github.com/mono/gio-sharp"
+SRC_URI="http://github.com/mono/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-dotnet/glib-sharp-2.12
+ >=dev-dotnet/gtk-sharp-gapi-2.12
+ >=dev-libs/glib-2.22:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-debug-libs.patch
+ sed -i -e '/autoreconf/d' autogen-generic.sh || die
+ NOCONFIGURE=1 ./autogen-2.22.sh || die
+
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ mono_multilib_comply
+}