summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 12:38:24 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 12:38:24 +0000
commitb75ad3fe572822d798e7f6ff8cf6839080de2528 (patch)
treeaf2ecb24ad8cdbf5930403d32dcbe9ddeba828af /dev-db
parent*** empty log message *** (diff)
downloadhistorical-b75ad3fe572822d798e7f6ff8cf6839080de2528.tar.gz
historical-b75ad3fe572822d798e7f6ff8cf6839080de2528.tar.bz2
historical-b75ad3fe572822d798e7f6ff8cf6839080de2528.zip
*** empty log message ***
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.281
-rw-r--r--dev-db/mysql/mysql-3.23.28.ebuild104
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.0.31
-rw-r--r--dev-db/postgresql/postgresql-7.0.3.ebuild34
4 files changed, 140 insertions, 0 deletions
diff --git a/dev-db/mysql/files/digest-mysql-3.23.28 b/dev-db/mysql/files/digest-mysql-3.23.28
new file mode 100644
index 000000000000..e37ad0c0977c
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-3.23.28
@@ -0,0 +1 @@
+MD5 c7846c514600711f3f5ae65deb320c63 mysql-3.23.28-gamma.tar.gz
diff --git a/dev-db/mysql/mysql-3.23.28.ebuild b/dev-db/mysql/mysql-3.23.28.ebuild
new file mode 100644
index 000000000000..360c5eed5b92
--- /dev/null
+++ b/dev-db/mysql/mysql-3.23.28.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.28.ebuild,v 1.1 2000/11/26 12:38:24 achim Exp $
+
+P=${PN}-${PV}-gamma
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The MySQL Database"
+SRC_URI="ftp://mysql.valueclick.com/mysql/Downloads/MySQL-3.23/${A}
+ http://www.mysql.com/Downloads/MySQL-3.23/${A}"
+HOMEPAGE="http://www.mysql.com/"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-apps/tcp-wrappers-7.6
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1"
+
+src_compile() {
+ if [ "$PLATFORM" = "i686-pc-linux-gnu" ]
+ then
+ export CFLAGS="-mpentium"
+ export CXXFLAGS="-mpentium"
+ fi
+ # Patch for qmail-mysql
+ cd ${S}/include
+ cp nisam.h nisam.h.orig
+ sed -e "s/define N_MAX_KEY_LENGTH 256/define N_MAX_KEY_LENGTH 500/" nisam.h.orig > nisam.h
+
+ cd ${S}
+ CXX=gcc ./configure --prefix=/usr --host=${CHOST} \
+ --enable-shared \
+ --enable-static \
+ --enable-assembler \
+ --enable-thread-safe-client \
+ --with-raid \
+ --with-low-memory \
+ --with-libwrap \
+ --with-berkley-db \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/mysql \
+ --infodir=/usr/info \
+ --mandir=/usr/man \
+ --without-debug \
+ --with-mysql-user=mysql
+ try make benchdir=/usr/share/mysql-bench
+}
+
+src_install() {
+
+ cd ${S}
+
+ # Install MySQL
+
+ try make install prefix=${D}/usr \
+ libdir=${D}/usr/lib \
+ libexecdir=${D}/usr/sbin \
+ sysconfdir=${D}/etc/mysql \
+ localstatedir=${D}/var/mysql \
+ infodir=${D}/usr/info \
+ mandir=${D}/usr/man \
+ benchdir=${D}/usr/share/mysql-bench
+
+
+ # Move Client Libs
+ mv ${D}/usr/lib/mysql/libmysqlclient.so* ${D}/usr/lib
+
+ insinto /usr/include/mysql
+ doins include/my_config.h include/my_dir.h
+ dodir /etc/mysql
+ cp scripts/mysqlaccess.conf ${D}/etc/mysql
+ cp ${O}/files/my.cnf ${D}/etc/mysql
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/mysql ${D}/etc/rc.d/init.d/mysql
+
+ # MySQL Docs
+
+ cd ${S}
+ into /usr
+ dodoc INSTALL-SOURCE README MIRRORS
+ cd ${S}/Docs
+ dodoc INSTALL-BINARY manual.ps manual.txt
+ docinto html
+ dodoc manual.html manual_toc.html
+
+}
+
+pkg_config () {
+
+ echo "Setting up symlinks..."
+ ${ROOT}/usr/sbin/rc-update add mysql
+
+}
+
+
+
+
+
+
+
diff --git a/dev-db/postgresql/files/digest-postgresql-7.0.3 b/dev-db/postgresql/files/digest-postgresql-7.0.3
new file mode 100644
index 000000000000..2fa7e81e47a2
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.0.3
@@ -0,0 +1 @@
+MD5 b416c04e6c91967160dfde866293ee6f postgresql-7.0.3.tar.gz
diff --git a/dev-db/postgresql/postgresql-7.0.3.ebuild b/dev-db/postgresql/postgresql-7.0.3.ebuild
new file mode 100644
index 000000000000..c5f1355aa055
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.0.3.ebuild,v 1.1 2000/11/26 12:38:24 achim Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}/src
+DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.postgresql.org/pub/v7.0.3/${A}"
+HOMEPAGE="http://postgresql.readysetnet.com/"
+
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --enable-locale --with-tcl --enable-syslog
+ cp Makefile.global Makefile.orig
+ sed -e "s:^TEMPLATEDIR=.*:TEMPLATEDIR=\$(POSTGRESDIR)/lib/postgres:" \
+ -e "s:^HEADERDIR=.*:HEADERDIR=\$(POSTGRESDIR)/include/postgres:" \
+ -e "s:-O2:${CFLAGS}:" \
+ Makefile.orig > Makefile.global
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make POSTGRESDIR=${D}/usr install
+
+}
+