summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-21 00:50:21 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-21 00:50:21 +0000
commit2acad96f7ca34848a3e2d62d6cae7437c87377e1 (patch)
tree0e7c7ff15118708ae8412f3bf723be9a64f74901 /app-vim/minibufexpl/minibufexpl-6.4.2.ebuild
parentUse correct license. (diff)
downloadhistorical-2acad96f7ca34848a3e2d62d6cae7437c87377e1.tar.gz
historical-2acad96f7ca34848a3e2d62d6cae7437c87377e1.tar.bz2
historical-2acad96f7ca34848a3e2d62d6cae7437c87377e1.zip
Version bump.
Package-Manager: portage-2.2.0_alpha45/cvs/Linux x86_64
Diffstat (limited to 'app-vim/minibufexpl/minibufexpl-6.4.2.ebuild')
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild b/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild
new file mode 100644
index 000000000000..bb9592559477
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild,v 1.1 2011/07/21 00:50:21 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="https://github.com/fholgado/minibufexpl.vim"
+SRC_URI="https://github.com/fholgado/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="minibufexpl.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '1,/"=\+$/d' -e '/"=\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/minibufexpl.vim \
+ > doc/minibufexpl.txt
+
+ # Discard unwanted files
+ rm -f .gitignore README project.html
+}