summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-31 12:13:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-31 12:13:56 +0000
commit78bcc4fbd16181bda03bf77e2d9cc01fddafe3b2 (patch)
treed9d8fb1c669bae6df0ec6d7795deb2ede6ff0196 /app-text/sgml-common
parentoutput warning to user without gnome USE flag to remerge libglade with gnome ... (diff)
downloadhistorical-78bcc4fbd16181bda03bf77e2d9cc01fddafe3b2.tar.gz
historical-78bcc4fbd16181bda03bf77e2d9cc01fddafe3b2.tar.bz2
historical-78bcc4fbd16181bda03bf77e2d9cc01fddafe3b2.zip
ebuild cleaned up a little.
Diffstat (limited to 'app-text/sgml-common')
-rw-r--r--app-text/sgml-common/ChangeLog8
-rw-r--r--app-text/sgml-common/files/digest-sgml-common-0.6.1-r11
-rw-r--r--app-text/sgml-common/sgml-common-0.6.1-r1.ebuild64
3 files changed, 72 insertions, 1 deletions
diff --git a/app-text/sgml-common/ChangeLog b/app-text/sgml-common/ChangeLog
index b22a8a8e6fcb..104a78bb42b7 100644
--- a/app-text/sgml-common/ChangeLog
+++ b/app-text/sgml-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/sgml-common
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/ChangeLog,v 1.1 2002/02/01 21:53:10 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/ChangeLog,v 1.2 2002/03/31 12:13:56 seemant Exp $
+
+*sgml-common-0.6.1-r1 (31 Mar 2002)
+
+ 31 Mar 2002; Seemant Kulleen <seemant@gentoo.org> sgml-common-0.6.1-r1.ebuild:
+
+ Cleaned up ebuild.
*sgml-common-0.6.1 (1 Feb 2002)
diff --git a/app-text/sgml-common/files/digest-sgml-common-0.6.1-r1 b/app-text/sgml-common/files/digest-sgml-common-0.6.1-r1
new file mode 100644
index 000000000000..5d7b0745a90b
--- /dev/null
+++ b/app-text/sgml-common/files/digest-sgml-common-0.6.1-r1
@@ -0,0 +1 @@
+MD5 3a12478c3c622f94a292272df674f178 sgml-common-0.6.1.tgz 77590
diff --git a/app-text/sgml-common/sgml-common-0.6.1-r1.ebuild b/app-text/sgml-common/sgml-common-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..3e572c8e8590
--- /dev/null
+++ b/app-text/sgml-common/sgml-common-0.6.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/sgml-common-0.6.1-r1.ebuild,v 1.1 2002/03/31 12:13:56 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Base ISO character entities and utilities for SGML"
+SRC_URI="ftp://ftp.kde.org/pub/kde/devel/docbook/SOURCES/${P}.tgz
+ http://download.sourceforge.net/pub/mirrors/kde/devel/docbook/SOURCES/${P}.tgz"
+HOMEPAGE="http://www.iso.ch/cate/3524030.html"
+
+src_unpack() {
+
+ unpack ${A}
+ # We use a hacked version of install-catalog that supports the ROOT variable
+ cp ${FILESDIR}/${P}-install-catalog.in ${S}/bin
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ docdir=${D}/usr/share/doc \
+ install || die
+
+}
+
+pkg_postinst() {
+ if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ install-catalog --add \
+ /etc/sgml/sgml-ent.cat \
+ /usr/share/sgml/sgml-iso-entities-8879.1986/catalog
+
+ install-catalog --add \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/sgml-ent.cat
+ else
+ echo "install-catalog not found!"
+ fi
+}
+
+pkg_prerm() {
+ if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ install-catalog --remove \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/sgml-ent.cat
+
+ install-catalog --remove \
+ /etc/sgml/sgml-ent.cat \
+ /usr/share/sgml/sgml-iso-entities-8879.1986/catalog
+ fi
+}