summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-07 19:18:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-07 19:18:36 +0000
commit0a70aeb0d6fb4d0539590dee36faa4848de3c93e (patch)
tree87e3e061e0596f7bfd79875f17c06322e8e69425 /app-text/poppler/files
parentConvert media-libs/jpeg to virtual/jpeg (diff)
downloadhistorical-0a70aeb0d6fb4d0539590dee36faa4848de3c93e.tar.gz
historical-0a70aeb0d6fb4d0539590dee36faa4848de3c93e.tar.bz2
historical-0a70aeb0d6fb4d0539590dee36faa4848de3c93e.zip
punt files directory, all unused files
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'app-text/poppler/files')
-rw-r--r--app-text/poppler/files/poppler-0.12.3-cairo-downscale.patch529
-rw-r--r--app-text/poppler/files/poppler-0.12.3-cmake-disable-tests.patch79
-rw-r--r--app-text/poppler/files/poppler-0.12.3-darwin-gtk-link.patch14
-rw-r--r--app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch43
-rw-r--r--app-text/poppler/files/poppler-0.12.3-gdk.patch20
-rw-r--r--app-text/poppler/files/poppler-0.12.3-preserve-cflags.patch44
-rw-r--r--app-text/poppler/files/poppler-0.12.4-config.patch95
-rw-r--r--app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch43
-rw-r--r--app-text/poppler/files/poppler-0.12.4-strings_h.patch36
-rw-r--r--app-text/poppler/files/poppler-0.12.4-xopen_source.patch31
10 files changed, 0 insertions, 934 deletions
diff --git a/app-text/poppler/files/poppler-0.12.3-cairo-downscale.patch b/app-text/poppler/files/poppler-0.12.3-cairo-downscale.patch
deleted file mode 100644
index 8e0b798510e2..000000000000
--- a/app-text/poppler/files/poppler-0.12.3-cairo-downscale.patch
+++ /dev/null
@@ -1,529 +0,0 @@
-diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index 9a0f3be..42ac3a8 100644
---- a/poppler/CairoOutputDev.cc
-+++ b/poppler/CairoOutputDev.cc
-@@ -58,6 +58,7 @@
- #include <splash/SplashBitmap.h>
- #include "CairoOutputDev.h"
- #include "CairoFontEngine.h"
-+#include "CairoRescaleBox.h"
- //------------------------------------------------------------------------
-
- // #define LOG_CAIRO
-@@ -1331,6 +1332,82 @@ void CairoOutputDev::endMaskClip(GfxState *state) {
- clearSoftMask(state);
- }
-
-+cairo_surface_t *CairoOutputDev::downscaleSurface(cairo_surface_t *orig_surface) {
-+ cairo_surface_t *dest_surface;
-+ unsigned char *dest_buffer;
-+ int dest_stride;
-+ unsigned char *orig_buffer;
-+ int orig_width, orig_height;
-+ int orig_stride;
-+ GBool res;
-+
-+ if (printing)
-+ return NULL;
-+
-+ cairo_matrix_t matrix;
-+ cairo_get_matrix(cairo, &matrix);
-+
-+ /* this whole computation should be factored out */
-+ double xScale = matrix.xx;
-+ double yScale = matrix.yy;
-+ int tx, tx2, ty, ty2; /* the integer co-oridinates of the resulting image */
-+ int scaledHeight;
-+ int scaledWidth;
-+ if (xScale >= 0) {
-+ tx = splashRound(matrix.x0 - 0.01);
-+ tx2 = splashRound(matrix.x0 + xScale + 0.01) - 1;
-+ } else {
-+ tx = splashRound(matrix.x0 + 0.01) - 1;
-+ tx2 = splashRound(matrix.x0 + xScale - 0.01);
-+ }
-+ scaledWidth = abs(tx2 - tx) + 1;
-+ //scaledWidth = splashRound(fabs(xScale));
-+ if (scaledWidth == 0) {
-+ // technically, this should draw nothing, but it generally seems
-+ // better to draw a one-pixel-wide stripe rather than throwing it
-+ // away
-+ scaledWidth = 1;
-+ }
-+ if (yScale >= 0) {
-+ ty = splashFloor(matrix.y0 + 0.01);
-+ ty2 = splashCeil(matrix.y0 + yScale - 0.01);
-+ } else {
-+ ty = splashCeil(matrix.y0 - 0.01);
-+ ty2 = splashFloor(matrix.y0 + yScale + 0.01);
-+ }
-+ scaledHeight = abs(ty2 - ty);
-+ if (scaledHeight == 0) {
-+ scaledHeight = 1;
-+ }
-+
-+ orig_width = cairo_image_surface_get_width (orig_surface);
-+ orig_height = cairo_image_surface_get_height (orig_surface);
-+ if (scaledWidth >= orig_width || scaledHeight >= orig_height)
-+ return NULL;
-+
-+ dest_surface = cairo_surface_create_similar (orig_surface,
-+ cairo_surface_get_content (orig_surface),
-+ scaledWidth, scaledHeight);
-+ dest_buffer = cairo_image_surface_get_data (dest_surface);
-+ dest_stride = cairo_image_surface_get_stride (dest_surface);
-+
-+ orig_buffer = cairo_image_surface_get_data (orig_surface);
-+ orig_stride = cairo_image_surface_get_stride (orig_surface);
-+
-+ res = downscale_box_filter((uint32_t *)orig_buffer,
-+ orig_stride, orig_width, orig_height,
-+ scaledWidth, scaledHeight, 0, 0,
-+ scaledWidth, scaledHeight,
-+ (uint32_t *)dest_buffer, dest_stride);
-+ if (!res) {
-+ cairo_surface_destroy (dest_surface);
-+ return NULL;
-+ }
-+
-+ return dest_surface;
-+
-+}
-+
- void CairoOutputDev::drawImageMask(GfxState *state, Object *ref, Stream *str,
- int width, int height, GBool invert,
- GBool interpolate, GBool inlineImg) {
-@@ -2094,6 +2171,18 @@ void CairoOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
- }
- gfree(lookup);
-
-+ cairo_surface_t *scaled_surface;
-+
-+ scaled_surface = downscaleSurface (image);
-+ if (scaled_surface) {
-+ if (cairo_surface_status (scaled_surface))
-+ goto cleanup;
-+ cairo_surface_destroy (image);
-+ image = scaled_surface;
-+ width = cairo_image_surface_get_width (image);
-+ height = cairo_image_surface_get_height (image);
-+ }
-+
- cairo_surface_mark_dirty (image);
- pattern = cairo_pattern_create_for_surface (image);
- cairo_surface_destroy (image);
-diff --git a/poppler/CairoOutputDev.h b/poppler/CairoOutputDev.h
-index fb9c0d7..266f0cb 100644
---- a/poppler/CairoOutputDev.h
-+++ b/poppler/CairoOutputDev.h
-@@ -268,6 +268,7 @@ public:
-
- protected:
- void doPath(cairo_t *cairo, GfxState *state, GfxPath *path);
-+ cairo_surface_t *downscaleSurface(cairo_surface_t *orig_surface);
-
- GfxRGB fill_color, stroke_color;
- cairo_pattern_t *fill_pattern, *stroke_pattern;
-diff --git a/poppler/CairoRescaleBox.cc b/poppler/CairoRescaleBox.cc
-new file mode 100644
-index 0000000..dce5ddd
---- /dev/null
-+++ b/poppler/CairoRescaleBox.cc
-@@ -0,0 +1,352 @@
-+/* -*- Mode: c; c-basic-offset: 4; tab-width: 8; indent-tabs-mode: t; -*- */
-+/*
-+ * Copyright © 2009 Mozilla Corporation
-+ *
-+ * Permission to use, copy, modify, distribute, and sell this software and its
-+ * documentation for any purpose is hereby granted without fee, provided that
-+ * the above copyright notice appear in all copies and that both that
-+ * copyright notice and this permission notice appear in supporting
-+ * documentation, and that the name of Mozilla Corporation not be used in
-+ * advertising or publicity pertaining to distribution of the software without
-+ * specific, written prior permission. Mozilla Corporation makes no
-+ * representations about the suitability of this software for any purpose. It
-+ * is provided "as is" without express or implied warranty.
-+ *
-+ * MOZILLA CORPORATION DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-+ * INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT
-+ * SHALL MOZILLA CORPORATION BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-+ * CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
-+ * DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
-+ * TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
-+ * OF THIS SOFTWARE.
-+ *
-+ * Author: Jeff Muizelaar, Mozilla Corp.
-+ */
-+
-+/* This implements a box filter that supports non-integer box sizes */
-+
-+#ifdef HAVE_CONFIG_H
-+#include <config.h>
-+#endif
-+
-+#include <stdint.h>
-+#include <stdio.h>
-+#include <assert.h>
-+#include <stdlib.h>
-+#include <math.h>
-+#include "goo/gmem.h"
-+#include "CairoRescaleBox.h"
-+
-+typedef unsigned short int uint16_t;
-+typedef unsigned int uint32_t;
-+
-+/* we work in fixed point where 1. == 1 << 24 */
-+#define FIXED_SHIFT 24
-+
-+static void downsample_row_box_filter (
-+ int start, int width,
-+ uint32_t *src, uint32_t *dest,
-+ int coverage[], int pixel_coverage)
-+{
-+ /* we need an array of the pixel contribution of each destination pixel on the boundaries.
-+ * we invert the value to get the value on the other size of the box */
-+ /*
-+
-+ value = a * contribution * 1/box_size
-+ value += a * 1/box_size
-+ value += a * 1/box_size
-+ value += a * 1/box_size
-+ value += a * (1 - contribution) * 1/box_size
-+ a * (1/box_size - contribution * 1/box_size)
-+
-+ box size is constant
-+
-+
-+ value = a * contribtion_a * 1/box_size + b * contribution_b * 1/box_size
-+ contribution_b = (1 - contribution_a)
-+ = (1 - contribution_a_next)
-+ */
-+
-+ /* box size = ceil(src_width/dest_width) */
-+ int x = 0;
-+
-+ /* skip to start */
-+ /* XXX: it might be possible to do this directly instead of iteratively, however
-+ * the iterative solution is simple */
-+ while (x < start)
-+ {
-+ int box = 1 << FIXED_SHIFT;
-+ int start_coverage = coverage[x];
-+ box -= start_coverage;
-+ src++;
-+ while (box >= pixel_coverage)
-+ {
-+ src++;
-+ box -= pixel_coverage;
-+ }
-+ x++;
-+ }
-+
-+ while (x < start + width)
-+ {
-+ uint32_t a = 0;
-+ uint32_t r = 0;
-+ uint32_t g = 0;
-+ uint32_t b = 0;
-+ int box = 1 << FIXED_SHIFT;
-+ int start_coverage = coverage[x];
-+
-+ a = ((*src >> 24) & 0xff) * start_coverage;
-+ r = ((*src >> 16) & 0xff) * start_coverage;
-+ g = ((*src >> 8) & 0xff) * start_coverage;
-+ b = ((*src >> 0) & 0xff) * start_coverage;
-+ src++;
-+ x++;
-+ box -= start_coverage;
-+
-+ while (box >= pixel_coverage)
-+ {
-+ a += ((*src >> 24) & 0xff) * pixel_coverage;
-+ r += ((*src >> 16) & 0xff) * pixel_coverage;
-+ g += ((*src >> 8) & 0xff) * pixel_coverage;
-+ b += ((*src >> 0) & 0xff) * pixel_coverage;
-+ src++;
-+
-+ box -= pixel_coverage;
-+ }
-+
-+ /* multiply by whatever is leftover
-+ * this ensures that we don't bias down.
-+ * i.e. start_coverage + n*pixel_coverage + box == 1 << 24 */
-+ if (box > 0)
-+ {
-+ a += ((*src >> 24) & 0xff) * box;
-+ r += ((*src >> 16) & 0xff) * box;
-+ g += ((*src >> 8) & 0xff) * box;
-+ b += ((*src >> 0) & 0xff) * box;
-+ }
-+
-+ a >>= FIXED_SHIFT;
-+ r >>= FIXED_SHIFT;
-+ g >>= FIXED_SHIFT;
-+ b >>= FIXED_SHIFT;
-+
-+ *dest = (a << 24) | (r << 16) | (g << 8) | b;
-+ dest++;
-+ }
-+}
-+
-+static void downsample_columns_box_filter (
-+ int n,
-+ int start_coverage,
-+ int pixel_coverage,
-+ uint32_t *src, uint32_t *dest)
-+{
-+ int stride = n;
-+ while (n--) {
-+ uint32_t a = 0;
-+ uint32_t r = 0;
-+ uint32_t g = 0;
-+ uint32_t b = 0;
-+ uint32_t *column_src = src;
-+ int box = 1 << FIXED_SHIFT;
-+
-+ a = ((*column_src >> 24) & 0xff) * start_coverage;
-+ r = ((*column_src >> 16) & 0xff) * start_coverage;
-+ g = ((*column_src >> 8) & 0xff) * start_coverage;
-+ b = ((*column_src >> 0) & 0xff) * start_coverage;
-+ column_src += stride;
-+ box -= start_coverage;
-+
-+ while (box >= pixel_coverage)
-+ {
-+ a += ((*column_src >> 24) & 0xff) * pixel_coverage;
-+ r += ((*column_src >> 16) & 0xff) * pixel_coverage;
-+ g += ((*column_src >> 8) & 0xff) * pixel_coverage;
-+ b += ((*column_src >> 0) & 0xff) * pixel_coverage;
-+ column_src += stride;
-+ box -= pixel_coverage;
-+ }
-+
-+ if (box > 0) {
-+ a += ((*column_src >> 24) & 0xff) * box;
-+ r += ((*column_src >> 16) & 0xff) * box;
-+ g += ((*column_src >> 8) & 0xff) * box;
-+ b += ((*column_src >> 0) & 0xff) * box;
-+ }
-+
-+ a >>= FIXED_SHIFT;
-+ r >>= FIXED_SHIFT;
-+ g >>= FIXED_SHIFT;
-+ b >>= FIXED_SHIFT;
-+
-+ *dest = (a << 24) | (r << 16) | (g << 8) | b;
-+ dest++;
-+ src++;
-+ }
-+}
-+
-+static int compute_coverage (int coverage[], int src_length, int dest_length)
-+{
-+ int i;
-+ /* num = src_length/dest_length
-+ total = sum(pixel) / num
-+
-+ pixel * 1/num == pixel * dest_length / src_length
-+ */
-+ /* the average contribution of each source pixel */
-+ int ratio = ((1 << 24)*(long long int)dest_length)/src_length;
-+ /* because ((1 << 24)*(long long int)dest_length) won't always be divisible by src_length
-+ * we'll need someplace to put the other bits.
-+ *
-+ * We want to ensure a + n*ratio < 1<<24
-+ *
-+ * 1<<24
-+ * */
-+
-+ double scale = (double)src_length/dest_length;
-+
-+ /* for each destination pixel compute the coverage of the left most pixel included in the box */
-+ /* I have a proof of this, which this margin is too narrow to contain */
-+ for (i=0; i<dest_length; i++)
-+ {
-+ float left_side = i*scale;
-+ float right_side = (i+1)*scale;
-+ float right_fract = right_side - floor (right_side);
-+ float left_fract = ceil (left_side) - left_side;
-+ int overage;
-+ /* find out how many source pixels will be used to fill the box */
-+ int count = floor (right_side) - ceil (left_side);
-+ /* what's the maximum value this expression can become?
-+ floor((i+1)*scale) - ceil(i*scale)
-+
-+ (i+1)*scale - i*scale == scale
-+
-+ since floor((i+1)*scale) <= (i+1)*scale
-+ and ceil(i*scale) >= i*scale
-+
-+ floor((i+1)*scale) - ceil(i*scale) <= scale
-+
-+ further since: floor((i+1)*scale) - ceil(i*scale) is an integer
-+
-+ therefore:
-+ floor((i+1)*scale) - ceil(i*scale) <= floor(scale)
-+ */
-+
-+ if (left_fract == 0.)
-+ count--;
-+
-+ /* compute how much the right-most pixel contributes */
-+ overage = ratio*(right_fract);
-+
-+ /* the remainder is the the amount that the left-most pixel
-+ * contributes */
-+ coverage[i] = (1<<24) - (count * ratio + overage);
-+ }
-+
-+ return ratio;
-+}
-+
-+GBool downscale_box_filter(uint32_t *orig, int orig_stride, unsigned orig_width, unsigned orig_height,
-+ signed scaled_width, signed scaled_height,
-+ uint16_t start_column, uint16_t start_row,
-+ uint16_t width, uint16_t height,
-+ uint32_t *dest, int dst_stride)
-+{
-+ int pixel_coverage_x, pixel_coverage_y;
-+ int dest_y;
-+ int src_y = 0;
-+ uint32_t *scanline = orig;
-+ int *x_coverage = NULL;
-+ int *y_coverage = NULL;
-+ uint32_t *temp_buf = NULL;
-+ GBool retval = gFalse;
-+
-+ x_coverage = (int *)gmallocn3 (orig_width, 1, sizeof(int));
-+ y_coverage = (int *)gmallocn3 (orig_height, 1, sizeof(int));
-+
-+ /* we need to allocate enough room for ceil(src_height/dest_height)+1
-+ Example:
-+ src_height = 140
-+ dest_height = 50
-+ src_height/dest_height = 2.8
-+
-+ |-------------| 2.8 pixels
-+ |----|----|----|----| 4 pixels
-+ need to sample 3 pixels
-+
-+ |-------------| 2.8 pixels
-+ |----|----|----|----| 4 pixels
-+ need to sample 4 pixels
-+ */
-+
-+ temp_buf = (uint32_t *)gmallocn3 ((orig_height + scaled_height-1)/scaled_height+1, scaled_width, sizeof(uint32_t));
-+
-+ if (!x_coverage || !y_coverage || !scanline || !temp_buf)
-+ goto cleanup;
-+
-+ pixel_coverage_x = compute_coverage (x_coverage, orig_width, scaled_width);
-+ pixel_coverage_y = compute_coverage (y_coverage, orig_height, scaled_height);
-+
-+ assert (width + start_column <= scaled_width);
-+
-+ /* skip the rows at the beginning */
-+ for (dest_y = 0; dest_y < start_row; dest_y++)
-+ {
-+ int box = 1 << FIXED_SHIFT;
-+ int start_coverage_y = y_coverage[dest_y];
-+ box -= start_coverage_y;
-+ src_y++;
-+ while (box >= pixel_coverage_y)
-+ {
-+ box -= pixel_coverage_y;
-+ src_y++;
-+ }
-+ }
-+
-+ for (; dest_y < start_row + height; dest_y++)
-+ {
-+ int columns = 0;
-+ int box = 1 << FIXED_SHIFT;
-+ int start_coverage_y = y_coverage[dest_y];
-+
-+ scanline = orig + src_y * orig_stride / 4;
-+ downsample_row_box_filter (start_column, width, scanline, temp_buf + width * columns, x_coverage, pixel_coverage_x);
-+ columns++;
-+ src_y++;
-+ box -= start_coverage_y;
-+
-+ while (box >= pixel_coverage_y)
-+ {
-+ scanline = orig + src_y * orig_stride / 4;
-+ downsample_row_box_filter (start_column, width, scanline, temp_buf + width * columns, x_coverage, pixel_coverage_x);
-+ columns++;
-+ src_y++;
-+ box -= pixel_coverage_y;
-+ }
-+
-+ /* downsample any leftovers */
-+ if (box > 0)
-+ {
-+ scanline = orig + src_y * orig_stride / 4;
-+ downsample_row_box_filter (start_column, width, scanline, temp_buf + width * columns, x_coverage, pixel_coverage_x);
-+ columns++;
-+ }
-+
-+ /* now scale the rows we just downsampled in the y direction */
-+ downsample_columns_box_filter (width, start_coverage_y, pixel_coverage_y, temp_buf, dest);
-+ dest += dst_stride / 4;
-+
-+// assert(width*columns <= ((orig_height + scaled_height-1)/scaled_height+1) * width);
-+ }
-+// assert (src_y<=orig_height);
-+
-+ retval = gTrue;
-+
-+cleanup:
-+ free (x_coverage);
-+ free (y_coverage);
-+ free (temp_buf);
-+
-+ return gTrue;
-+}
-diff --git a/poppler/CairoRescaleBox.h b/poppler/CairoRescaleBox.h
-new file mode 100644
-index 0000000..5349c87
---- /dev/null
-+++ b/poppler/CairoRescaleBox.h
-@@ -0,0 +1,12 @@
-+#ifndef CAIRO_RESCALE_BOX_H
-+#define CAIRO_RESCALE_BOX_H
-+
-+#include "goo/gtypes.h"
-+
-+GBool downscale_box_filter(unsigned int *orig, int orig_stride, unsigned orig_width, unsigned orig_height,
-+ signed scaled_width, signed scaled_height,
-+ unsigned short int start_column, unsigned short int start_row,
-+ unsigned short int width, unsigned short int height,
-+ unsigned int *dest, int dst_stride);
-+
-+#endif /* CAIRO_RESCALE_BOX_H */
-diff --git a/poppler/Makefile.am b/poppler/Makefile.am
-index ec79e31..096ea76 100644
---- a/poppler/Makefile.am
-+++ b/poppler/Makefile.am
-@@ -47,7 +47,9 @@ libpoppler_cairo_la_SOURCES = \
- CairoFontEngine.cc \
- CairoFontEngine.h \
- CairoOutputDev.cc \
-- CairoOutputDev.h
-+ CairoOutputDev.h \
-+ CairoRescaleBox.cc \
-+ CairoRescaleBox.h
-
- endif
-
-diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
-index 6ed9523..ceef25e 100644
---- a/glib/CMakeLists.txt
-+++ b/glib/CMakeLists.txt
-@@ -90,6 +90,7 @@ if (CAIRO_FOUND)
- set(poppler_glib_SRCS ${poppler_glib_SRCS}
- ${CMAKE_SOURCE_DIR}/poppler/CairoFontEngine.cc
- ${CMAKE_SOURCE_DIR}/poppler/CairoOutputDev.cc
-+ ${CMAKE_SOURCE_DIR}/poppler/CairoRescaleBox.cc
- )
- endif (CAIRO_FOUND)
- add_library(poppler-glib SHARED ${poppler_glib_SRCS})
diff --git a/app-text/poppler/files/poppler-0.12.3-cmake-disable-tests.patch b/app-text/poppler/files/poppler-0.12.3-cmake-disable-tests.patch
deleted file mode 100644
index 3da19bb51866..000000000000
--- a/app-text/poppler/files/poppler-0.12.3-cmake-disable-tests.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From 4fd0aae36004d48736673a8c6c40bb880e2e87e4 Mon Sep 17 00:00:00 2001
-From: Maciej Mrozowski <reavertm@gmail.com>
-Date: Sat, 23 Jan 2010 06:51:16 +0100
-Subject: [PATCH] [CMake] Fix building with glib or Qt4 tests disabled. This is workaround to be honest and needs
- poppler_add_test macro fixed
-
----
- glib/CMakeLists.txt | 8 ++++----
- qt4/CMakeLists.txt | 6 ++++--
- test/CMakeLists.txt | 4 ++--
- 3 files changed, 10 insertions(+), 8 deletions(-)
-
-diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
-index 6ed9523..c6b3922 100644
---- a/glib/CMakeLists.txt
-+++ b/glib/CMakeLists.txt
-@@ -18,9 +18,9 @@ endif (GDK_FOUND)
-
- configure_file(poppler-features.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/poppler-features.h @ONLY)
-
--if (GTK_FOUND)
-+if (GTK_FOUND AND BUILD_GTK_TESTS)
- add_subdirectory(demo)
--endif (GTK_FOUND)
-+endif (GTK_FOUND AND BUILD_GTK_TESTS)
-
- set(poppler_glib_public_headers
- poppler-action.h
-@@ -107,11 +107,11 @@ install(FILES
- DESTINATION include/poppler/glib)
-
-
--if (GDK_FOUND)
-+if (GDK_FOUND AND BUILD_GTK_TESTS)
- set(test_poppler_glib_SRCS
- test-poppler-glib.cc
- )
- poppler_add_test(test-poppler-glib BUILD_GTK_TESTS ${test_poppler_glib_SRCS})
- target_link_libraries(test-poppler-glib poppler-glib ${GDK2_LIBRARIES})
--endif (GDK_FOUND)
-+endif (GDK_FOUND AND BUILD_GTK_TESTS)
-
-diff --git a/qt4/CMakeLists.txt b/qt4/CMakeLists.txt
-index a364abf..461ed77 100644
---- a/qt4/CMakeLists.txt
-+++ b/qt4/CMakeLists.txt
-@@ -1,3 +1,5 @@
- add_subdirectory(src)
--add_subdirectory(tests)
--add_subdirectory(demos)
-+if(BUILD_QT4_TESTS)
-+ add_subdirectory(tests)
-+ add_subdirectory(demos)
-+endif(BUILD_QT4_TESTS)
-diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
-index 478cb31..2c6ec36 100644
---- a/test/CMakeLists.txt
-+++ b/test/CMakeLists.txt
-@@ -10,7 +10,7 @@ if (ENABLE_SPLASH)
-
- endif (ENABLE_SPLASH)
-
--if (GTK_FOUND)
-+if (GTK_FOUND AND BUILD_GTK_TESTS)
-
- add_definitions(${GTK2_CFLAGS})
-
-@@ -41,7 +41,7 @@ if (GTK_FOUND)
-
- endif (HAVE_CAIRO)
-
--endif (GTK_FOUND)
-+endif (GTK_FOUND AND BUILD_GTK_TESTS)
-
- set (pdf_fullrewrite_SRCS
- pdf-fullrewrite.cc
---
-1.6.4.4
-
diff --git a/app-text/poppler/files/poppler-0.12.3-darwin-gtk-link.patch b/app-text/poppler/files/poppler-0.12.3-darwin-gtk-link.patch
deleted file mode 100644
index d66f98e8c64d..000000000000
--- a/app-text/poppler/files/poppler-0.12.3-darwin-gtk-link.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.freedesktop.org/show_bug.cgi?id=26442
-
---- glib/CMakeLists.txt
-+++ glib/CMakeLists.txt
-@@ -100,6 +100,9 @@
- if (CAIRO_FOUND)
- target_link_libraries(poppler-glib ${CAIRO_LIBRARIES})
- endif (CAIRO_FOUND)
-+if (GDK_FOUND)
-+ target_link_libraries(poppler-glib ${GDK2_LIBRARIES})
-+endif (GDK_FOUND)
- install(TARGETS poppler-glib RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX})
-
- install(FILES
diff --git a/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch b/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch
deleted file mode 100644
index c382a0a34293..000000000000
--- a/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0cd32df..070be33 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -363,6 +363,11 @@ if(ENABLE_XPDF_HEADERS)
- goo/FixedPoint.h
- goo/gstrtod.h
- DESTINATION include/poppler/goo)
-+ if(PNG_FOUND)
-+ install(FILES
-+ goo/PNGWriter.h
-+ DESTINATION include/poppler/goo)
-+ endif(PNG_FOUND)
- install(FILES
- fofi/FoFiBase.h
- fofi/FoFiEncodings.h
-
-diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
-index 6ed9523..9f5d0e7 100644
---- a/glib/CMakeLists.txt
-+++ b/glib/CMakeLists.txt
-@@ -30,6 +30,7 @@ set(poppler_glib_public_headers
- poppler-attachment.h
- poppler-form-field.h
- poppler-annot.h
-+ poppler-layer.h
- poppler.h
- )
-
-diff --git a/qt4/src/Makefile.am b/qt4/src/Makefile.am
-index 7e982e7..10ac221 100644
---- a/qt4/src/Makefile.am
-+++ b/qt4/src/Makefile.am
-@@ -16,8 +16,7 @@ poppler_include_HEADERS = \
- poppler-form.h \
- poppler-optcontent.h \
- poppler-export.h \
-- poppler-page-transition.h \
-- poppler-page-transition-private.h
-+ poppler-page-transition.h
-
- lib_LTLIBRARIES = libpoppler-qt4.la
-
diff --git a/app-text/poppler/files/poppler-0.12.3-gdk.patch b/app-text/poppler/files/poppler-0.12.3-gdk.patch
deleted file mode 100644
index d3881e075a8e..000000000000
--- a/app-text/poppler/files/poppler-0.12.3-gdk.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- glib/poppler-features.h.cmake.orig 2009-09-09 23:22:31.000000000 +0200
-+++ glib/poppler-features.h.cmake 2010-01-26 23:36:17.518737903 +0100
-@@ -20,6 +20,7 @@
- #define __POPPLER_FEATURES_H__
-
- @CAIRO_FEATURE@
-+@GDK_FEATURE@
-
- #define POPPLER_MAJOR_VERSION (@POPPLER_MAJOR_VERSION@)
- #define POPPLER_MINOR_VERSION (@POPPLER_MINOR_VERSION@)
---- glib/CMakeLists.txt.orig 2010-01-26 23:40:40.719242931 +0100
-+++ glib/CMakeLists.txt 2010-01-26 23:48:30.107752041 +0100
-@@ -13,6 +13,7 @@
- endif (CAIRO_FOUND)
-
- if (GDK_FOUND)
-+ set (GDK_FEATURE "#define POPPLER_WITH_GDK 1")
- add_definitions(${GDK2_CFLAGS})
- endif (GDK_FOUND)
-
diff --git a/app-text/poppler/files/poppler-0.12.3-preserve-cflags.patch b/app-text/poppler/files/poppler-0.12.3-preserve-cflags.patch
deleted file mode 100644
index ddbf642e628e..000000000000
--- a/app-text/poppler/files/poppler-0.12.3-preserve-cflags.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -ru ../poppler-0.12.3/cmake/modules/PopplerMacros.cmake ./cmake/modules/PopplerMacros.cmake
---- ../poppler-0.12.3/cmake/modules/PopplerMacros.cmake 2009-10-05 00:20:41.000000000 +0200
-+++ ./cmake/modules/PopplerMacros.cmake 2010-04-10 03:57:46.763786638 +0200
-@@ -86,12 +86,9 @@
- endif(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
-
- if(CMAKE_COMPILER_IS_GNUCXX)
-- # set the default compile warnings
-- set(DEFAULT_COMPILE_WARNINGS_NO)
-- set(DEFAULT_COMPILE_WARNINGS_YES "-Wall -Wno-write-strings")
-- set(DEFAULT_COMPILE_WARNINGS_KDE "-Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common")
--
-- set(CMAKE_CXX_FLAGS "-Woverloaded-virtual")
-+ set(CMAKE_C_FLAGS "-Wall -Wno-write-strings -Wno-long-long -Wundef -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common ${CMAKE_C_FLAGS}")
-+ set(CMAKE_CXX_FLAGS "-Wall -Woverloaded-virtual -Wno-write-strings -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-check-new -fno-common ${CMAKE_CXX_FLAGS}")
-+ add_definitions(-D_XOPEN_SOURCE=500 -D_BSD_SOURCE)
- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
- set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG")
- set(CMAKE_CXX_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
-diff -ru ../poppler-0.12.3/CMakeLists.txt ./CMakeLists.txt
---- ../poppler-0.12.3/CMakeLists.txt 2009-12-24 11:50:12.000000000 +0100
-+++ ./CMakeLists.txt 2010-04-10 03:29:23.799102761 +0200
-@@ -115,21 +115,6 @@
- include_directories(${LCMS_INCLUDE_DIR})
- endif(LCMS_FOUND)
-
--if(DEFINED COMPILE_WARNINGS)
--else(DEFINED COMPILE_WARNINGS)
-- set(COMPILE_WARNINGS "yes")
--endif(DEFINED COMPILE_WARNINGS)
--string(TOLOWER "${COMPILE_WARNINGS}" _comp_warnings)
--if(_comp_warnings STREQUAL "no")
-- add_definitions(${DEFAULT_COMPILE_WARNINGS_NO})
--endif(_comp_warnings STREQUAL "no")
--if(_comp_warnings STREQUAL "yes")
-- add_definitions(${DEFAULT_COMPILE_WARNINGS_YES})
--endif(_comp_warnings STREQUAL "yes")
--if(_comp_warnings STREQUAL "kde")
-- set(CMAKE_CXX_FLAGS "${DEFAULT_COMPILE_WARNINGS_KDE} ${CMAKE_CXX_FLAGS}")
--endif(_comp_warnings STREQUAL "kde")
--
-
- include(ConfigureChecks.cmake)
- configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
diff --git a/app-text/poppler/files/poppler-0.12.4-config.patch b/app-text/poppler/files/poppler-0.12.4-config.patch
deleted file mode 100644
index 0449e3f4ca44..000000000000
--- a/app-text/poppler/files/poppler-0.12.4-config.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-diff -urN poppler-0.12.3.sav/poppler/poppler-config.h poppler-0.12.3/poppler/poppler-config.h
---- poppler-0.12.3.sav/poppler/poppler-config.h 2009-12-24 11:51:39.000000000 +0100
-+++ poppler-0.12.3/poppler/poppler-config.h 1970-01-01 01:00:00.000000000 +0100
-@@ -1,91 +0,0 @@
--/* poppler/poppler-config.h. Generated from poppler-config.h.in by configure. */
--//================================================= -*- mode: c++ -*- ====
--//
--// poppler-config.h
--//
--// Copyright 1996-2004 Glyph & Cog, LLC
--//
--//========================================================================
--
--#ifndef POPPLER_CONFIG_H
--#define POPPLER_CONFIG_H
--
--// We duplicate some of the config.h #define's here since they are
--// used in some of the header files we install. The #ifndef/#endif
--// around #undef look odd, but it's to silence warnings about
--// redefining those symbols.
--
--/* Enable multithreading support. */
--#ifndef MULTITHREADED
--#define MULTITHREADED 1
--#endif
--
--/* Enable exceptions. */
--#ifndef USE_EXCEPTIONS
--/* #undef USE_EXCEPTIONS */
--#endif
--
--/* Use fixedpoint. */
--#ifndef USE_FIXEDPOINT
--/* #undef USE_FIXEDPOINT */
--#endif
--
--/* Include support for OPI comments. */
--#ifndef OPI_SUPPORT
--#define OPI_SUPPORT 1
--#endif
--
--/* Enable word list support. */
--#ifndef TEXTOUT_WORD_LIST
--#define TEXTOUT_WORD_LIST 1
--#endif
--
--// Also, there's a couple of preprocessor symbols in the header files
--// that are used but never defined: DISABLE_OUTLINE, DEBUG_MEM and
--
--//------------------------------------------------------------------------
--// version
--//------------------------------------------------------------------------
--
--// copyright notice
--#define popplerCopyright "Copyright 2005-2009 The Poppler Developers - http://poppler.freedesktop.org"
--#define xpdfCopyright "Copyright 1996-2004 Glyph & Cog, LLC"
--
--//------------------------------------------------------------------------
--// popen
--//------------------------------------------------------------------------
--
--#if defined(_MSC_VER) || defined(__BORLANDC__)
--#define popen _popen
--#define pclose _pclose
--#endif
--
--#if defined(VMS) || defined(VMCMS) || defined(DOS) || defined(OS2) || defined(__EMX__) || defined(_WIN32) || defined(__DJGPP__) || defined(MACOS)
--#define POPEN_READ_MODE "rb"
--#else
--#define POPEN_READ_MODE "r"
--#endif
--
--//------------------------------------------------------------------------
--// Win32 stuff
--//------------------------------------------------------------------------
--
--#if defined(_WIN32) && !defined(_MSC_VER)
--#include <windef.h>
--#else
--#define CDECL
--#endif
--
--//------------------------------------------------------------------------
--// Compiler
--//------------------------------------------------------------------------
--
--#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ > 4)
--#define GCC_PRINTF_FORMAT(fmt_index, va_index) \
-- __attribute__((__format__(__printf__, fmt_index, va_index)))
--#else
--#define GCC_PRINTF_FORMAT(fmt_index, va_index)
--#endif
--
--
--#endif /* POPPLER_CONFIG_H */
diff --git a/app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch b/app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch
deleted file mode 100644
index a2843bfd7f6e..000000000000
--- a/app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-http://bugs.freedesktop.org/show_bug.cgi?id=26650
-
-diff --git a/ConfigureChecks.cmake b/ConfigureChecks.cmake
-index 6049c9a..04de970 100644
---- a/ConfigureChecks.cmake
-+++ b/ConfigureChecks.cmake
-@@ -49,3 +49,8 @@ check_for_dir("dirent.h" HAVE_DIRENT_H)
- check_for_dir("ndir.h" HAVE_NDIR_H)
- check_for_dir("sys/dir.h" HAVE_SYS_DIR_H)
- check_for_dir("sys/ndir.h" HAVE_SYS_NDIR_H)
-+
-+check_function_exists("nanosleep" HAVE_NANOSLEEP)
-+if(NOT HAVE_NANOSLEEP)
-+ check_library_exists("rt" "nanosleep" "" LIB_RT_HAS_NANOSLEEP)
-+endif(NOT HAVE_NANOSLEEP)
-diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
-index 2c6ec36..eada899 100644
---- a/test/CMakeLists.txt
-+++ b/test/CMakeLists.txt
-@@ -1,12 +1,17 @@
-
- if (ENABLE_SPLASH)
-
-- set (perf_test_SRCS
-- perf-test.cc
-- perf-test-preview-dummy.cc
-- )
-- add_executable(perf-test ${perf_test_SRCS})
-- target_link_libraries(perf-test poppler)
-+ if (HAVE_NANOSLEEP OR LIB_RT_HAS_NANOSLEEP)
-+ set (perf_test_SRCS
-+ perf-test.cc
-+ perf-test-preview-dummy.cc
-+ )
-+ add_executable(perf-test ${perf_test_SRCS})
-+ target_link_libraries(perf-test poppler)
-+ if (LIB_RT_HAS_NANOSLEEP)
-+ target_link_libraries(perf-test rt)
-+ endif (LIB_RT_HAS_NANOSLEEP)
-+ endif (HAVE_NANOSLEEP OR LIB_RT_HAS_NANOSLEEP)
-
- endif (ENABLE_SPLASH)
-
diff --git a/app-text/poppler/files/poppler-0.12.4-strings_h.patch b/app-text/poppler/files/poppler-0.12.4-strings_h.patch
deleted file mode 100644
index 49dea9178ba3..000000000000
--- a/app-text/poppler/files/poppler-0.12.4-strings_h.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 4cce1f14e964edf1bf2d9fb8286ee002a67dc212 Mon Sep 17 00:00:00 2001
-From: Albert Astals Cid <aacid@kde.org>
-Date: Tue, 13 Apr 2010 20:57:16 +0000
-Subject: include strings.h on non windows platforms
-
-See also https://bugs.freedesktop.org/show_bug.cgi?id=27610
-and http://bugs.gentoo.org/show_bug.cgi?id=314925
----
-diff --git a/poppler/GlobalParams.cc b/poppler/GlobalParams.cc
-index 09a1b20..bf79585 100644
---- a/poppler/GlobalParams.cc
-+++ b/poppler/GlobalParams.cc
-@@ -68,6 +68,8 @@
-
- #ifdef _WIN32
- # define strcasecmp stricmp
-+#else
-+# include <strings.h>
- #endif
-
- #if MULTITHREADED
-diff --git a/test/perf-test.cc b/test/perf-test.cc
-index a11a377..6d6961e 100644
---- a/test/perf-test.cc
-+++ b/test/perf-test.cc
-@@ -22,6 +22,8 @@
-
- #ifdef _WIN32
- #include <windows.h>
-+#else
-+#include <strings.h>
- #endif
-
- // Define COPY_FILE if you want the file to be copied to a local disk first
---
-cgit v0.8.3-6-g21f6
diff --git a/app-text/poppler/files/poppler-0.12.4-xopen_source.patch b/app-text/poppler/files/poppler-0.12.4-xopen_source.patch
deleted file mode 100644
index b02400b07b64..000000000000
--- a/app-text/poppler/files/poppler-0.12.4-xopen_source.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From a8d43ec1c7f5448a7f63d9bbd9062d56ee1c7c58 Mon Sep 17 00:00:00 2001
-From: Albert Astals Cid <aacid@kde.org>
-Date: Wed, 14 Apr 2010 18:21:33 +0000
-Subject: update XOPEN_SOURCE to 600 in non standard compile options
-
-it seems helps compiling on some BSD
-See also https://bugs.freedesktop.org/show_bug.cgi?id=27610
-and http://bugs.gentoo.org/show_bug.cgi?id=314925
-
---- poppler-0.12.4.orig/cmake/modules/PopplerMacros.cmake
-+++ poppler-0.12.4/cmake/modules/PopplerMacros.cmake
-@@ -88,7 +88,7 @@
- if(CMAKE_COMPILER_IS_GNUCXX)
- set(CMAKE_C_FLAGS "-Wall -Wno-write-strings -Wno-long-long -Wundef -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common ${CMAKE_C_FLAGS}")
- set(CMAKE_CXX_FLAGS "-Wall -Woverloaded-virtual -Wno-write-strings -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-check-new -fno-common ${CMAKE_CXX_FLAGS}")
-- add_definitions(-D_XOPEN_SOURCE=500 -D_BSD_SOURCE)
-+ add_definitions(-D_XOPEN_SOURCE=600 -D_BSD_SOURCE)
- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
- set(CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG")
- set(CMAKE_CXX_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
---- poppler-0.12.4.orig/configure.ac
-+++ poppler-0.12.4/configure.ac
-@@ -512,7 +512,7 @@
- no) ;;
- yes) CXXFLAGS="-Wall -Wno-write-strings -Woverloaded-virtual $CXXFLAGS" ;;
- kde) CXXFLAGS="-Wnon-virtual-dtor -Wno-long-long -Wundef -ansi \
-- -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align \
-+ -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -Wcast-align \
- -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith \
- -Wwrite-strings -O2 -Wformat-security \
- -Wmissing-format-attribute -fno-exceptions -fno-check-new \