summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-08-11 08:15:36 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-08-11 08:15:36 +0000
commit13081def57ddf16534dbd3d46bbf544ab5891dbf (patch)
treeb87d6fc3786e8845733f33e0a72343a1eaf49a63 /app-text/ghostscript
parentmove fonts to /usr/share/fonts/ghostscript (diff)
downloadhistorical-13081def57ddf16534dbd3d46bbf544ab5891dbf.tar.gz
historical-13081def57ddf16534dbd3d46bbf544ab5891dbf.tar.bz2
historical-13081def57ddf16534dbd3d46bbf544ab5891dbf.zip
apply fontconfig patch by default, move fonts to /usr/share/fonts/ghostscript
Diffstat (limited to 'app-text/ghostscript')
-rw-r--r--app-text/ghostscript/ChangeLog8
-rw-r--r--app-text/ghostscript/files/digest-ghostscript-7.07.1-r54
-rw-r--r--app-text/ghostscript/ghostscript-7.07.1-r5.ebuild134
3 files changed, 145 insertions, 1 deletions
diff --git a/app-text/ghostscript/ChangeLog b/app-text/ghostscript/ChangeLog
index d9d32afc1bd4..1290efd75d89 100644
--- a/app-text/ghostscript/ChangeLog
+++ b/app-text/ghostscript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/ghostscript
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.63 2004/08/09 11:28:43 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.64 2004/08/11 08:15:36 lanius Exp $
+
+*ghostscript-7.07.1-r5 (11 Aug 2004)
+
+ 11 Aug 2004; Heinrich Wendel <lanius@gentoo.org>
+ ghostscript-7.07.1-r5.ebuild:
+ apply fontconfig patch by default, move fonts to /usr/share/fonts/ghostscript
09 Aug 2004; Heinrich Wendel <lanius@gentoo.org>
ghostscript-7.07.1-r4.ebuild:
diff --git a/app-text/ghostscript/files/digest-ghostscript-7.07.1-r5 b/app-text/ghostscript/files/digest-ghostscript-7.07.1-r5
new file mode 100644
index 000000000000..986bb4d51dda
--- /dev/null
+++ b/app-text/ghostscript/files/digest-ghostscript-7.07.1-r5
@@ -0,0 +1,4 @@
+MD5 d30bf5c09f2c7caa8291f6305cf03044 espgs-7.07.1-source.tar.bz2 5400198
+MD5 6865682b095f8c4500c54b285ff05ef6 ghostscript-fonts-std-8.11.tar.gz 3752871
+MD5 a3bf430a7e21cd82401258a2ec3b8afb adobe-cmaps-200204.tar.gz 4360486
+MD5 2fbae60417d42779f6488ab897dcaaf6 acro5-cmaps-2001.tar.gz 631653
diff --git a/app-text/ghostscript/ghostscript-7.07.1-r5.ebuild b/app-text/ghostscript/ghostscript-7.07.1-r5.ebuild
new file mode 100644
index 000000000000..8ab888a41bf1
--- /dev/null
+++ b/app-text/ghostscript/ghostscript-7.07.1-r5.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.07.1-r5.ebuild,v 1.1 2004/08/11 08:15:36 lanius Exp $
+
+inherit flag-o-matic eutils gcc
+
+DESCRIPTION="ESP Ghostscript -- an enhanced version of GNU Ghostscript with better printer support"
+HOMEPAGE="http://www.cups.org/ghostscript.php"
+SRC_URI="mirror://sourceforge/espgs/espgs-${PV}-source.tar.bz2
+ ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/fonts/ghostscript-fonts-std-8.11.tar.gz
+ cjk? ( http://www.matsusaka-u.ac.jp/mirror/gs-cjk/adobe-cmaps-200204.tar.gz
+ http://www.matsusaka-u.ac.jp/mirror/gs-cjk/acro5-cmaps-2001.tar.gz)"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~ia64 ~x86 -ppc ~sparc ~alpha ~hppa ~amd64 ~mips ~ppc64"
+IUSE="X cups cjk emacs truetype"
+
+RDEPEND="virtual/libc
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.1
+ >=sys-libs/zlib-1.1.4
+ X? ( virtual/x11 )
+ cjk? ( media-fonts/arphicfonts
+ media-fonts/kochi-substitute
+ media-fonts/baekmuk-fonts )
+ cups? ( net-print/cups )
+ !virtual/ghostscript
+ media-libs/fontconfig "
+
+DEPEND="${RDEPEND}
+ truetype? ( dev-util/pkgconfig )"
+
+S=${WORKDIR}/espgs-${PV}
+
+PROVIDE="virtual/ghostscript"
+
+src_unpack() {
+ unpack espgs-${PV}-source.tar.bz2
+ unpack ghostscript-fonts-std-8.11.tar.gz
+
+ cd ${S}
+
+ if use cjk ; then
+ epatch ${FILESDIR}/gs7.05.6-cjk.diff.bz2
+ epatch ${FILESDIR}/gs7.05.6-kochi-substitute.patch
+ fi
+
+ # add fontconfig support
+ epatch ${FILESDIR}/gs7.07.1-fontconfig-rh.patch.bz2
+
+ # man page patch from absinthe@pobox.com (Dylan Carlson) bug #14150
+ epatch ${FILESDIR}/ghostscript-7.05.6.man.patch
+
+ # pxl dash patch
+ epatch ${FILESDIR}/gs${PV}-ps2epsi.patch
+
+ # ijs fPIC patch
+ epatch ${FILESDIR}/gs${PV}-ijs.patch
+
+ # pxl dash patch
+ epatch ${FILESDIR}/gs7.05.6-gdevpx.patch
+
+ # search path fix
+ sed -i -e 's:$(gsdatadir)/lib:/usr/share/ghostscript/7.07/lib:' Makefile.in
+ sed -i -e 's:$(gsdir)/fonts:/usr/share/fonts/ghostscript/:' Makefile.in
+
+ # krgb support
+ cd src
+ epatch ${FILESDIR}/gs7.07.1-krgb.patch.gz
+}
+
+src_compile() {
+ local myconf
+ myconf="--with-ijs --with-omni --without-gimp-print"
+
+ use X && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use cups && myconf="${myconf} --enable-cups" \
+ || myconf="${myconf} --disable-cups"
+
+ # -O3 will make ghostscript fail when compiling with gcc 3.4
+ if [ "`gcc-major-version`" -eq "3" ] && [ "`gcc-minor-version`" -eq "4" ]
+ then
+ strip-flags
+ replace-flags -O? -O2
+ fi
+
+ autoconf
+ econf ${myconf} || die "econf failed"
+ make || die "make failed"
+
+ cd ijs
+ econf --prefix=${D}/usr || die "econf failed"
+ make || die "make failed"
+ cd ..
+}
+
+src_install() {
+ einstall install_prefix=${D}
+
+ cd ${WORKDIR}
+ dodir /usr/share/fonts/ghostscript
+ cp -a fonts/* ${D}/usr/share/fonts/ghostscript || die
+ cd ${S}
+
+ rm -fr ${D}/usr/share/ghostscript/7.07/doc || die
+ dodoc doc/README doc/COPYING doc/COPYING.LGPL
+ dohtml doc/*.html doc/*.htm
+
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins doc/gsdoc.el
+ fi
+
+ if use cjk ; then
+ dodir /usr/share/ghostscript/Resource
+ dodir /usr/share/ghostscript/Resource/Font
+ dodir /usr/share/ghostscript/Resource/CIDFont
+ cd ${D}/usr/share/ghostscript/Resource
+ unpack adobe-cmaps-200204.tar.gz
+ unpack acro5-cmaps-2001.tar.gz
+ fi
+
+ # Install ijs
+ cd ${S}/ijs
+ dodir /usr/bin /usr/include /usr/lib
+ # This is broken - there are not even a 'install_prefix'
+ # anywhere in ${S}/ijs ...
+ #einstall install_prefix=${D}
+ einstall
+ dosed "s:^prefix=.*:prefix=/usr:" /usr/bin/ijs-config
+}