summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-10-31 04:40:59 +0000
committerNed Ludd <solar@gentoo.org>2004-10-31 04:40:59 +0000
commit7328f5d37752ed31a441b1306ac56a40aa470bfb (patch)
treeee9320b4562da377683c44fdd7dd34e3000a4788 /app-shells/sash
parentportage-2.0.51 is the minimum (diff)
downloadhistorical-7328f5d37752ed31a441b1306ac56a40aa470bfb.tar.gz
historical-7328f5d37752ed31a441b1306ac56a40aa470bfb.tar.bz2
historical-7328f5d37752ed31a441b1306ac56a40aa470bfb.zip
sash command line will segv/core with -c Ax12000bytes
Diffstat (limited to 'app-shells/sash')
-rw-r--r--app-shells/sash/ChangeLog6
-rw-r--r--app-shells/sash/Manifest23
-rw-r--r--app-shells/sash/files/sash-3.7-builtin.patch14
-rw-r--r--app-shells/sash/sash-3.7.ebuild3
4 files changed, 38 insertions, 8 deletions
diff --git a/app-shells/sash/ChangeLog b/app-shells/sash/ChangeLog
index 81cab5686a38..79b4dcabc72b 100644
--- a/app-shells/sash/ChangeLog
+++ b/app-shells/sash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/sash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.31 2004/09/13 20:40:52 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.32 2004/10/31 04:40:59 solar Exp $
+
+ 31 Oct 2004; <solar@gentoo.org> +files/sash-3.7-builtin.patch,
+ sash-3.7.ebuild:
+ sash command line will segv/core with -c Ax12000bytes
13 Sep 2004; Guy Martin <gmsoft@gentoo.org> sash-3.7.ebuild:
Stable on hppa.
diff --git a/app-shells/sash/Manifest b/app-shells/sash/Manifest
index 38f41bdf4b71..c6015edc555f 100644
--- a/app-shells/sash/Manifest
+++ b/app-shells/sash/Manifest
@@ -1,10 +1,21 @@
-MD5 19866c967064623e4ed734a9162a0f84 ChangeLog 3649
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 3ca09d43463d9393c7db75f1cc65cf49 sash-3.7.ebuild 1243
MD5 3b21afef4759a8477260dc345b99525c sash-3.6.ebuild 1079
-MD5 d120d645681200701e2641213db3587f sash-3.7.ebuild 1203
-MD5 c0a4b54f51097cb6d1e76b0f0df2d938 files/digest-sash-3.6 59
-MD5 ed10e67a2e293993478c999f67c612b8 files/digest-sash-3.7 59
-MD5 570237f86f81b58c68835104a03da8dc files/sash-3.4-gentoo.diff 7087
+MD5 e3730768e4af7333d98268a0b2ed5869 ChangeLog 3789
+MD5 d38ab7c3e9697a320856b2a1727d9be8 files/sash-3.6-ppc64-includes.patch 291
MD5 d38ab7c3e9697a320856b2a1727d9be8 files/sash-3.6-2.6-includes.patch 291
MD5 e8758a0d35504ea0420262b58acc5a62 files/sash-3.6-fix-includes.patch 334
-MD5 d38ab7c3e9697a320856b2a1727d9be8 files/sash-3.6-ppc64-includes.patch 291
+MD5 0fa262804299a7ba80c5266f578722eb files/sash-3.7-builtin.patch 465
+MD5 c0a4b54f51097cb6d1e76b0f0df2d938 files/digest-sash-3.6 59
+MD5 ed10e67a2e293993478c999f67c612b8 files/digest-sash-3.7 59
MD5 d33602f9d3d89db4b3ea2adad619fdf2 files/sash-3.6-readline.patch 7507
+MD5 570237f86f81b58c68835104a03da8dc files/sash-3.4-gentoo.diff 7087
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFBhGx694CCfB4KcwwRAvjeAKCNxtXKVURKt/8+CR/jv4SdRTOFPQCfV+Ei
+J04Oe2zyZKo1yIwdUPb18b4=
+=oexD
+-----END PGP SIGNATURE-----
diff --git a/app-shells/sash/files/sash-3.7-builtin.patch b/app-shells/sash/files/sash-3.7-builtin.patch
new file mode 100644
index 000000000000..be943063efdf
--- /dev/null
+++ b/app-shells/sash/files/sash-3.7-builtin.patch
@@ -0,0 +1,14 @@
+diff -Nrup sash-3.7.orig/sash.c sash-3.7/sash.c
+--- sash-3.7.orig/sash.c 2004-01-14 00:08:03.000000000 -0500
++++ sash-3.7/sash.c 2004-10-31 00:05:59.000000000 -0400
+@@ -739,6 +739,10 @@ tryBuiltIn(const char * cmd)
+ while (*endCmd && !isBlank(*endCmd))
+ endCmd++;
+
++ /* FIXME: command line will segv with -c 12000bytes -solar */
++ if ((endCmd - cmd) >= sizeof(cmdName))
++ return FALSE;
++
+ memcpy(cmdName, cmd, endCmd - cmd);
+
+ cmdName[endCmd - cmd] = '\0';
diff --git a/app-shells/sash/sash-3.7.ebuild b/app-shells/sash/sash-3.7.ebuild
index a7e65b219eaa..de36a18c9bac 100644
--- a/app-shells/sash/sash-3.7.ebuild
+++ b/app-shells/sash/sash-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.14 2004/10/04 23:38:50 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7.ebuild,v 1.15 2004/10/31 04:40:59 solar Exp $
inherit eutils flag-o-matic
@@ -23,6 +23,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/sash-3.6-fix-includes.patch
+ epatch ${FILESDIR}/sash-3.7-builtin.patch
use readline && epatch ${FILESDIR}/sash-3.6-readline.patch
# this indicates broken header files but don't know what to do