summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 18:41:57 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 18:41:57 +0000
commit21ea5a1cf24897df46b871f217fac650e7e38339 (patch)
tree70d20160aba0ec38a5e51725714ff03fc5e0396b /app-sci/ghemical
parentfix license (diff)
downloadhistorical-21ea5a1cf24897df46b871f217fac650e7e38339.tar.gz
historical-21ea5a1cf24897df46b871f217fac650e7e38339.tar.bz2
historical-21ea5a1cf24897df46b871f217fac650e7e38339.zip
fix license
Diffstat (limited to 'app-sci/ghemical')
-rw-r--r--app-sci/ghemical/ghemical-0.90.ebuild26
-rw-r--r--app-sci/ghemical/ghemical-1.00.ebuild22
2 files changed, 23 insertions, 25 deletions
diff --git a/app-sci/ghemical/ghemical-0.90.ebuild b/app-sci/ghemical/ghemical-0.90.ebuild
index 5099c66d27dd..0c7c6bdf3f98 100644
--- a/app-sci/ghemical/ghemical-0.90.ebuild
+++ b/app-sci/ghemical/ghemical-0.90.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/ghemical/ghemical-0.90.ebuild,v 1.5 2003/02/13 09:21:36 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ghemical/ghemical-0.90.ebuild,v 1.6 2003/08/05 18:33:25 vapier Exp $
-DEPEND="gnome-base/gnome-libs
- dev-libs/libf2c
- x11-libs/gtkglext
- app-sci/mpqc"
-
-IUSE=""
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
+inherit eutils
DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
-
HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
SRC_URI="http://www.uku.fi/~thassine/ghemical/download/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="gnome-base/gnome-libs
+ dev-libs/libf2c
+ x11-libs/gtkglext
+ app-sci/mpqc"
+
src_compile() {
- patch -p0 < ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
./configure --prefix=/usr --enable-mpqc
emake
}
diff --git a/app-sci/ghemical/ghemical-1.00.ebuild b/app-sci/ghemical/ghemical-1.00.ebuild
index 99f1ec75127d..bb596a4c4050 100644
--- a/app-sci/ghemical/ghemical-1.00.ebuild
+++ b/app-sci/ghemical/ghemical-1.00.ebuild
@@ -1,6 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/ghemical/ghemical-1.00.ebuild,v 1.8 2003/02/13 09:21:40 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ghemical/ghemical-1.00.ebuild,v 1.9 2003/08/05 18:33:25 vapier Exp $
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
+SRC_URI="http://www.uku.fi/~thassine/ghemical/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
DEPEND="gnome-base/gnome-libs
dev-libs/libf2c
@@ -10,16 +18,6 @@ DEPEND="gnome-base/gnome-libs
dev-libs/libxml
=gnome-base/libglade-0*"
-IUSE=""
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
-
-DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
-
-HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
-SRC_URI="http://www.uku.fi/~thassine/ghemical/download/${P}.tgz"
-
src_compile() {
./configure --prefix=/usr --enable-mpqc ||die
emake ||die