summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 19:28:00 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 19:28:00 +0000
commite7c84e07d2de54b3e36063028a813e316bc84f01 (patch)
treeb5b46c1d2848161b874266e2e0d9f296f3695e8f /app-pda
parentversion bump (diff)
downloadhistorical-e7c84e07d2de54b3e36063028a813e316bc84f01.tar.gz
historical-e7c84e07d2de54b3e36063028a813e316bc84f01.tar.bz2
historical-e7c84e07d2de54b3e36063028a813e316bc84f01.zip
add inherit eutils
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/multisync/multisync-0.81.ebuild46
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8.ebuild14
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild9
-rw-r--r--app-pda/synce-rra/synce-rra-0.8.9.ebuild9
4 files changed, 35 insertions, 43 deletions
diff --git a/app-pda/multisync/multisync-0.81.ebuild b/app-pda/multisync/multisync-0.81.ebuild
index d8f276dab6d2..0b5a7bbbe773 100644
--- a/app-pda/multisync/multisync-0.81.ebuild
+++ b/app-pda/multisync/multisync-0.81.ebuild
@@ -1,43 +1,41 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.81.ebuild,v 1.5 2004/03/29 00:44:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.81.ebuild,v 1.6 2004/04/07 19:22:53 vapier Exp $
+
+inherit eutils
DESCRIPTION="Client to sync apps with WinCE or mobile devices"
HOMEPAGE="http://multisync.sourceforge.net/"
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
SRC_URI="mirror://sourceforge/multisync/${PN}-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE="evo irmc opie ldap"
# evo - evolution plugin
# irmc - bluetooth/irmc/irda plugin ( local )
# opie - opie plugin ( local )
# ldap - ldap plugin - experimental
-IUSE="evo irmc opie ldap"
DEPEND="virtual/glibc
- >=gnome-base/libbonobo-2.2
- >=gnome-base/libgnome-2.2
- >=gnome-base/ORBit2-2.8.2
- >=dev-libs/openssl-0.9.6j
- evo? (
- gtk2? (
- =net-mail/evolution-1.4*
- =x11-libs/gtk+-2* )
- !gtk2 (
- =net-mail/evolution-1.2*
- =x11-libs/gtk+-1* )
- )
- irmc? ( >=sys-apps/irda-utils-0.9.15
- >=net-wireless/bluez-utils-2.3
- >=dev-libs/openobex-1.0.0 )
- opie? ( >=net-misc/curl-7.10.5 )
- ldap? ( >=net-nds/openldap-2.0.27
- >=dev-libs/cyrus-sasl-2.1.4 )"
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/ORBit2-2.8.2
+ >=dev-libs/openssl-0.9.6j
+ evo? (
+ gtk2? (
+ =net-mail/evolution-1.4*
+ =x11-libs/gtk+-2* )
+ !gtk2 (
+ =net-mail/evolution-1.2*
+ =x11-libs/gtk+-1* )
+ )
+ irmc? ( >=sys-apps/irda-utils-0.9.15
+ >=net-wireless/bluez-utils-2.3
+ >=dev-libs/openobex-1.0.0 )
+ opie? ( >=net-misc/curl-7.10.5 )
+ ldap? ( >=net-nds/openldap-2.0.27
+ >=dev-libs/cyrus-sasl-2.1.4 )"
S=${WORKDIR}/${PF/-r1/}
diff --git a/app-pda/pilot-link/pilot-link-0.11.8.ebuild b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
index 7c8907229091..f04971bb3741 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.6 2003/12/14 01:11:25 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8.ebuild,v 1.7 2004/04/07 19:23:34 vapier Exp $
-inherit perl-module
+inherit perl-module eutils
DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
-SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
HOMEPAGE="http://www.pilot-link.org/"
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
IUSE="perl java tcltk python png readline"
@@ -56,7 +56,7 @@ src_compile() {
# java fails w/emake
make || die
- if [ `use perl` ] ; then
+ if use perl ; then
cd ${S}/bindings/Perl
perl-module_src_prep
perl-module_src_compile
@@ -68,7 +68,7 @@ src_install() {
dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
- if [ `use perl` ] ; then
+ if use perl ; then
cd ${S}/bindings/Perl
perl-module_src_install
fi
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
index ddadaac3bcf2..b682298e859c 100644
--- a/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
+++ b/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild,v 1.2 2004/03/30 12:10:58 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.8.9.ebuild,v 1.3 2004/04/07 19:27:47 vapier Exp $
+
+inherit eutils
DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync."
HOMEPAGE="http://sourceforge.net/projects/synce/"
@@ -18,11 +20,6 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${P}-gcc33.patch
}
-src_compile() {
- econf
- emake || die
-}
-
src_install() {
make DESTDIR=${D} install || die
dodoc README
diff --git a/app-pda/synce-rra/synce-rra-0.8.9.ebuild b/app-pda/synce-rra/synce-rra-0.8.9.ebuild
index 7fb2c9fd879d..4245923f98b4 100644
--- a/app-pda/synce-rra/synce-rra-0.8.9.ebuild
+++ b/app-pda/synce-rra/synce-rra-0.8.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-rra/synce-rra-0.8.9.ebuild,v 1.1 2004/03/26 12:34:10 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-rra/synce-rra-0.8.9.ebuild,v 1.2 2004/04/07 19:28:00 vapier Exp $
+
+inherit eutils
DESCRIPTION="Synchronize Windows CE devices with computers running GNU/Linux, like MS ActiveSync."
HOMEPAGE="http://sourceforge.net/projects/synce/"
@@ -22,11 +24,6 @@ src_unpack() {
epatch ${DISTDIR}/librra-synce-kde-0.7.diff
}
-src_compile() {
- econf
- emake || die
-}
-
src_install() {
make DESTDIR="${D%/}" install || die
}