summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-07-11 21:00:15 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-07-11 21:00:15 +0000
commit657568d5e45a7180b33621e0d1a56d3a180da4ea (patch)
tree51c823030d9463fa5990b1c1add1aba8f0bb8d12 /app-office
parentversion bump (diff)
downloadhistorical-657568d5e45a7180b33621e0d1a56d3a180da4ea.tar.gz
historical-657568d5e45a7180b33621e0d1a56d3a180da4ea.tar.bz2
historical-657568d5e45a7180b33621e0d1a56d3a180da4ea.zip
Fixed BUG #52737.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/sc/Manifest3
-rw-r--r--app-office/sc/files/sc-7.12-amd64.patch13
-rw-r--r--app-office/sc/sc-7.12.ebuild10
3 files changed, 24 insertions, 2 deletions
diff --git a/app-office/sc/Manifest b/app-office/sc/Manifest
index 47d298f18e11..bb98303ee6ec 100644
--- a/app-office/sc/Manifest
+++ b/app-office/sc/Manifest
@@ -1,3 +1,4 @@
-MD5 7b19732ff16b16d49244fb4671eb453e sc-7.12.ebuild 973
MD5 8668ce88facde796b81b51e25046b23e ChangeLog 1325
+MD5 584565466bee48610e6fb57337420e81 sc-7.12.ebuild 1067
MD5 f47369435a7c7e6fd45629852c8ec440 files/digest-sc-7.12 59
+MD5 b80148293ba40aff64b004432edf0e21 files/sc-7.12-amd64.patch 309
diff --git a/app-office/sc/files/sc-7.12-amd64.patch b/app-office/sc/files/sc-7.12-amd64.patch
new file mode 100644
index 000000000000..2133ed42e325
--- /dev/null
+++ b/app-office/sc/files/sc-7.12-amd64.patch
@@ -0,0 +1,13 @@
+--- xmalloc.c.orig 2004-07-11 22:34:48.681076912 +0200
++++ xmalloc.c 2004-07-11 22:34:57.150789320 +0200
+@@ -6,8 +6,8 @@
+ #include <curses.h>
+ #include "sc.h"
+
+-extern char *malloc();
+-extern char *realloc();
++extern void *malloc(size_t size);
++extern void *realloc();
+ extern void free();
+ void fatal();
+
diff --git a/app-office/sc/sc-7.12.ebuild b/app-office/sc/sc-7.12.ebuild
index a3bcb981fae9..13aba428bbaa 100644
--- a/app-office/sc/sc-7.12.ebuild
+++ b/app-office/sc/sc-7.12.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/sc/sc-7.12.ebuild,v 1.17 2004/07/02 16:39:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/sc/sc-7.12.ebuild,v 1.18 2004/07/11 21:00:15 kugelfang Exp $
+
+inherit eutils
DESCRIPTION="sc is a free curses-based spreadsheet program that uses key bindings similar to vi and less."
SRC_URI="ftp://ibiblio.org/pub/Linux/apps/financial/spreadsheet/${P}.tar.gz"
@@ -14,6 +16,12 @@ IUSE=""
DEPEND=">=sys-apps/sed-4.0.5
>=sys-libs/ncurses-5.2"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-amd64.patch
+}
+
src_compile() {
make CFLAGS="-DSYSV3 $CFLAGS" prefix=/usr || die
}