summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 21:59:33 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 21:59:33 +0000
commit5e2f589877bb59855341b6f75a2ff2cfb818058d (patch)
tree1f3a6f41df7f1d73eb15772b23c8b7de62286656 /app-office
parentChanged src_install () to src_install() (diff)
downloadhistorical-5e2f589877bb59855341b6f75a2ff2cfb818058d.tar.gz
historical-5e2f589877bb59855341b6f75a2ff2cfb818058d.tar.bz2
historical-5e2f589877bb59855341b6f75a2ff2cfb818058d.zip
Changed econf||die to econf
Diffstat (limited to 'app-office')
-rw-r--r--app-office/dia/dia-0.88.1-r1.ebuild17
-rw-r--r--app-office/dia/dia-0.90-r2.ebuild16
2 files changed, 10 insertions, 23 deletions
diff --git a/app-office/dia/dia-0.88.1-r1.ebuild b/app-office/dia/dia-0.88.1-r1.ebuild
index 09bd85451f16..d97398a02e2d 100644
--- a/app-office/dia/dia-0.88.1-r1.ebuild
+++ b/app-office/dia/dia-0.88.1-r1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1-r1.ebuild,v 1.10 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1-r1.ebuild,v 1.11 2002/11/30 21:58:24 vapier Exp $
-IUSE="nls cups gnome bonobo"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Diagram Creation Program"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
@@ -12,6 +9,7 @@ HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
SLOT="0"
KEYWORDS="x86 ppc"
LICENSE="GPL-2"
+IUSE="nls cups gnome bonobo"
RDEPEND=">=dev-libs/libxml-1.8.15
>=media-libs/gdk-pixbuf-0.16.0-r4
@@ -24,23 +22,16 @@ DEPEND="${RDEPEND}
src_compile() {
local myconf
-
use gnome && myconf="--enable-gnome"
-
use bonobo && myconf="--enable-gnome --enable-bonobo"
-
# use python && myconf="${myconf} --with-python"
-
use nls || myconf="${myconf} --disable-nls"
-
use cups || myconf="${myconf} --disable-gnome-print"
-
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
}
diff --git a/app-office/dia/dia-0.90-r2.ebuild b/app-office/dia/dia-0.90-r2.ebuild
index ef2d4ca59d65..fc59593f2deb 100644
--- a/app-office/dia/dia-0.90-r2.ebuild
+++ b/app-office/dia/dia-0.90-r2.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.90-r2.ebuild,v 1.2 2002/10/23 15:21:31 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.90-r2.ebuild,v 1.3 2002/11/30 21:59:33 vapier Exp $
-IUSE="nls gnome bonobo truetype png"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Diagram Creation Program"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
@@ -12,6 +9,7 @@ HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc"
+IUSE="nls gnome bonobo truetype png"
RDEPEND=">=dev-libs/libxml-1.8.14
>=media-libs/gdk-pixbuf-0.7
@@ -20,8 +18,7 @@ RDEPEND=">=dev-libs/libxml-1.8.14
bonobo? ( gnome-base/bonobo )
truetype? ( >=media-libs/freetype-2.0.5 )
png? ( media-libs/libpng
- >=media-libs/libart_lgpl-2.1 )"
-
+ >=media-libs/libart_lgpl-2.1 )"
# Python module needs some work
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -43,14 +40,13 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
- # enable-gnome-print not recoomended
+ # enable-gnome-print not recoomended
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
}