summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2005-07-28 20:29:04 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2005-07-28 20:29:04 +0000
commit618239f2003efe778e252bbc4e560f670a566785 (patch)
treecd5d3a8bbbb4e0cb37f62c929fb12128a6eb73b3 /app-mobilephone
parentVersion bump, bug #96135. Moved phex wrapper to /usr/bin (diff)
downloadhistorical-618239f2003efe778e252bbc4e560f670a566785.tar.gz
historical-618239f2003efe778e252bbc4e560f670a566785.tar.bz2
historical-618239f2003efe778e252bbc4e560f670a566785.zip
initial commit. Implementing CAPI, Lua and SLang support.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/yaps/ChangeLog11
-rw-r--r--app-mobilephone/yaps/Manifest6
-rw-r--r--app-mobilephone/yaps/files/digest-yaps-0.962
-rw-r--r--app-mobilephone/yaps/files/yaps-0.96-capiv3.patch61
-rw-r--r--app-mobilephone/yaps/files/yaps-0.96.patch422
-rw-r--r--app-mobilephone/yaps/metadata.xml6
-rw-r--r--app-mobilephone/yaps/yaps-0.96.ebuild65
7 files changed, 573 insertions, 0 deletions
diff --git a/app-mobilephone/yaps/ChangeLog b/app-mobilephone/yaps/ChangeLog
new file mode 100644
index 000000000000..c4e4bfc26f60
--- /dev/null
+++ b/app-mobilephone/yaps/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-mobilephone/yaps
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.1 2005/07/28 20:29:04 sbriesen Exp $
+
+*yaps-0.96 (28 Jul 2005)
+
+ 28 Jul 2005; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/yaps-0.96-capiv3.patch, +files/yaps-0.96.patch, +metadata.xml,
+ +yaps-0.96.ebuild:
+ initial commit. Implementing CAPI, Lua and SLang support.
+
diff --git a/app-mobilephone/yaps/Manifest b/app-mobilephone/yaps/Manifest
new file mode 100644
index 000000000000..ed6cf3cfe782
--- /dev/null
+++ b/app-mobilephone/yaps/Manifest
@@ -0,0 +1,6 @@
+MD5 f7552a0cc39d664b72d0108fd614735f yaps-0.96.ebuild 1699
+MD5 faa0723efb064c14ed9d1c097e4808ec ChangeLog 450
+MD5 2e3ea70bd2303c7b7915e056bdd44066 metadata.xml 258
+MD5 8cd1ba9738bbe553fc3d400dd7f7c20c files/yaps-0.96.patch 9867
+MD5 5b713d70117b792c0fa6a519f8c0b208 files/digest-yaps-0.96 121
+MD5 836bccf5ccea5152fa69261df18d3bb9 files/yaps-0.96-capiv3.patch 1820
diff --git a/app-mobilephone/yaps/files/digest-yaps-0.96 b/app-mobilephone/yaps/files/digest-yaps-0.96
new file mode 100644
index 000000000000..c4b03dc27253
--- /dev/null
+++ b/app-mobilephone/yaps/files/digest-yaps-0.96
@@ -0,0 +1,2 @@
+MD5 69857a8eb69ce660ffae5bcc66df78e7 yaps-0.96.c2.tgz 108686
+MD5 6b5afb26526cb20f0995e5bb2cfa494e yaps-0.96.tar.gz 91060
diff --git a/app-mobilephone/yaps/files/yaps-0.96-capiv3.patch b/app-mobilephone/yaps/files/yaps-0.96-capiv3.patch
new file mode 100644
index 000000000000..0fd67b3bbf2c
--- /dev/null
+++ b/app-mobilephone/yaps/files/yaps-0.96-capiv3.patch
@@ -0,0 +1,61 @@
+--- capiconn.c.orig 2004-06-13 14:57:42.000000000 +0200
++++ capiconn.c 2005-06-02 16:56:58.385211987 +0200
+@@ -912,7 +912,8 @@
+ 0, /* BChannelinformation */
+ 0, /* Keypadfacility */
+ 0, /* Useruserdata */
+- 0 /* Facilitydataarray */
++ 0, /* Facilitydataarray */
++ 0 /* SendingComplete */
+ );
+ plcip->msgid = gcmsg.Messagenumber;
+ send_message(card, &gcmsg);
+@@ -964,6 +965,7 @@
+ 0,
+ 0,
+ 0,
++ 0, /* Globalconfiguration */
+ 0, /* ConnectedNumber */
+ 0, /* ConnectedSubaddress */
+ 0, /* LLC */
+@@ -1506,13 +1508,15 @@
+ plcip->conninfo.b1config,
+ plcip->conninfo.b2config,
+ plcip->conninfo.b3config,
++ 0, /* Globalconfiguration */
+ 0, /* BC */
+ 0, /* LLC */
+ 0, /* HLC */
+ plcip->conninfo.bchaninfo, /* BChannelinformation */
+ 0, /* Keypadfacility */
+ 0, /* Useruserdata */
+- 0 /* Facilitydataarray */
++ 0, /* Facilitydataarray */
++ 0 /* SendingComplete */
+ );
+
+ plcip->msgid = cmdcmsg.Messagenumber;
+@@ -1564,6 +1568,7 @@
+ plcip->conninfo.b1config,
+ plcip->conninfo.b2config,
+ plcip->conninfo.b3config,
++ 0, /* Globalconfiguration */
+ 0, /* ConnectedNumber */
+ 0, /* ConnectedSubaddress */
+ 0, /* LLC */
+@@ -1597,6 +1602,7 @@
+ 0,
+ 0,
+ 0,
++ 0, /* Globalconfiguration */
+ 0, /* ConnectedNumber */
+ 0, /* ConnectedSubaddress */
+ 0, /* LLC */
+@@ -1630,6 +1636,7 @@
+ 0,
+ 0,
+ 0,
++ 0, /* Globalconfiguration */
+ 0, /* ConnectedNumber */
+ 0, /* ConnectedSubaddress */
+ 0, /* LLC */
diff --git a/app-mobilephone/yaps/files/yaps-0.96.patch b/app-mobilephone/yaps/files/yaps-0.96.patch
new file mode 100644
index 000000000000..94699611100a
--- /dev/null
+++ b/app-mobilephone/yaps/files/yaps-0.96.patch
@@ -0,0 +1,422 @@
+--- Config.orig 2005-06-02 20:28:35.000000000 +0200
++++ Config 2005-07-28 17:46:44.000000000 +0200
+@@ -24,9 +24,9 @@
+ # Name of local configuration file (location is $HOME.)
+ YAPS_LCFGFILE = .yapsrc
+ # Directory for installing the binary
+-YAPS_BINDIR = /usr/local/bin
++YAPS_BINDIR = /usr/bin
+ # Directory for optional support files
+-YAPS_LIBDIR = /usr/local/lib/yaps
++YAPS_LIBDIR = /usr/lib/yaps
+ # User/Group/Mode for yaps
+ YAPS_USER = bin
+ YAPS_GROUP = uucp
+@@ -43,12 +43,12 @@
+ ifdef SLANG
+ LDEFS += -DSCRIPT_SLANG
+ LLIBS += -lslang
+-MATH = True
++#MATH = True
+ endif
+ ifdef LUA
+ LDEFS += -DSCRIPT_LUA
+-LLIBS += -llualib -llua
+-MATH = True
++LLIBS += `pkg-config --libs lua`
++#MATH = True
+ endif
+ ifdef MATH
+ LLIBS += -lm
+--- Makefile.orig 2005-06-02 20:33:27.000000000 +0200
++++ Makefile 2005-07-28 17:46:44.000000000 +0200
+@@ -33,19 +33,19 @@
+ lynx -cfg=/dev/null -nolist -dump $< > $@
+
+ install: $(DSTFLE) $(CFGFILE)
+- if [ ! -d $(YAPS_LIBDIR) ]; then \
+- install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(YAPS_LIBDIR) ; \
++ if [ ! -d $(DESTDIR)$(YAPS_LIBDIR) ]; then \
++ install -d -m 755 $(DESTDIR)$(YAPS_LIBDIR) ; \
+ fi
+ @if [ -f contrib/Makefile ]; then \
+ $(MAKE) -C contrib install ; \
+ fi
+
+ $(DSTFLE): yaps
+- install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $@
++ install -m $(YAPS_MODE) -s yaps $(DESTDIR)$@
+
+ $(CFGFILE): yaps.rc
+ @if [ ! -f $@ ]; then \
+- install -o $(YAPS_RCUSER) -g $(YAPS_RCGROUP) -m $(YAPS_RCMODE) -s yaps.rc $@ ; \
++ install -m $(YAPS_RCMODE) -s yaps.rc $(DESTDIR)$@ ; \
+ fi
+
+ clean:
+--- yaps.rc.orig 2005-06-02 20:28:35.000000000 +0200
++++ yaps.rc 2005-07-28 18:22:08.000000000 +0200
+@@ -9,26 +9,28 @@
+ # This is a comma seperated list of available services. This
+ # is required for autodetect the matching service for a
+ # pager-id
+-services D1,D2,E+
+-+services Telmi,Telmi-Fun,Telmi-Family,Telmi-Top,Telmi-Pro
+-+services Skyper,Quix
++services D1-0160, D1-0170, D1-0171, D1-0175
+++services D2-0172, D2-0173, D2-0174, D2-0174
+++services E+0177, E+0178
+++services Telmi,Telmi-Fun,Telmi-Family,Telmi-Top,Telmi-Pro
+++services Skyper,Quix
+ #
+ # This is the default caller-id. If the protocol/service allowes
+ # it, this is inserted in the message (and the receiver gets this
+ # as the sender's number)
+-call-id +1-(555)-1234
++#call-id 0123-4567890
+ #
+ # If you forget to sign your message, you can automatically append
+ # this string to each message.
+-signature (It's me!)
++#signature NAME
+ #
+ # You can either switch the use of the signature here on for all
+ # services or in each service section for that particular service.
+-use-signature True
++#use-signature True
+ #
+ # To get more verbose output when running yaps increase this value.
+ # Currently 4 is the highest supported value.
+-verbose 0
++verbose 4
+ #
+ # If you'd like to log every sending session define this. It should
+ # point to a writeable file. If you install the software setgid, then
+@@ -88,12 +90,12 @@
+ #
+ # Most services limit the length of a message to a specific length.
+ # Enter the value here to check valid messages
+-#max-size 160
++max-size 160
+
+ #
+ # If a message is longer than max-size, you can set this to split
+ # it off into several single messages of allowed length
+-#may-split True
++may-split True
+
+ #
+ # If a message is longer than max-size, you can set this to truncate
+@@ -107,7 +109,7 @@
+
+ #
+ # If the service allows using your caller-id set this to True.
+-#use-call-id True
++use-call-id True
+
+ #
+ # If the service is reachable over a phonenumber where the pager-id
+@@ -186,7 +188,8 @@
+
+ #
+ # Set this to the modem device you wish to use
+-#device /dev/modem
++device /dev/ttyS0
++#device /dev/ttyI5
+ #device /dev/cua1
+ #device /dev/cua/a
+
+@@ -194,7 +197,7 @@
+ # Set this to the prefix of the lockfile use for the device. There
+ # are several places, and two common formats:
+ #lock-prefix /usr/spool/uucp/LCK..
+-#lock-prefix /var/spool/lock/LCK..
++lock-prefix /var/spool/lock/LCK..
+ #lock-prefix /var/spool/locks/LK.
+
+ #
+@@ -223,7 +226,57 @@
+ #
+ # D1 (by Deutsche Telekom)
+ #
+-[D1]
++[D1-0160]
++protocol tap
++valid-pid 0160|0049160|49160
++change-pid 0160
++convert *no-8bit,cv-d1
++cv-d1 {
++ Ä [
++ Ö \
++ Ü ~
++ ä {
++ ö |
++ ü ~
++ ß ^]
++}
+++cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
++phone 01712092522
++# use this number for isdn-dialin:
++# phone 01712521001
++max-size 160
++may-split True
++use-call-id False
++tap-old True
++#
++#----------------------------------------------------------
++#
++[D1-0170]
++protocol tap
++valid-pid 0170|0049170|49170
++change-pid 0170
++convert *no-8bit,cv-d1
++cv-d1 {
++ Ä [
++ Ö \
++ Ü ~
++ ä {
++ ö |
++ ü ~
++ ß ^]
++}
+++cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
++phone 01712092522
++# use this number for isdn-dialin:
++# phone 01712521001
++max-size 160
++may-split True
++use-call-id False
++tap-old True
++#
++#----------------------------------------------------------
++#
++[D1-0171]
+ protocol tap
+ valid-pid 0171|0049171|49171
+ change-pid 0171
+@@ -239,21 +292,122 @@
+ }
+ +cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
+ phone 01712092522
++# use this number for isdn-dialin:
++# phone 01712521001
+ max-size 160
+ may-split True
+ use-call-id False
+ tap-old True
+ #
++#----------------------------------------------------------
++#
++[D1-0175]
++protocol tap
++valid-pid 0175|0049175|49175
++change-pid 0175
++convert *no-8bit,cv-d1
++cv-d1 {
++ Ä [
++ Ö \
++ Ü ~
++ ä {
++ ö |
++ ü ~
++ ß ^]
++}
+++cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
++phone 01712092522
++# use this number for isdn-dialin:
++# phone 01712521001
++max-size 160
++may-split True
++use-call-id False
++tap-old True
++#
++#----------------------------------------------------------
++#
++
++
++
++#
+ # D2 (by Mannesmann Mobilfunk)
+ #
+-[D2]
+-modem standard-d2
++[D2-0162]
++modem standard
++protocol ucp
++valid-pid 0162|0049162|49162
++change-pid 0162
++convert *no-8bit,cv-default
+++cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
++# phone 01722278020
++# use this number for isdn-dialin:
++phone 01722278010
++max-size 160
++may-split True
++use-call-id True
++can-delay True
++can-expire True
++can-rds True
++check-call-id >1111111111111111<
++check-pager-id >1111111111111111<
++ucp-extend True
++#
++#----------------------------------------------------------
++#
++[D2-0172]
++modem standard
+ protocol ucp
+ valid-pid 0172|0049172|49172
+ change-pid 0172
+ convert *no-8bit,cv-default
+ +cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
+-phone 01722278020
++# phone 01722278020
++# use this number for isdn-dialin:
++phone 01722278010
++max-size 160
++may-split True
++use-call-id True
++can-delay True
++can-expire True
++can-rds True
++check-call-id >1111111111111111<
++check-pager-id >1111111111111111<
++ucp-extend True
++#
++#----------------------------------------------------------
++#
++[D2-0173]
++modem standard
++protocol ucp
++valid-pid 0173|0049173|49173|173
++change-pid 0173
++convert *no-8bit,cv-default
+++cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
++# phone 01722278020
++# use this number for isdn-dialin:
++phone 01722278010
++max-size 160
++may-split True
++use-call-id True
++can-delay True
++can-expire True
++can-rds True
++check-call-id >1111111111111111<
++check-pager-id >1111111111111111<
++ucp-extend True
++#
++#----------------------------------------------------------
++#
++[D2-0174]
++modem standard
++protocol ucp
++valid-pid 0174|0049174|49174|174
++change-pid 0174
++convert *no-8bit,cv-default
+++cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
++# phone 01722278020
++# use this number for isdn-dialin:
++phone 01722278010
+ max-size 160
+ may-split True
+ use-call-id True
+@@ -264,10 +418,17 @@
+ check-pager-id >1111111111111111<
+ ucp-extend True
+ #
++#----------------------------------------------------------
++#
++
++
++
++#
++#
+ # E+ (by ???)
+ # !! UNTESTED !!
+ #
+-[E+]
++[E+0177]
+ protocol tap
+ valid-pid 0177|0049177|49177
+ change-pid 0177
+@@ -278,6 +439,22 @@
+ may-split True
+ use-call-id False
+ #
++#----------------------------------------------------------
++#
++[E+0178]
++protocol tap
++valid-pid 0178|0049178|49178|0178
++#change-pid 0178
++convert *no-8bit,cv-default
+++cost timetable=Wk0800-1800=5.7;Wk1800-0800=11.4;Ss=11.4
++phone 01771167
++max-size 160
++may-split True
++use-call-id False
++#
++#----------------------------------------------------------
++#
++#
+ # Telmi, Telmi-* (by Deutsche Funkruf)
+ # !! ONLY TESTED FOR TELMI-FUN !!
+ #
+@@ -335,10 +512,10 @@
+ # Locking
+ #
+ # Older Unix versions
+-lock-prefix /usr/spool/uucp/LCK..
++#lock-prefix /usr/spool/uucp/LCK..
+ # Newer Unix versions
+ #lock-prefix /var/spool/uucp/LCK..
+-#lock-prefix /var/lock/LCK..
++lock-prefix /var/lock/LCK..
+ # SysV4
+ #lock-prefix /var/spool/locks/LK.
+ #lock-method sysv4
+@@ -346,22 +523,38 @@
+ # Device
+ #
+ # Typical a symbolic link to the real device
+-device /dev/modem
++device /dev/ttyS0
+ # "normal" call-out device
+ #device /dev/cua1
+ # Solaris convention
+ #device /dev/cua/a
++# use the following device for isdn-dialout:
++#device /dev/ttyI6
++# use the following device for CAPI
++# syntax: CAPI/<controller>/<MSN>
++#device CAPI/1/12345
+
+ #
++#
+ # Modem talk
+ #
+-init \\r !200D ATZ\r <OK ATE0Q0V1\r <OK
+-dial ATD%L\r <60CONNECT|OK|BUSY|NO\sDIALTONE|NO\sCARRIER
+-reset ATZ\r <OK
++#init \\r !200D AT&F2\r <OK ATE0Q0V1M1L1X3\r <OK
++init \\r !200D AT&F2\r <OK ATV1M1L1X3\r <OK
++
++# use the following init-string for isdn:
++# and change MSN to your MSN (what else...:-))
++#init \\r !200D ATZ\r <OK AT&E9879356\r <OK
++
++dial ATDT0%L\r <60CONNECT|OK|BUSY|NO\sDIALTONE|NO\sCARRIER
++reset ATH\r <OK
+ timeout 10
++
++
+ # Customizing an existing modem entry
+-[standard-d2] standard
+-local-init AT\%C2\r <OK
++#[standard-d2] standard
++#local-init AT\%C2\r <OK
++
++
+ #
+ # alias section
+ #
diff --git a/app-mobilephone/yaps/metadata.xml b/app-mobilephone/yaps/metadata.xml
new file mode 100644
index 000000000000..9c5ebcb79a00
--- /dev/null
+++ b/app-mobilephone/yaps/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mobile-phone</herd>
+ <longdescription>Yet Another Pager Software (optional with CAPI support)</longdescription>
+</pkgmetadata>
diff --git a/app-mobilephone/yaps/yaps-0.96.ebuild b/app-mobilephone/yaps/yaps-0.96.ebuild
new file mode 100644
index 000000000000..cba2ecbc72f2
--- /dev/null
+++ b/app-mobilephone/yaps/yaps-0.96.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/yaps-0.96.ebuild,v 1.1 2005/07/28 20:29:04 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="Yet Another Pager Software (optional with CAPI support)"
+HOMEPAGE="ftp://sunsite.unc.edu/pub/Linux/apps/serialcomm/machines/"
+SRC_URI="capi? ( mirror://sourceforge/capi4yaps/${P}.c2.tgz )
+ !capi? ( ftp://sunsite.unc.edu/pub/Linux/apps/serialcomm/machines/${P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="capi lua slang unicode"
+DEPEND="capi? ( net-dialup/capi4k-utils )
+ slang? ( sys-libs/slang )
+ lua? ( dev-lang/lua )
+ lua? ( dev-util/pkgconfig )"
+
+use capi && S="${S}.c2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # apply patches
+ epatch ${FILESDIR}/${P}.patch
+ use capi \
+ && grep 2>/dev/null -q CAPI_LIBRARY_V2 /usr/include/capiutils.h \
+ && epatch ${FILESDIR}/${P}-capiv3.patch
+
+ # if specified, convert all relevant files from latin1 to UTF-8
+ if use unicode; then
+ for i in yaps.doc; do
+ einfo "Converting '${i}' to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use lua && myconf="${myconf} LUA=True"
+ use slang && myconf="${myconf} SLANG=True"
+ emake CFLAGS="$CFLAGS" ${myconf} || die "emake failed"
+}
+
+src_install() {
+ dobin yaps
+ insinto /etc
+ doins yaps.rc
+ keepdir /usr/lib/yaps
+ doman yaps.1
+ dohtml yaps.html
+ dodoc BUGREPORT COPYRIGHT INSTALL README yaps.lsm yaps.doc
+ docinto contrib
+ dodoc contrib/{README,m2y.pl,tap.sl}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please edit /etc/yaps.rc to suit your needs."
+ einfo
+}