summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 04:18:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 04:18:52 +0000
commitdf5dbac64793120bd42de7e388374590da2b5287 (patch)
tree90f06c3d21bf3f66510acc04e4f0c7084b424bb9 /app-misc/wipe
parentunmask baselayout-1.10 (diff)
downloadhistorical-df5dbac64793120bd42de7e388374590da2b5287.tar.gz
historical-df5dbac64793120bd42de7e388374590da2b5287.tar.bz2
historical-df5dbac64793120bd42de7e388374590da2b5287.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/wipe')
-rw-r--r--app-misc/wipe/wipe-2.1.0.ebuild15
-rw-r--r--app-misc/wipe/wipe-2.2.0.ebuild12
2 files changed, 11 insertions, 16 deletions
diff --git a/app-misc/wipe/wipe-2.1.0.ebuild b/app-misc/wipe/wipe-2.1.0.ebuild
index 0055a53c1b56..a3e8261f78f9 100644
--- a/app-misc/wipe/wipe-2.1.0.ebuild
+++ b/app-misc/wipe/wipe-2.1.0.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.1.0.ebuild,v 1.9 2004/06/24 22:37:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.1.0.ebuild,v 1.10 2004/06/28 04:17:54 vapier Exp $
DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
-SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
HOMEPAGE="http://wipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="x86"
+IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
>=sys-apps/sed-4"
src_unpack() {
@@ -19,13 +19,8 @@ src_unpack() {
sed -i -e '28 i\#include <errno.h>' ${S}/rand.c || die "sed rand.c failed"
}
-src_compile() {
- econf || die "econf failed"
- emake || die "compile problem"
-}
-
src_install() {
- dobin wipe
+ dobin wipe || die
doman wipe.1
dodoc copyright CHANGES README TODO TESTING
}
diff --git a/app-misc/wipe/wipe-2.2.0.ebuild b/app-misc/wipe/wipe-2.2.0.ebuild
index 043ee31a2d9b..f8821ae33048 100644
--- a/app-misc/wipe/wipe-2.2.0.ebuild
+++ b/app-misc/wipe/wipe-2.2.0.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.2.0.ebuild,v 1.4 2004/06/26 10:47:38 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wipe/wipe-2.2.0.ebuild,v 1.5 2004/06/28 04:17:54 vapier Exp $
DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
HOMEPAGE="http://wipe.sourceforge.net/"
SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
-RESTRICT="nomirror"
-KEYWORDS="x86 ~ppc"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ~ppc"
IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_install() {
dobin wipe || die "dobin failed"
- doman wipe.1 || die "doman failed"
- dodoc copyright CHANGES README TODO TESTING || die "dodoc failed"
+ doman wipe.1
+ dodoc CHANGES README TODO TESTING
}
pkg_postinst() {