summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-05-09 11:30:02 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-05-09 11:30:02 +0000
commitc4d63d9c48af5c4227602a2883fae492df7bfc77 (patch)
treefc90558c7c946b1db2d2be4b0b2bf22d088499ea /app-misc/mouseremote
parentd'oh! (diff)
downloadhistorical-c4d63d9c48af5c4227602a2883fae492df7bfc77.tar.gz
historical-c4d63d9c48af5c4227602a2883fae492df7bfc77.tar.bz2
historical-c4d63d9c48af5c4227602a2883fae492df7bfc77.zip
This is the first stab at an ebuild for mouseremote from X10
Diffstat (limited to 'app-misc/mouseremote')
-rw-r--r--app-misc/mouseremote/Changelog9
-rw-r--r--app-misc/mouseremote/files/digest-mouseremote-0.901
-rw-r--r--app-misc/mouseremote/files/mouseremote-gentoo.diff82
-rw-r--r--app-misc/mouseremote/files/mouseremote.conf14
-rw-r--r--app-misc/mouseremote/files/mouseremote.start30
-rw-r--r--app-misc/mouseremote/mouseremote-0.90.ebuild61
6 files changed, 197 insertions, 0 deletions
diff --git a/app-misc/mouseremote/Changelog b/app-misc/mouseremote/Changelog
new file mode 100644
index 000000000000..c864fcaa1242
--- /dev/null
+++ b/app-misc/mouseremote/Changelog
@@ -0,0 +1,9 @@
+# ChangeLog for app-misc/mouseremote
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mouseremote/Changelog,v 1.1 2002/05/09 11:30:02 blauwers Exp $
+
+*mouseremote-0.90-r0 (9 May 2002)
+
+ 9 May 2002; B.Lauwers <blauwers@gentoo.org> ChangeLog, mouseremote-0.90.ebuild :
+
+ Created ebuild for MouseRemote from http://www4.pair.com/gribnif/ha/
diff --git a/app-misc/mouseremote/files/digest-mouseremote-0.90 b/app-misc/mouseremote/files/digest-mouseremote-0.90
new file mode 100644
index 000000000000..79282687b33a
--- /dev/null
+++ b/app-misc/mouseremote/files/digest-mouseremote-0.90
@@ -0,0 +1 @@
+MD5 b99e95fbe3737dd4156f215f1d9a6c3e MouseRemote.tar.gz 41752
diff --git a/app-misc/mouseremote/files/mouseremote-gentoo.diff b/app-misc/mouseremote/files/mouseremote-gentoo.diff
new file mode 100644
index 000000000000..5c0963859078
--- /dev/null
+++ b/app-misc/mouseremote/files/mouseremote-gentoo.diff
@@ -0,0 +1,82 @@
+diff -Naur MouseRemote.ORG/MultiMouse/Makefile MouseRemote/MultiMouse/Makefile
+--- MouseRemote.ORG/MultiMouse/Makefile Thu Aug 21 14:52:56 1997
++++ MouseRemote/MultiMouse/Makefile Sat May 4 15:49:16 2002
+@@ -20,10 +20,10 @@
+ -DMOUSE_FIFO=\"$(FIFO)\"\
+ -DLOCKDIR=\"$(LOCKDIR)\"\
+ -DMAX_MICE=$(MICE)
+-CFLAGS= $(OPTS)\
+- -O2 # -DDEBUG
+ LDLAGS= -O2
+
++OUTPUT_OPTION= $(OPTS) -o $@
++
+ all: $(TARGET)
+
+ multimoused: $(OBJS)
+diff -Naur MouseRemote.ORG/client/MouseRemote.conf MouseRemote/client/MouseRemote.conf
+--- MouseRemote.ORG/client/MouseRemote.conf Sat Oct 9 21:03:42 1999
++++ MouseRemote/client/MouseRemote.conf Sat May 4 16:04:43 2002
+@@ -61,3 +61,35 @@
+
+ # Definitions for the DVD device
+ [DVD]
++Power
++ChUp
++ChDown
++Mute
++VolUp
++VolDown
++Play
++Stop
++TxtRes
++Rew
++FF
++0
++1
++2
++3
++4
++5
++6
++7
++8
++9
++Ent
++Pause
++Last
++Disp
++AB
++Shift
++Guide
++Select
++TxtOff
++TxtTrns
++Rec
+diff -Naur MouseRemote.ORG/client/MouseRemoteKeys.pl MouseRemote/client/MouseRemoteKeys.pl
+--- MouseRemote.ORG/client/MouseRemoteKeys.pl Sun Oct 10 00:09:42 1999
++++ MouseRemote/client/MouseRemoteKeys.pl Sat May 4 15:58:58 2002
+@@ -11,6 +11,7 @@
+ play => 0x0d,
+ stop => 0x0e,
+ power => 0x0f,
++ txtres => 0x1b,
+ rew => 0x1c,
+ ff => 0x1d,
+ 0 => 0x40,
+@@ -31,11 +32,13 @@
+ 'shift' => 0x6b,
+ guide => 0x6d,
+ 'select' => 0x93,
++ txtoff => 0x9b,
++ txttrns => 0xeb,
+ rec => 0xff,
+
+ pc => 0x2b,
+- phone => 0x4b,
++ phone => 0x4b, # Marked as F2 on my model
+ web => 0x8b,
+ cd => 0xab,
+- dvd => 0xcb,
++ dvd => 0xcb, # Marked as F1 on my model
+ );
diff --git a/app-misc/mouseremote/files/mouseremote.conf b/app-misc/mouseremote/files/mouseremote.conf
new file mode 100644
index 000000000000..cc6625c4a519
--- /dev/null
+++ b/app-misc/mouseremote/files/mouseremote.conf
@@ -0,0 +1,14 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Lauwers <blauwers@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mouseremote/files/mouseremote.conf,v 1.1 2002/05/09 11:30:02 blauwers Exp $
+# Config file for /etc/init.d/mouseremote
+
+# Configure the type of mouseremote you have and the device it is connected to
+
+# If your device is attached to the regular psaux port then set DRV to X10
+# If your device is attached to a serial port then set DRV to SX10
+#DRV=SX10
+
+# Set this to the port on which your mouseremote is attached
+#DEV=/dev/ttyS1
diff --git a/app-misc/mouseremote/files/mouseremote.start b/app-misc/mouseremote/files/mouseremote.start
new file mode 100644
index 000000000000..6a2e75186687
--- /dev/null
+++ b/app-misc/mouseremote/files/mouseremote.start
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Lauwers <blauwers@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mouseremote/files/mouseremote.start,v 1.1 2002/05/09 11:30:02 blauwers Exp $
+
+depend() {
+ use modules logger
+ before xdm
+}
+
+checkconfig() {
+ [ -z "$DEV" ] || [ -z "$DRV" ] || return 0
+ eerror "You need to setup DEV and DRV in /etc/conf.d/mouseremote first"
+ return 1
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting X10 MouseRemote Server"
+ /usr/sbin/multimoused -${DRV} ${DEV} 2> /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping X10 MouseRemote Server"
+ kill $(cat /var/lock/MultiMouse.pid)
+ eend ${?} "Failed to stop MouseRemote Server"
+}
diff --git a/app-misc/mouseremote/mouseremote-0.90.ebuild b/app-misc/mouseremote/mouseremote-0.90.ebuild
new file mode 100644
index 000000000000..d89d8a586f62
--- /dev/null
+++ b/app-misc/mouseremote/mouseremote-0.90.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bart Lauwers <blauwers@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mouseremote/mouseremote-0.90.ebuild,v 1.1 2002/05/09 11:30:02 blauwers Exp $
+
+DESCRIPTION="X10 MouseRemote"
+HOMEPAGE="http://www4.pair.com/gribnif/ha/"
+LICENSE="GPL-2"
+
+SRC_URI="http://www4.pair.com/gribnif/ha/MouseRemote.tar.gz"
+
+DEPEND=""
+RDEPEND="dev-perl/Time-HiRes"
+
+S=${WORKDIR}/MouseRemote
+
+src_compile() {
+ patch -p1 < ${FILESDIR}/${PN}-gentoo.diff || die
+ cd MultiMouse && emake \
+ PREFIX=/usr \
+ LOCKDIR=/var/lock \
+ JMANDIR=/usr/share/man/ja_JP.ujis || die
+}
+
+src_install () {
+ dobin MultiMouse/multimouse
+ dosbin MultiMouse/multimoused
+
+ dodoc README MultiMouse/README.jis MultiMouse/README.newstuff
+ newdoc MultiMouse/README README.MultiMouse
+ newdoc client/MouseRemote.conf MouseRemote.conf.dist
+ newdoc client/MouseRemote.pl MouseRemote.pl.dist
+ newdoc client/MouseRemoteKeys.pl MouseRemoteKeys.pl.dist
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mouseremote.start mouseremote
+ insinto /etc/conf.d
+ newins ${FILESDIR}/mouseremote.conf mouseremote
+}
+
+pkg_postinst() {
+ [ -e /dev/mumse ] || mkfifo ${ROOT}/dev/mumse
+ [ -e /dev/x10fifo ] || mkfifo ${ROOT}/dev/x10fifo
+
+ einfo "To use the mouse function in X, add the following to your XF86Config"
+ einfo "Section \"InputDevice\""
+ einfo " Identifier \"MouseREM\""
+ einfo " Driver \"mouse\""
+ einfo " Option \"Protocol\" \"MouseSystems\""
+ einfo " Option \"Device\" \"/dev/mumse\""
+ einfo "EndSection"
+ einfo
+ einfo "Don't forget to add the new device to the section \"ServerLayout\""
+ einfo "like: InputDevice \"MouseREM\" \"SendCoreEvents\""
+ einfo
+ einfo "Enable the daemon with \"rc-update add mouseremote default\"."
+ einfo
+ einfo "Configure the daemon is run in /etc/conf.d/mouseremote."
+ einfo
+ einfo "See /usr/share/doc/${PF} on how to configure the buttons."
+}