summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-08-21 11:20:43 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-08-21 11:20:43 +0000
commitefe71665f5e05cae0bd9b75fcd20827f33f5fc05 (patch)
tree01894f2fe5c82732f13bde7557de9f441c3d199f /app-misc/mc
parenttwo bugfixes (diff)
downloadhistorical-efe71665f5e05cae0bd9b75fcd20827f33f5fc05.tar.gz
historical-efe71665f5e05cae0bd9b75fcd20827f33f5fc05.tar.bz2
historical-efe71665f5e05cae0bd9b75fcd20827f33f5fc05.zip
two bugfixes
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/Manifest4
-rw-r--r--app-misc/mc/files/digest-mc-4.6.0-r21
-rw-r--r--app-misc/mc/files/mc.gentoo6
-rw-r--r--app-misc/mc/mc-4.6.0-r2.ebuild86
4 files changed, 92 insertions, 5 deletions
diff --git a/app-misc/mc/Manifest b/app-misc/mc/Manifest
index b06a81af29b0..455803accd60 100644
--- a/app-misc/mc/Manifest
+++ b/app-misc/mc/Manifest
@@ -1,8 +1,8 @@
MD5 4090f3780e5d0172d9571a02881e8b40 mc-4.5.55-r7.ebuild 2039
-MD5 6580c786edb86c9933e92d29d3b90737 mc-4.6.0-r2.ebuild 2293
+MD5 1b552b6a3eea589c5717cb1c441246ee mc-4.6.0-r2.ebuild 2297
MD5 45827173f96dfdfd6bee2c88c9f7490e mc-4.6.0.ebuild 1840
MD5 6e728fcb48031502109cfc362b3a9a70 mc-4.6.0-r1.ebuild 2272
-MD5 2ebf4a4481e3c16351d8230f1e23a13d ChangeLog 4467
+MD5 574aa9a638d5369c5f864f5ed629a369 ChangeLog 4617
MD5 d8853d9a555c715676945a15c98030c1 files/digest-mc-4.5.55-r7 125
MD5 c5a71ea818f2b8043cd26204c5d281d7 files/digest-mc-4.6.0 120
MD5 835695dda387b59a2497658f3f5af1d5 files/mc.gentoo 322
diff --git a/app-misc/mc/files/digest-mc-4.6.0-r2 b/app-misc/mc/files/digest-mc-4.6.0-r2
new file mode 100644
index 000000000000..1ea08f5eaef9
--- /dev/null
+++ b/app-misc/mc/files/digest-mc-4.6.0-r2
@@ -0,0 +1 @@
+MD5 70804dc9e2049e24f294ff7090a82a12 mc-4.6.0.tar.gz 3727676
diff --git a/app-misc/mc/files/mc.gentoo b/app-misc/mc/files/mc.gentoo
index 9762925fe515..a71d249b8f6b 100644
--- a/app-misc/mc/files/mc.gentoo
+++ b/app-misc/mc/files/mc.gentoo
@@ -11,6 +11,6 @@ done
# include this, so also xterm,kterm,gterm,etc will have default bash settings
-if [ "x$SHLVL" != "x1" ]; then # We're not a login shell
- . /etc/profile
-fi
+#if [ "x$SHLVL" != "x1" ]; then # We're not a login shell
+# . /etc/profile
+#fi
diff --git a/app-misc/mc/mc-4.6.0-r2.ebuild b/app-misc/mc/mc-4.6.0-r2.ebuild
new file mode 100644
index 000000000000..0d00ef070442
--- /dev/null
+++ b/app-misc/mc/mc-4.6.0-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r2.ebuild,v 1.1 2003/08/21 11:20:31 lanius Exp $
+
+IUSE="gpm nls samba ncurses X slang"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${P}.tar.gz"
+
+DEPEND=">=sys-apps/e2fsprogs-1.19
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ >=sys-libs/pam-0.72
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ samba? ( >=net-fs/samba-2.2.3a-r1 )
+ X? ( virtual/x11 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+src_compile() {
+ local myconf=""
+
+ if ! use slang && ! use ncurses
+ then
+ myconf="${myconf} --with-screen=mcslang"
+ elif
+ use ncurses && ! use slang
+ then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ use gpm \
+ && myconf="${myconf} --with-gpm-mouse" \
+ || myconf="${myconf} --without-gpm-mouse"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba
+ --with-codepagedir=/var/lib/samba/codepages" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-gnu-ld \
+ --with-ext2undel \
+ --with-edit \
+ --enable-charset \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ cat ${FILESDIR}/chdir-4.6.0.gentoo >>\
+ ${S}/lib/mc-wrapper.sh
+
+ einstall || die
+
+ dodoc ABOUT-NLS COPYING* ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+
+ insinto /usr/share/mc
+ doins ${FILESDIR}/mc.gentoo
+}
+
+pkg_postinst() {
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "allow mc to chdir to it's latest working dir at exit"
+ einfo ""
+ einfo "# Midnight Commander chdir enhancement"
+ einfo "if [ -f /usr/share/mc/mc.gentoo ]; then"
+ einfo " . /usr/share/mc/mc.gentoo"
+ einfo "fi"
+}