summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 21:17:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 21:17:24 +0000
commit12277fc04e3dda711f239e20d042162496186d22 (patch)
tree3ad62018b44a30040ea9935b2993145d28819a30 /app-misc/hachoir-urwid/hachoir-urwid-1.1.ebuild
parentFixed bug 307995 (patch by Iain Oliver), also fixed USE flags handling and re... (diff)
downloadhistorical-12277fc04e3dda711f239e20d042162496186d22.tar.gz
historical-12277fc04e3dda711f239e20d042162496186d22.tar.bz2
historical-12277fc04e3dda711f239e20d042162496186d22.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-15841-svn/cvs/Linux x86_64
Diffstat (limited to 'app-misc/hachoir-urwid/hachoir-urwid-1.1.ebuild')
-rw-r--r--app-misc/hachoir-urwid/hachoir-urwid-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/hachoir-urwid/hachoir-urwid-1.1.ebuild b/app-misc/hachoir-urwid/hachoir-urwid-1.1.ebuild
new file mode 100644
index 000000000000..3156552efde6
--- /dev/null
+++ b/app-misc/hachoir-urwid/hachoir-urwid-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hachoir-urwid/hachoir-urwid-1.1.ebuild,v 1.1 2010/03/26 21:17:24 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="ncurses"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Binary file explorer using Hachoir and urwid libraries"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-urwid http://pypi.python.org/pypi/hachoir-urwid"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/hachoir-core-1.2
+ >=dev-python/hachoir-parser-1.0
+ >=dev-python/urwid-0.9.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DISTUTILS_GLOBAL_OPTIONS=("--setuptools")
+PYTHON_MODNAME="${PN/-/_}"