summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 09:32:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-10 09:32:45 +0000
commit7f0234cb55750059151aec1b4e533cad4c51104f (patch)
treedab11283ba86491da10237c0a35a5e0fc3ac7fa4 /app-misc/cdspeed/cdspeed-0.3.ebuild
parentclean older ebuild (diff)
downloadhistorical-7f0234cb55750059151aec1b4e533cad4c51104f.tar.gz
historical-7f0234cb55750059151aec1b4e533cad4c51104f.tar.bz2
historical-7f0234cb55750059151aec1b4e533cad4c51104f.zip
don't assign default to S; depend on sed >= 4; error check sed; use user CFLAGS; tidy
Diffstat (limited to 'app-misc/cdspeed/cdspeed-0.3.ebuild')
-rw-r--r--app-misc/cdspeed/cdspeed-0.3.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/app-misc/cdspeed/cdspeed-0.3.ebuild b/app-misc/cdspeed/cdspeed-0.3.ebuild
index 5ed9e8415fb8..e07519cf9ec7 100644
--- a/app-misc/cdspeed/cdspeed-0.3.ebuild
+++ b/app-misc/cdspeed/cdspeed-0.3.ebuild
@@ -1,33 +1,35 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/cdspeed-0.3.ebuild,v 1.4 2004/02/29 17:19:59 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/cdspeed-0.3.ebuild,v 1.5 2004/04/10 09:32:45 mr_bones_ Exp $
DESCRIPTION="Change the speed of your CD drive."
HOMEPAGE="http://linuxfocus.org/~guido/"
-LICENSE="GPL-2"
+SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
-DEPEND="virtual/glibc"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~mips"
+IUSE=""
-SLOT="0"
-SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
-S=${WORKDIR}/${P}
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
cd ${S}
- sed -i -e "s:^CFLAGS=-O.*:CFLAGS=${CFLAGS}:" \
- Makefile
+ sed -i \
+ -e 's:^CFLAGS=.*:CFLAGS=$(E_CFLAGS):' Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
- emake || die
+ emake E_CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
- exeinto /usr/bin
- doexe cdspeed
+ dobin cdspeed || die "dobin failed"
exeinto /usr/lib/cdspeed
- doexe cdmount
+ doexe cdmount || die "doexe failed"
dodoc README
}