summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-12 14:50:06 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-12 14:50:06 +0000
commit1ef3dfef914943067ed454535bfcb8bc48f323fd (patch)
treee191d6a52d6933bce4cb2d641819f5540a78292d /app-i18n
parentFix --as-needed bug #247508 (diff)
downloadhistorical-1ef3dfef914943067ed454535bfcb8bc48f323fd.tar.gz
historical-1ef3dfef914943067ed454535bfcb8bc48f323fd.tar.bz2
historical-1ef3dfef914943067ed454535bfcb8bc48f323fd.zip
Version bumped.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog8
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090211.ebuild55
-rw-r--r--app-i18n/ibus-hangul/ChangeLog8
-rw-r--r--app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090211.ebuild38
-rw-r--r--app-i18n/ibus/ChangeLog8
-rw-r--r--app-i18n/ibus/ibus-1.1.0.20090211.ebuild97
6 files changed, 211 insertions, 3 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 56cdcfd61fe4..8db63d606341 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.5 2009/02/05 16:15:00 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.6 2009/02/12 14:50:06 matsuu Exp $
+
+*ibus-anthy-1.1.0.20090211 (12 Feb 2009)
+
+ 12 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-anthy-1.1.0.20090211.ebuild:
+ Version bumped.
*ibus-anthy-1.1.0.20090205 (05 Feb 2009)
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090211.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090211.ebuild
new file mode 100644
index 000000000000..dfbc346906c3
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090211.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.1.0.20090211.ebuild,v 1.1 2009/02/12 14:50:06 matsuu Exp $
+
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1.0
+ app-i18n/anthy
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-i18n/ibus-hangul/ChangeLog b/app-i18n/ibus-hangul/ChangeLog
index 5f200aefba41..395b919f6990 100644
--- a/app-i18n/ibus-hangul/ChangeLog
+++ b/app-i18n/ibus-hangul/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-hangul
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.3 2009/02/05 16:17:26 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ChangeLog,v 1.4 2009/02/12 14:49:55 matsuu Exp $
+
+*ibus-hangul-1.1.0.20090211 (12 Feb 2009)
+
+ 12 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-hangul-1.1.0.20090211.ebuild:
+ Version bumped.
*ibus-hangul-1.1.0.20090205 (05 Feb 2009)
diff --git a/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090211.ebuild b/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090211.ebuild
new file mode 100644
index 000000000000..5cedca4a12df
--- /dev/null
+++ b/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090211.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-hangul/ibus-hangul-1.1.0.20090211.ebuild,v 1.1 2009/02/12 14:49:55 matsuu Exp $
+
+DESCRIPTION="The Hangul engine for IBus input platform"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.1
+ app-i18n/libhangul
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index fb22e7732b7b..97a966bc5d81 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.18 2009/02/05 16:13:05 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.19 2009/02/12 14:47:51 matsuu Exp $
+
+*ibus-1.1.0.20090211 (12 Feb 2009)
+
+ 12 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-1.1.0.20090211.ebuild:
+ Version bumped.
*ibus-1.1.0.20090205 (05 Feb 2009)
diff --git a/app-i18n/ibus/ibus-1.1.0.20090211.ebuild b/app-i18n/ibus/ibus-1.1.0.20090211.ebuild
new file mode 100644
index 000000000000..7757b06bfe70
--- /dev/null
+++ b/app-i18n/ibus/ibus-1.1.0.20090211.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.1.0.20090211.ebuild,v 1.1 2009/02/12 14:47:51 matsuu Exp $
+
+EAPI="1"
+inherit autotools eutils multilib python
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls qt4"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2
+ >=gnome-base/gconf-2.11.1
+ >=gnome-base/librsvg-2
+ sys-apps/dbus
+ qt4? (
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+ )
+ app-text/iso-codes
+ x11-libs/libX11
+ >=dev-lang/python-2.5
+ >=dev-python/pygobject-2.15
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg
+ x11-misc/notification-daemon"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ sed -i -e '/QMAKE/s/$/ "CONFIG+=nostrip"/' client/qt4/Makefile.am || die
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls) \
+ $(use_enable qt4 qt4-immodule) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ local qt_im_module="xim"
+ use qt4 && qt_im_module="ibus"
+
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog "2. Set the following in your"
+ elog " user startup scripts such as .xinitrc or .bashrc"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"${qt_im_module}\""
+ elog " ibus &"
+
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_cleanup /usr/share/${PN}
+}