summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-05-16 10:48:22 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-05-16 10:48:22 +0000
commitb54d65502b58c87f77099a01d724ac41a8e1b1b4 (patch)
tree8a68c5bacf70c787b8a9f66405586e2d477b444a /app-emulation
parentgphoto: take virtual/libusb dep from 2.4.4-r1 ebuild (diff)
downloadhistorical-b54d65502b58c87f77099a01d724ac41a8e1b1b4.tar.gz
historical-b54d65502b58c87f77099a01d724ac41a8e1b1b4.tar.bz2
historical-b54d65502b58c87f77099a01d724ac41a8e1b1b4.zip
initial commit, bug 213287
Package-Manager: portage-2.1.6.11/cvs/Linux ppc
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/playonlinux/ChangeLog10
-rw-r--r--app-emulation/playonlinux/Manifest4
-rw-r--r--app-emulation/playonlinux/metadata.xml10
-rw-r--r--app-emulation/playonlinux/playonlinux-3.5.ebuild92
4 files changed, 116 insertions, 0 deletions
diff --git a/app-emulation/playonlinux/ChangeLog b/app-emulation/playonlinux/ChangeLog
new file mode 100644
index 000000000000..0847d846fbee
--- /dev/null
+++ b/app-emulation/playonlinux/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/playonlinux
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.1 2009/05/16 10:48:22 volkmar Exp $
+
+*playonlinux-3.5 (16 May 2009)
+
+ 16 May 2009; Mounir Lamouri <volkmar@gentoo.org> +metadata.xml,
+ +playonlinux-3.5.ebuild:
+ Initial commit. See bug 213287
+
diff --git a/app-emulation/playonlinux/Manifest b/app-emulation/playonlinux/Manifest
new file mode 100644
index 000000000000..ce8ad7e78a3d
--- /dev/null
+++ b/app-emulation/playonlinux/Manifest
@@ -0,0 +1,4 @@
+DIST PlayOnLinux_3.5.tar.gz 1057535 RMD160 acfb5ac4873e43040b134a996b3c6341b6df6301 SHA1 467eb9d03be44c42b678f2df614f322998f5cd23 SHA256 6e505b9f051f8c044e6c8aff013146a89a6615b2e3ca6fc7d730d662b9605ba1
+EBUILD playonlinux-3.5.ebuild 2759 RMD160 4a69db367c8b53beabe661b08b112c22766cdb40 SHA1 51dc62ca6d0c68564ba537568d632a972a9d19e7 SHA256 b04c92bb2bb698c8cf680c10c720e3983bc8ccb9a6a69ceb3bed8ef7bd80aba8
+MISC ChangeLog 383 RMD160 11de34fea7ec5225f7348faea486dd1f2879cd59 SHA1 b818d45185343991ada353ff8fe4478b5b7f4f86 SHA256 f56e0ccb14f85541c044800f460ed7d84a86fde43ae46e06ac740b5a81c0af15
+MISC metadata.xml 257 RMD160 224ee82bfe66c5da4a2dc1dd697b1782e7f03cb9 SHA1 6b583c76750b206bd133403d1a4685a14f8e6b95 SHA256 45f231de4d8bc5ed6309ba83d2eb9a06b8e13f828d7b74e909a144439356cd62
diff --git a/app-emulation/playonlinux/metadata.xml b/app-emulation/playonlinux/metadata.xml
new file mode 100644
index 000000000000..d44dc8ef07cc
--- /dev/null
+++ b/app-emulation/playonlinux/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>volkmar@gentoo.org</email>
+ <name>Mounir Lamouri</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/app-emulation/playonlinux/playonlinux-3.5.ebuild b/app-emulation/playonlinux/playonlinux-3.5.ebuild
new file mode 100644
index 000000000000..564657089f29
--- /dev/null
+++ b/app-emulation/playonlinux/playonlinux-3.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-3.5.ebuild,v 1.1 2009/05/16 10:48:22 volkmar Exp $
+
+EAPI="1"
+
+inherit eutils python games
+
+MY_PN="PlayOnLinux"
+
+DESCRIPTION="Set of scripts to easily install and use Windows(tm) games and softwares"
+HOMEPAGE="http://playonlinux.com/"
+SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-emulation/wine
+ app-arch/cabextract
+ app-arch/unzip
+ dev-python/wxpython:2.8
+ media-gfx/imagemagick
+ x11-terms/xterm"
+
+S=${WORKDIR}/${PN}
+
+# TODO:
+# Having a real install script and let playonlinux use standard filesystem
+# architecture to prevent having everything installed into GAMES_DATADIR
+# It will let using LANGUAGES easily
+
+src_install() {
+ # all things without exec permissions
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r themes lang lib etc || die "doins failed"
+
+ # bash/ install
+ exeinto "${GAMES_DATADIR}/${PN}/bash"
+ doexe bash/* || die "doexe failed"
+ exeinto "${GAMES_DATADIR}/${PN}/bash/terminals"
+ doexe bash/terminals/* || die "doexe failed"
+ exeinto "${GAMES_DATADIR}/${PN}/bash/expert"
+ doexe bash/expert/* || die "doexe failed"
+ exeinto "${GAMES_DATADIR}/${PN}/bash/options"
+ doexe bash/options/* || die "doexe failed"
+
+ # python/ install
+ exeinto "${GAMES_DATADIR}/${PN}/python"
+ doexe python/* || die "doexe failed"
+ exeinto "${GAMES_DATADIR}/${PN}/python/tools"
+ doexe python/tools/* || die "doexe failed"
+ # sub dir without exec permissions
+ insinto "${GAMES_DATADIR}/${PN}/python"
+ doins -r python/lib || die "doins failed"
+
+ # daemon/ install
+ exeinto "${GAMES_DATADIR}/${PN}/daemon"
+ doexe daemon/* || "doexe failed"
+
+ # main executable files
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe ${PN} || die "doexe failed"
+ doexe ${PN}-pkg || die "doexe failed"
+ doexe ${PN}-daemon || die "doexe failed"
+
+ # making a script to run app from ${GAMES_BINDIR}
+ echo "#!/bin/bash" > ${PN}_launcher
+ echo "cd \"${GAMES_DATADIR}/${PN}\" && ./${PN}" >> ${PN}_launcher
+ newgamesbin playonlinux_launcher playonlinux || die "newgamesbin failed"
+
+ dodoc CHANGELOG || die "dodoc failed"
+
+ doicon etc/${PN}.png || die "doicon failed"
+ make_desktop_entry ${PN} ${MY_PN} || die "make_desktop_entry failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ python_mod_optimize "${ROOT}${GAMES_DATADIR}/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}${GAMES_DATADIR}/${PN}"
+
+ ewarn "Installed softwares and games with playonlinux have not been removed."
+ ewarn "To remove them, you can re-install playonlinux and remove them using it"
+ ewarn "or do it manually."
+}