summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-16 01:50:21 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-16 01:50:21 +0000
commita831cc211d67a477ea995455729accb486927c4c (patch)
treeb63f35ef1aa2de0b5e909874dde96816abf7c6bd /app-emulation
parentversion bump #19736 (diff)
downloadhistorical-a831cc211d67a477ea995455729accb486927c4c.tar.gz
historical-a831cc211d67a477ea995455729accb486927c4c.tar.bz2
historical-a831cc211d67a477ea995455729accb486927c4c.zip
glx patch #24383
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xmame/ChangeLog5
-rw-r--r--app-emulation/xmame/files/0.70.1-glx-fix.patch19
-rw-r--r--app-emulation/xmame/xmame-0.70.1.ebuild4
3 files changed, 26 insertions, 2 deletions
diff --git a/app-emulation/xmame/ChangeLog b/app-emulation/xmame/ChangeLog
index 74fc8ded8f18..c3d633fd4ce4 100644
--- a/app-emulation/xmame/ChangeLog
+++ b/app-emulation/xmame/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-emulation/xmame
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.20 2003/07/11 16:53:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.21 2003/07/16 01:50:21 vapier Exp $
*xmame-0.70.1 (11 Jul 2003)
+ 15 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add glx patch #24383.
+
11 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
Version bump + major rehaul of code. Thanks to Caleb Shay <caleb@webninja.com> for
his ideas/submissions.
diff --git a/app-emulation/xmame/files/0.70.1-glx-fix.patch b/app-emulation/xmame/files/0.70.1-glx-fix.patch
new file mode 100644
index 000000000000..20d29a9d0573
--- /dev/null
+++ b/app-emulation/xmame/files/0.70.1-glx-fix.patch
@@ -0,0 +1,19 @@
+diff -urN xmame-0.70.1-orig/src/unix/osd_cpu.h xmame-0.70.1/src/unix/osd_cpu.h
+--- xmame-0.70.1-orig/src/unix/osd_cpu.h 2003-06-12 05:37:50.000000000 +0200
++++ xmame-0.70.1/src/unix/osd_cpu.h 2003-07-15 15:09:03.000000000 +0200
+@@ -39,11 +39,15 @@
+ #endif
+
+ /* grrr work around some stupid header conflicts */
++#ifndef xgl
+ #if !defined __XF86_DGA_C && !defined __XOPENGL_C_ && !defined LONG64
+ typedef signed char INT8;
+ typedef signed short INT16;
+ typedef signed int INT32;
+ #endif
++#else
++#include <X11/Xmd.h>
++#endif
+
+ #ifndef LONG64
+ typedef signed long long INT64;
diff --git a/app-emulation/xmame/xmame-0.70.1.ebuild b/app-emulation/xmame/xmame-0.70.1.ebuild
index a8033abebf8b..26b965eb358f 100644
--- a/app-emulation/xmame/xmame-0.70.1.ebuild
+++ b/app-emulation/xmame/xmame-0.70.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.70.1.ebuild,v 1.2 2003/07/11 23:28:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.70.1.ebuild,v 1.3 2003/07/16 01:50:21 vapier Exp $
inherit games flag-o-matic gcc
@@ -33,6 +33,8 @@ src_unpack() {
cd ${S}
+ epatch ${FILESDIR}/${PV}-glx-fix.patch
+
[ ${ARCH} == "x86" ] && sed -i -e '/X86_ASM_68000 =/s:#::' -e '/X86_MIPS3_DRC =/s:#::' Makefile
[ ${ARCH} == "ppc" ] && sed -i '/^MY_CPU/s:i386:risc:' Makefile
[ ${ARCH} == "sparc" ] && sed -i '/^MY_CPU/s:i386:risc:' Makefile