summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-04 21:04:15 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-04 21:04:15 +0000
commit748011323497c8045520bda19eed7aa897a6d740 (patch)
tree64bcf480ec6058fe0aea6586de9cf8b986169aca /app-emulation
parentfixing fftw depend. (diff)
downloadhistorical-748011323497c8045520bda19eed7aa897a6d740.tar.gz
historical-748011323497c8045520bda19eed7aa897a6d740.tar.bz2
historical-748011323497c8045520bda19eed7aa897a6d740.zip
Cleanup submitted by Jonathan Heaney
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uae/ChangeLog6
-rw-r--r--app-emulation/uae/Manifest5
-rw-r--r--app-emulation/uae/files/install_libscg_gentoo27
-rw-r--r--app-emulation/uae/uae-0.8.25_pre20040302.ebuild14
4 files changed, 11 insertions, 41 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 02373a615a14..0c65d3ff164b 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.13 2004/03/04 20:05:05 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.14 2004/03/04 21:04:12 dholm Exp $
+
+ 04 Mar 2004; David Holm <dholm@gentoo.org> uae-0.8.25_pre20040302.ebuild,
+ files/install_libscg_gentoo:
+ Cleanup submitted by Jonathan Heaney.
*uae-0.8.25_pre20040302 (04 Mar 2004)
diff --git a/app-emulation/uae/Manifest b/app-emulation/uae/Manifest
index 948bc97f30bd..39a6537b3719 100644
--- a/app-emulation/uae/Manifest
+++ b/app-emulation/uae/Manifest
@@ -1,10 +1,9 @@
-MD5 3739bd42d898dd2a25d52b7a3dc8065c ChangeLog 2165
+MD5 d8b01c760b4e6291119ca205968eeb6b ChangeLog 2313
MD5 9942fdc6d0c4e617f237b18ed3f71768 uae-0.8.22.ebuild 1251
MD5 800d59bca6b74f54268ca8c63af928ee metadata.xml 668
MD5 a79fb678ea1d364d3105b6fbc3ddacc4 uae-0.8.23_pre20040129.ebuild 1348
-MD5 ffd307645922b6b8b10e455921b5937d uae-0.8.25_pre20040302.ebuild 1559
+MD5 4864bd6964906719d773b6ad309c7bab uae-0.8.25_pre20040302.ebuild 1438
MD5 b2fac0f21ee34abaa6279cf7ad023119 files/digest-uae-0.8.22 62
MD5 4d3af2d2cc2945b006249066cb8c7adb files/uae-patch.diff 364
MD5 24ce02be9243fef32739ff76bd9ba84c files/digest-uae-0.8.23_pre20040129 73
-MD5 b40e309b9e4a5592840dca0346ee0de5 files/install_libscg_gentoo 652
MD5 02f734719ea8dc27787fb6be6ddcc11e files/digest-uae-0.8.25_pre20040302 73
diff --git a/app-emulation/uae/files/install_libscg_gentoo b/app-emulation/uae/files/install_libscg_gentoo
deleted file mode 100644
index 4670d5b72eae..000000000000
--- a/app-emulation/uae/files/install_libscg_gentoo
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-#
-# copy those files that are necessary to use the libscg
-# in UAE ON GENTOO
-#
-# Patrick Ohly, 9.4.2000, GPL
-#
-# Updated for cdrtools 2.0.x Richard Drummond 15.2.2004
-# Ripped to pieces by Jonathan Heaney 23.2.2004
-#
-# check arguments
-#
-libsdir=/usr/lib
-incsdir=/usr/include
-scsiinc="$incsdir"/scsilib
-
-#
-# find our own directory
-# hint: this file is in src
-#
-uaedir=`dirname "$0"`
-
-cp -R -f -L "$scsiinc/btorder.h" "$scsiinc/intcvt.h" "$scsiinc/mconfig.h" \
- "$scsiinc/prototyp.h" "$scsiinc/utypes.h" "$scsiinc/scg" \
- "$incsdir/xconfig.h" "$uaedir"/include
-cp -f "$libsdir/libscg.a" \
- "$libsdir/libschily.a" "$uaedir"
diff --git a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
index c4db6b94b086..0ef924c0e572 100644
--- a/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
+++ b/app-emulation/uae/uae-0.8.25_pre20040302.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.1 2004/03/04 20:05:05 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.25_pre20040302.ebuild,v 1.2 2004/03/04 21:04:12 dholm Exp $
inherit flag-o-matic
@@ -18,26 +18,20 @@ IUSE="X gtk sdl"
DEPEND="X? ( virtual/x11 gtk? x11-libs/gtk+ ) :
( ncurses? sys-libs/ncurses svga? media-libs/svgalib )
sdl? media-libs/libsdl
- games-emulation/caps
- app-cdr/cdrtools"
+ app-cdr/cdrtools
+ games-emulation/caps"
src_compile() {
ewarn "Compiling the CPU-core requires a substantial amount of RAM."
ewarn "Make sure that you have at least 512MB of RAM+SWAP available."
- # copy over dirty scsi copy script
- cp ${FILESDIR}/install_libscg_gentoo ${S}/src
- # and run
- /bin/sh ${S}/src/install_libscg_gentoo
-
replace-flags "-O3" "-O2"
use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
econf ${myconf} \
--enable-threads \
--enable-scsi-device \
- --enable-cdtv \
- --enable-cd32 \
+ --with-libscg-includedir=/usr/include/scsilib \
|| die "./configure failed"
emake -j1 || die "emake failed"