summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-09 18:50:55 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-09 18:50:55 +0000
commit92bb42b8fc0aea73d62b0fc6951913dbff68542a (patch)
tree09ab3e69971a0d59293e7f143fe1b8c47c4d7ef6 /app-emulation/wine
parentcleanup (diff)
downloadhistorical-92bb42b8fc0aea73d62b0fc6951913dbff68542a.tar.gz
historical-92bb42b8fc0aea73d62b0fc6951913dbff68542a.tar.bz2
historical-92bb42b8fc0aea73d62b0fc6951913dbff68542a.zip
cleanup
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/Manifest2
-rw-r--r--app-emulation/wine/wine-20031118.ebuild126
2 files changed, 0 insertions, 128 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 30399afd3cdc..9e4d8ca4438d 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,9 +1,7 @@
-MD5 bf8a6ecb4897cb73eeac70260c40f136 wine-20031118.ebuild 3284
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 9bf1cedbd74c942349dea043a5c457e6 wine-20031016.ebuild 3285
MD5 7f4cd16ddc0c267538fefef61936109c wine-20031118-r1.ebuild 3362
MD5 0658f7590c52a36b7684f8ef169556ad ChangeLog 10935
-MD5 bde92e756c5eaff5ee1d195d4d098cc9 files/digest-wine-20031118 282
MD5 babcff559a797fab676479737edee307 files/digest-wine-20031016 282
MD5 1668a758aa2007cb99a773b3c5c844c9 files/winearts-kdecvs-fix.patch 325
MD5 f4c2e1af9760b436e551775c823b6bed files/digest-wine-20031118-r1 285
diff --git a/app-emulation/wine/wine-20031118.ebuild b/app-emulation/wine/wine-20031118.ebuild
deleted file mode 100644
index 70dc633553a3..000000000000
--- a/app-emulation/wine/wine-20031118.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20031118.ebuild,v 1.1 2003/11/19 19:34:23 mholzer Exp $
-
-inherit eutils base
-
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
-HOMEPAGE="http://www.winehq.com/"
-SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
- mirror://gentoo/${P}-xopenfont.patch
- mirror://gentoo/${P}-fake_windows.tar.bz2
- mirror://gentoo/${P}-misc.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 -ppc -sparc"
-IUSE="nas arts cups opengl alsa tcltk nptl debug"
-
-DEPEND="sys-devel/gcc
- sys-devel/flex
- dev-util/yacc
- >=sys-libs/ncurses-5.2
- >=media-libs/freetype-2.0.0
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tcl dev-lang/tk )
- arts? ( kde-base/arts )
- alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )"
-
-src_unpack() {
- base_src_unpack
- cd ${S}
- epatch ${DISTDIR}/${P}-xopenfont.patch
-}
-
-src_compile() {
- # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
-
- unset CFLAGS CXXFLAGS
-
- ac_cv_header_jack_jack_h=no \
- ac_cv_lib_soname_jack= \
- ./configure \
- --prefix=/usr/lib/wine \
- --sysconfdir=/etc/wine \
- --host=${CHOST} \
- --enable-curses \
- `use_enable opengl` \
- `use_with nptl` \
- `use_enable debug trace` \
- `use_enable debug` \
- || die "configure failed"
-
- cd ${S}/programs/winetest
- sed -i 's:wine.pm:include/wine.pm:' Makefile
-
- # No parallel make
- cd ${S}
- make depend all || die
- cd programs && emake || die
-}
-
-src_install() {
- local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
-
- ### Install wine to ${D}
- make ${WINEMAKEOPTS} install || die
- cd ${S}/programs
- make ${WINEMAKEOPTS} install || die
-
- # Needed for later installation
- dodir /usr/bin
-
- ### Creation of /usr/lib/wine/.data
- # Setting up fake_windows
- dodir /usr/lib/wine/.data
- cd ${D}/usr/lib/wine/.data
- tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
- chown root:root fake_windows/ -R
-
- # Unpacking the miscellaneous files
- tar jxvf ${DISTDIR}/${P}-misc.tar.bz2
- chown root:root config
-
- # moving the wrappers to bin/
- insinto /usr/bin
- dobin regedit-wine wine
- rm regedit-wine wine
-
- # copying the winedefault.reg into .data
- insinto /usr/lib/wine/.data
- doins ${WORKDIR}/${P}/winedefault.reg
-
- # Set up this dynamic data
- cd ${S}
- insinto /usr/lib/wine/.data/fake_windows/Windows
- doins documentation/samples/system.ini
- doins documentation/samples/generic.ppd
- ## Setup of .data complete
-
- ### Misc tasks
- # Take care of the documentation
- cd ${S}
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
-
- # Manpage setup
- cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
- doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
- rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
- doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
- rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
-
- # Remove the executable flag from those libraries.
- cd ${D}/usr/lib/wine/lib/wine
- chmod a-x *.so
-}
-
-pkg_postinst() {
- einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
- einfo "which will take care of everything else."
- einfo ""
- einfo "Use /usr/bin/regedit-wine to import registry files into the"
- einfo "wine registry."
-}