summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-07-13 14:03:12 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-07-13 14:03:12 +0000
commit6187cb1f04cafa6c094ddb6730c6fa425119fe4e (patch)
tree7ee53bd9700c836f4e32af215bac9c813b96c2ec /app-emulation/qemu
parentfilter some gcc 3.4 flags that the gcc 3.3.3 xgcc will fail on (diff)
downloadhistorical-6187cb1f04cafa6c094ddb6730c6fa425119fe4e.tar.gz
historical-6187cb1f04cafa6c094ddb6730c6fa425119fe4e.tar.bz2
historical-6187cb1f04cafa6c094ddb6730c6fa425119fe4e.zip
New version
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog8
-rw-r--r--app-emulation/qemu/Manifest5
-rw-r--r--app-emulation/qemu/files/digest-qemu-0.6.01
-rw-r--r--app-emulation/qemu/files/qemu-0.6.0-typo.patch12
-rw-r--r--app-emulation/qemu/qemu-0.6.0.ebuild59
5 files changed, 83 insertions, 2 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 1232dde6217b..333b9b5b3a61 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.13 2004/07/02 20:41:26 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.14 2004/07/13 14:03:12 lu_zero Exp $
+
+*qemu-0.6.0 (13 Jul 2004)
+
+ 13 Jul 2004; Luca Barbato <lu_zero@gentoo.org> +files/qemu-0.6.0-typo.patch,
+ +qemu-0.6.0.ebuild:
+ New version
*qemu-0.5.5-r1 (02 Jul 2004)
diff --git a/app-emulation/qemu/Manifest b/app-emulation/qemu/Manifest
index 2fc250b55964..a32159d1ce4d 100644
--- a/app-emulation/qemu/Manifest
+++ b/app-emulation/qemu/Manifest
@@ -1,11 +1,14 @@
+MD5 0e65c5cc5f17f5e00f4c219e3782a0de qemu-0.6.0.ebuild 1530
MD5 db6c35fa4ad6e21c959cab27a63e0e84 qemu-0.5.3.ebuild 1129
-MD5 4f8f9268b6e422ecdf0d0e29baf0c09a ChangeLog 1609
+MD5 c0e76c3bb735fad7c61a3904652adcd2 ChangeLog 1752
MD5 be42bb328ff24160549960a145f53d42 qemu-0.5.5-r1.ebuild 1515
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
MD5 4cb86c404627f57c95e561741dda268f qemu-0.5.5.ebuild 1475
MD5 b320f3f8c9b4c5695af93a4b8a65ed2e qemu-0.5.4.ebuild 1233
MD5 4b86f5b59feacd176698e9ecb59e7040 qemu-0.5.1.ebuild 1257
MD5 18dca85a7af16809c4aa1c7c0053e611 qemu-0.5.2.ebuild 1257
+MD5 f6094ee9cd2ee3a38404680796df2b75 files/qemu-0.6.0-typo.patch 528
+MD5 9052eb692ddc0cbb296d7712b0cc6f44 files/digest-qemu-0.6.0 62
MD5 ed6b8235e3ff239ab99ca1d1a27bb3a3 files/digest-qemu-0.5.5 62
MD5 0c6b253eac2104422e703ff88143185a files/digest-qemu-0.5.3 62
MD5 88e94451ca673f24fe04a290f6675c88 files/digest-qemu-0.5.1 62
diff --git a/app-emulation/qemu/files/digest-qemu-0.6.0 b/app-emulation/qemu/files/digest-qemu-0.6.0
new file mode 100644
index 000000000000..dc459bc45072
--- /dev/null
+++ b/app-emulation/qemu/files/digest-qemu-0.6.0
@@ -0,0 +1 @@
+MD5 cdbc7258f122f381cba7ac1ca6ce0722 qemu-0.6.0.tar.gz 874397
diff --git a/app-emulation/qemu/files/qemu-0.6.0-typo.patch b/app-emulation/qemu/files/qemu-0.6.0-typo.patch
new file mode 100644
index 000000000000..52fb55af849a
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-0.6.0-typo.patch
@@ -0,0 +1,12 @@
+diff -ruN qemu-0.6.0.orig/cpu-exec.c qemu-0.6.0/cpu-exec.c
+--- qemu-0.6.0.orig/cpu-exec.c 2004-07-13 15:40:54.008504168 +0200
++++ qemu-0.6.0/cpu-exec.c 2004-07-13 15:41:16.604069120 +0200
+@@ -903,7 +903,7 @@
+ # define TRAP_sig(context) EXCEPREG_sig(exception, context) /* number of powerpc exception taken */
+ #endif /* __APPLE__ */
+
+-int cpu_signal_handler(int host_signum, siginfo *info,
++int cpu_signal_handler(int host_signum, struct siginfo *info,
+ void *puc)
+ {
+ struct ucontext *uc = puc;
diff --git a/app-emulation/qemu/qemu-0.6.0.ebuild b/app-emulation/qemu/qemu-0.6.0.ebuild
new file mode 100644
index 000000000000..797b0218b42c
--- /dev/null
+++ b/app-emulation/qemu/qemu-0.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.6.0.ebuild,v 1.1 2004/07/13 14:03:12 lu_zero Exp $
+
+inherit eutils
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -alpha -sparc"
+IUSE="softmmu qemu-fast sdl"
+RESTRICT="nostrip"
+
+DEPEND="virtual/libc
+ sdl? ( media-libs/libsdl )"
+RDEPEND=""
+
+set_target_list() {
+ TARGET_LIST="arm-user i386-user ppc-user sparc-user" #i386-softmmu ppc-softmmu
+ use softmmu && TARGET_LIST="${TARGET_LIST} i386-softmmu ppc-softmmu"
+ use qemu-fast && TARGET_LIST="${TARGET_LIST} i386"
+ export TARGET_LIST
+}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-typo.patch
+}
+
+src_compile() {
+ set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp \
+ `use_enable sdl`\
+ || die "could not configure"
+ make || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc \
+ mandir=${D}/usr/share/man || die
+}
+
+pkg_postinst() {
+ echo ">> You will need the Universal TUN/TAP driver compiled into"
+ echo ">> kernel or as a module to use the virtual network device."
+}