summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-16 12:12:57 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-16 12:12:57 +0000
commitb059862ab674038ad66ec9fcaa731dceb062f160 (patch)
tree589c5e44a02ba1bfc3ed83d9e51b800aa0f341ad /app-emulation/dosemu
parentRemoved broken ebuilds. (diff)
downloadhistorical-b059862ab674038ad66ec9fcaa731dceb062f160.tar.gz
historical-b059862ab674038ad66ec9fcaa731dceb062f160.tar.bz2
historical-b059862ab674038ad66ec9fcaa731dceb062f160.zip
version bump which fixes a host of bugs.
Diffstat (limited to 'app-emulation/dosemu')
-rw-r--r--app-emulation/dosemu/ChangeLog9
-rw-r--r--app-emulation/dosemu/Manifest7
-rw-r--r--app-emulation/dosemu/dosemu-1.1.4.15.ebuild70
-rw-r--r--app-emulation/dosemu/dosemu-1.1.4.ebuild11
-rw-r--r--app-emulation/dosemu/files/digest-dosemu-1.1.4.153
5 files changed, 94 insertions, 6 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index aacbb1874f43..1a94a74ae6fb 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/dosemu
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.8 2003/02/12 04:00:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.9 2003/04/16 12:12:57 liquidx Exp $
+
+*dosemu-1.1.4.15 (16 Apr 2003)
+
+ 16 Apr 2003; Alastair Tse <liquidx@gentoo.org> dosemu-1.1.4.15.ebuild,
+ dosemu-1.1.4.ebuild:
+ bumping to an unstable testing version because this fixes the ugly build
+ scripts and also the errno problem with slang .ar.
*dosemu-1.1.4 (07 Feb 2003)
diff --git a/app-emulation/dosemu/Manifest b/app-emulation/dosemu/Manifest
new file mode 100644
index 000000000000..89ea7f0eecb9
--- /dev/null
+++ b/app-emulation/dosemu/Manifest
@@ -0,0 +1,7 @@
+MD5 8aa65ff7293c715899135811164cbef7 ChangeLog 1422
+MD5 27739374e52001236c26589a9f84f2c2 dosemu-1.1.3-r1.ebuild 2162
+MD5 04828a50f3c5691adc6126ac3458c302 dosemu-1.1.4.ebuild 2207
+MD5 93e0f7371f4e8a00e7009f01673027ae dosemu-1.1.4.15.ebuild 2442
+MD5 20a65e5999072d738757e22ed2626e28 files/digest-dosemu-1.1.3-r1 129
+MD5 a6ff6e1d128581d10035bc7d7bc781a5 files/digest-dosemu-1.1.4 129
+MD5 5e4f5c1cb8a157071502e110dbb13e15 files/digest-dosemu-1.1.4.15 195
diff --git a/app-emulation/dosemu/dosemu-1.1.4.15.ebuild b/app-emulation/dosemu/dosemu-1.1.4.15.ebuild
new file mode 100644
index 000000000000..4046ddad025a
--- /dev/null
+++ b/app-emulation/dosemu/dosemu-1.1.4.15.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.1.4.15.ebuild,v 1.1 2003/04/16 12:12:57 liquidx Exp $
+
+IUSE="X svga"
+
+MAJOR_PV=${PV%.[0-9]*}
+MINOR_PV=${PV##[0-9]*.}
+S=${WORKDIR}/${PN}-${MAJOR_PV}
+DESCRIPTION="DOS Emulator"
+SRC_URI="mirror://sourceforge/dosemu/${PN}-freedos-bin.tgz
+ mirror://sourceforge/dosemu/${PN}-${MAJOR_PV}.tgz
+ http://dosemu.sourceforge.net/testing/patchset-${PV}.tgz"
+HOMEPAGE="http://www.dosemu.org/"
+LICENSE="GPL-2 | LGPL-2.1"
+KEYWORDS="~x86 -ppc"
+SLOT="0"
+DEPEND="X? ( virtual/x11 )
+ svga? ( media-libs/svgalib )
+ sys-libs/slang"
+
+src_unpack() {
+ unpack ${PN}-${MAJOR_PV}.tgz
+ # do patches
+ cd ${S}
+ unpack patchset-${PV}.tgz
+ sh tmp/do_patch || die
+ # extract freedos binary
+ cd ${S}/src
+ unpack ${PN}-freedos-bin.tgz
+}
+
+src_compile() {
+
+ local myflags
+
+### mitshm will bork ./base-configure entirely, so we disable it here
+ myflags="--enable-mitshm=no"
+ myflags="${myflags} --enable-experimental"
+ myflags="${myflags} --disable-force-slang"
+
+### and then set build paramaters based on USE variables
+ use X || myflags="${myflags} --with-x=no"
+ use svga && myflags="${myflags} --enable-use-svgalib"
+
+ econf ${myflags} || die "DOSemu Base Configuration Failed"
+
+### We HAVE to do this, or the build will fail due to strange additional
+### files in the downloaded tarball!
+# emake pristine || die "Dosemu Make Pristine Failed"
+
+### Ok, the build tree is clean, lets make the executables, and 'dos' commands
+ emake -C src || die "DOSemu Make Failed!"
+ emake dosbin || die "DOSbin Make Failed"
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ doman man/*.1
+ rm -rf ${D}/opt/dosemu/man/
+
+ mv ${D}/usr/share/doc/dosemu ${D}/usr/share/doc/${PF}
+
+ # freedos tarball is needed in /usr/share/dosemu
+ cp ${DISTDIR}/${PN}-freedos-bin.tgz ${D}/usr/share/dosemu
+
+}
+
diff --git a/app-emulation/dosemu/dosemu-1.1.4.ebuild b/app-emulation/dosemu/dosemu-1.1.4.ebuild
index 7ea790ad88ff..d9a302efdd3f 100644
--- a/app-emulation/dosemu/dosemu-1.1.4.ebuild
+++ b/app-emulation/dosemu/dosemu-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.1.4.ebuild,v 1.2 2003/02/13 07:13:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.1.4.ebuild,v 1.3 2003/04/16 12:12:57 liquidx Exp $
IUSE="X svga"
@@ -27,19 +27,20 @@ src_compile() {
### mitshm will bork ./base-configure entirely, so we disable it here
myflags="--enable-mitshm=no"
myflags="${myflags} --enable-experimental"
+ myflags="${myflags} --enable-force-slang=no"
### and then set build paramaters based on USE variables
use X || myflags="${myflags} --with-x=no"
use svga && myflags="${myflags} --enable-use-svgalib"
-### this is really a ./configure (honestly)
- ./base-configure \
- ${myflags} || die "DOSemu Base Configuration Failed"
-
### We HAVE to do this, or the build will fail due to strange additional
### files in the downloaded tarball!
emake pristine || die "Dosemu Make Pristine Failed"
+### this is really a ./configure (honestly)
+ ./base-configure \
+ ${myflags} || die "DOSemu Base Configuration Failed"
+
### Ok, the build tree is clean, lets make the executables, and 'dos' commands
emake -C src || die "DOSemu Make Failed!"
emake dosbin || die "DOSbin Make Failed"
diff --git a/app-emulation/dosemu/files/digest-dosemu-1.1.4.15 b/app-emulation/dosemu/files/digest-dosemu-1.1.4.15
new file mode 100644
index 000000000000..ec64bd0bb273
--- /dev/null
+++ b/app-emulation/dosemu/files/digest-dosemu-1.1.4.15
@@ -0,0 +1,3 @@
+MD5 ba5004378e6cacb1f7e5f9155f1ef176 dosemu-freedos-bin.tgz 686855
+MD5 be632c6e5edd3388d9d6d2c8dba7dc10 dosemu-1.1.4.tgz 2200531
+MD5 21b6d8cf3797333e6be0ddf8954e58e1 patchset-1.1.4.15.tgz 702493