summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 23:10:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 23:10:34 +0000
commit509ff8ffdb33d927dfa9f22084998201d6fb2d33 (patch)
tree1a2f1ccd202c2b3986e11f4d3e52c82fcb712154 /app-emulation/bochs
parentver bump (diff)
downloadhistorical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.tar.gz
historical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.tar.bz2
historical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.zip
touch the libc
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/bochs-1.4.1.ebuild36
-rw-r--r--app-emulation/bochs/bochs-1.4.ebuild34
-rw-r--r--app-emulation/bochs/bochs-2.0.2.ebuild10
-rw-r--r--app-emulation/bochs/bochs-2.0.ebuild32
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild8
-rw-r--r--app-emulation/bochs/bochs-2.1.ebuild8
6 files changed, 59 insertions, 69 deletions
diff --git a/app-emulation/bochs/bochs-1.4.1.ebuild b/app-emulation/bochs/bochs-1.4.1.ebuild
index f8ddd8d673bf..58b416422071 100644
--- a/app-emulation/bochs/bochs-1.4.1.ebuild
+++ b/app-emulation/bochs/bochs-1.4.1.ebuild
@@ -1,37 +1,34 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.1.ebuild,v 1.11 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.1.ebuild,v 1.12 2004/06/27 23:01:44 vapier Exp $
-DESCRIPTION="Bochs is a pc emulator.
-This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
-CDROM drive. It also comes with a disk image using dlxlinux."
+DESCRIPTION="a pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
-HOMEPAGE="http://bochs.sourceforge.net"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="x86 ppc ~alpha"
IUSE=""
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11"
-KEYWORDS="x86 ppc ~alpha"
-
src_unpack() {
unpack ${P}.tar.gz
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
- -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
- -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
- -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
-
+ cd ${S}
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
+ -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' \
+ Makefile.in
}
src_compile() {
-
[ "$ARCH" == "x86" ] && myconf="--enable-idle-hack"
./configure --enable-fpu --enable-cdrom --enable-control-panel \
@@ -44,8 +41,7 @@ src_compile() {
emake || die
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ dodoc CHANGES CVS README TESTFORM.txt
}
diff --git a/app-emulation/bochs/bochs-1.4.ebuild b/app-emulation/bochs/bochs-1.4.ebuild
index de7f58424410..c88fbbef7c1c 100644
--- a/app-emulation/bochs/bochs-1.4.ebuild
+++ b/app-emulation/bochs/bochs-1.4.ebuild
@@ -1,36 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.ebuild,v 1.17 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.ebuild,v 1.18 2004/06/27 23:01:44 vapier Exp $
MY_P=${P/_/.}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="Bochs is a pc emulator.
-This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
-CDROM drive.
-It also comes with a disk image using dlxlinux."
+DESCRIPTION="a pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net"
SRC_URI="mirror://sourceforge/bochs/${MY_P}.tar.gz
http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
-HOMEPAGE="http://bochs.sourceforge.net"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="x86 ppc"
IUSE=""
-#build-time dependencies
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11"
-KEYWORDS="x86 ppc"
-
src_unpack() {
unpack ${MY_P}.tar.gz
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
- -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
- -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
-
+ cd ${S}
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
+ -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' \
+ Makefile.in
}
src_compile() {
@@ -44,7 +40,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ dodoc CHANGES CVS README TESTFORM.txt
}
diff --git a/app-emulation/bochs/bochs-2.0.2.ebuild b/app-emulation/bochs/bochs-2.0.2.ebuild
index bb44aab27b11..7535999a176b 100644
--- a/app-emulation/bochs/bochs-2.0.2.ebuild
+++ b/app-emulation/bochs/bochs-2.0.2.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.14 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.2.ebuild,v 1.15 2004/06/27 23:01:44 vapier Exp $
inherit eutils
DESCRIPTION="a LGPL-ed pc emulator"
HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
- http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~ppc alpha sparc"
IUSE="sdl gtk"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
- sdl? media-libs/libsdl
- gtk? x11-libs/wxGTK"
+ sdl? ( media-libs/libsdl )
+ gtk? ( x11-libs/wxGTK )"
src_unpack() {
unpack ${A}
diff --git a/app-emulation/bochs/bochs-2.0.ebuild b/app-emulation/bochs/bochs-2.0.ebuild
index d01cfd3c22ea..ec33b0c318e7 100644
--- a/app-emulation/bochs/bochs-2.0.ebuild
+++ b/app-emulation/bochs/bochs-2.0.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.ebuild,v 1.8 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.0.ebuild,v 1.9 2004/06/27 23:01:44 vapier Exp $
-DESCRIPTION="Bochs is a pc emulator.
-This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
-CDROM drive. It also comes with a disk image using dlxlinux."
+DESCRIPTION="a pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
-HOMEPAGE="http://bochs.sourceforge.net"
+
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="x86 ~ppc ~alpha"
IUSE="sdl"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
- sdl? media-libs/libsdl"
-KEYWORDS="x86 ~ppc ~alpha"
+ sdl? ( media-libs/libsdl )"
src_unpack() {
unpack ${P}.tar.gz
- cd $S
- cp Makefile.in Makefile.in.orig
- sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
- -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
- -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
+ cd ${S}
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' \
+ Makefile.in
}
src_compile() {
@@ -38,9 +38,7 @@ src_compile() {
emake || die
}
-
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc CHANGES COPYING CVS README TESTFORM.txt
+ dodoc CHANGES CVS README TESTFORM.txt
}
-
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index b670c59bb523..b06ccd8f1f13 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.6 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.7 2004/06/27 23:01:44 vapier Exp $
inherit eutils
@@ -14,11 +14,11 @@ SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
IUSE="sdl gtk readline"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
- sdl? media-libs/libsdl
- gtk? x11-libs/wxGTK
+ sdl? ( media-libs/libsdl )
+ gtk? ( x11-libs/wxGTK )
readline? sys-libs/readline"
src_unpack() {
diff --git a/app-emulation/bochs/bochs-2.1.ebuild b/app-emulation/bochs/bochs-2.1.ebuild
index 446834bb504b..34ec72a6bbd3 100644
--- a/app-emulation/bochs/bochs-2.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.ebuild,v 1.3 2004/06/24 22:30:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.ebuild,v 1.4 2004/06/27 23:01:44 vapier Exp $
inherit eutils
@@ -14,11 +14,11 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc"
IUSE="sdl gtk readline"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
- sdl? media-libs/libsdl
- gtk? x11-libs/wxGTK
+ sdl? ( media-libs/libsdl )
+ gtk? ( x11-libs/wxGTK )
readline? sys-libs/readline"
src_unpack() {