summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-09-04 01:51:43 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-09-04 01:51:43 +0000
commit3b8a9dbe273a53f5da709e63876a142ae0a96fdb (patch)
tree1dd3f3cee9e90e85d87605d6c8772bbe14c13d29 /app-emacs/edb/edb-1.25.ebuild
parentversion bump (diff)
downloadhistorical-3b8a9dbe273a53f5da709e63876a142ae0a96fdb.tar.gz
historical-3b8a9dbe273a53f5da709e63876a142ae0a96fdb.tar.bz2
historical-3b8a9dbe273a53f5da709e63876a142ae0a96fdb.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'app-emacs/edb/edb-1.25.ebuild')
-rw-r--r--app-emacs/edb/edb-1.25.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/edb/edb-1.25.ebuild b/app-emacs/edb/edb-1.25.ebuild
new file mode 100644
index 000000000000..1cac76a7f40f
--- /dev/null
+++ b/app-emacs/edb/edb-1.25.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/edb/edb-1.25.ebuild,v 1.1 2005/09/04 01:51:43 mkennedy Exp $
+
+inherit eutils elisp
+
+DESCRIPTION="EDB, The Emacs Database"
+HOMEPAGE="http://www.glug.org/people/ttn/software/edb/"
+SRC_URI="http://www.glug.org/people/ttn/software/edb/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+SITEFILE="50edb-gentoo.el"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ econf || die
+ make || die # parallelism not supported
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dodoc AUTHORS BUGS COPYING HACKING NEWS PLANS README TODO
+ doinfo edb*info
+ cp -R examples tests ${D}/usr/share/doc/${PF}/
+}